Giffgaff issue FP3

I am trying to connect to the giffgaff 4G network (UK). The default APN settings that have been automatically installed by the giffgaff app are slightly different from the settings specified by giffgaff in their settings guide []. However, I am not able to manually edit these settings. I have tried setting up a new APN with the settings specified by giffgaff, but do not then have the option to select this network (no radio button appearing). Calls and text work fine. Thanks in advance for help resolving this!

In some cases the APN can’t be changed when a 4G link is in use. This can also be the case when mobile data is not actually active. To see whether this is what is happening, this might be worth a shot:

  1. Disable mobile data
  2. Set the preferred network type for the GiffGaff SIM to 2G
  3. Edit the existing APN or create a new APN with the desired settings and activate it.
  4. Set the preferred network type for the GiffGaff SIM to 4G
  5. Enable mobile data

Edit: Working settings for GiffGaff have been reported here:


I’ve just changed the APN type as suggested above and this seems to have worked - I am now connected to 4G. Thank you for your help!


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.