Data not working

Hi all, I have just received my FP3- I am in the UK and ordered it on contract from the co-operative phone company. I can’t start using my new Sim from the Co-op until next Tues when the phone number from my current Sim will have been transferred across. In the meantime I am using my old Sim (from Giffgaff) in my new phone. Phone calls, Wi-Fi and texts work just fine. However, I can’t use data.

I’m sure this is a carrier issue rather than a FP3 issue so have asked both co-op and Giffgaff for help but thought I would post here as well. Does anyone have any thoughts on the substantive differences between FP2 and 3 that might lead to my FP2 sim not working in the 3? So far I have:

  • ensured the APN settings are the same as they were in my fp2
  • turned off enhanced 4g LTE mode
  • Changed the preferrws network type to 2g/3g auto as fp2 didn’t have 4g

If I can’t make it work I’ll just switch back to my fp2 until Tues but thought I would see if anyone has any ideas first!



Could be that your GiffGaff SIM card is too old, see this resource:


I’m on a different network but having the same issue. The SIM from my FP2 (where data was fine) isn’t giving me any data on FP3. I’ve rebooted, tried turning the SIM off and on again, etc. Definitely in signal areas, phone and sms working great, wifi also working fine, but no mobile data. I’m on Virgin - i can look at getting a newer sim of course, but mine isn’t that old.

I got a new SIM from my network provider. It’s active, receiving calls etc, shows as “Virgin 4G” on the phone, but still mobile data doesn’t work. Restarted, turned data on and off, turned aeroplane mode on and off… Wifi works fine. So still stuck…

1 Like

Have you checked the APN settings.

  • Name: Virgin Internet.
  • APN :
  • Username: user.
  • MMS Proxy:
  • MMS Port: 8080.
  • Authentication Type: PAP. If you’re given a choice of APN types, select internet+mms, or if the keyboard appears, the * symbol.

If you use two SIM-cards, beware that only one SIM can be set to receive data.


Many thanks! I did another round with my network provider. The ‘automatic APN settings SMS’ never arrived. I manually entered all the APN settings from their site (not quite the same as yours!) and now it seems to be working!

thanks :slight_smile:


Hi, I have the same symptom here.
I’m a french user with bouygues telecom provider and I’m not able to make data working…
I’ve tried to :

  • update android (via wifi) : OK
  • reset APN informations
  • tried with a different sim

More informations :

  • about phone > SIM 1 state > Network Mobile State : disconnected / Offline
  • sms and phone calls work fine

If anyone can give me more ideas on this one…

Hi, Virgin customer here too. Have you managed to solve this?

Welcome to the community forum.

Please confirm you don’t see the answer to your question only 2 posts further down from the post you are answering to, in a topic of currently less than 10 posts :wink: .

1 Like

Hi there,

I have the same issue with my Giffgaff SIM. It is working perfectly in other Android, iOS devices but on my new Fairphone 3 only receives/makes calls and texts, Wifi is ok but data is not working. On the other hand, data is working fine with my other Vodafone SIM when I set it for data use on the Fairphone. So far I have:

  • List item Set the Giffgaff SIM (the one I’m using data with) for 4G network type, and set the other SIM for 2G only, with Cellular data for the Giffgaff SIM.

  • List item Created a new APN with the settings given by Giffgaff in

  • List item Tried to manually select networks between the available (non forbbiden ones), such as Sky, giffgaff etc

  • List item Turned on/off the phone, airplane mode, etc.

I don’t know if I am supposed to switch from one APN to the other or if just by creating them should work (right now I have both of them in the APN section). Nevertheless, I cannot forget or delete the default APN (with the incorrect settings). The Giffgaff SIM is three months old.

One of the SIM-cards I use in my Fairphone 3 is from Giffgaff as well, and I had the same issue (calls and texs work but no mobile data). The APN settings that were made automatically seem to be incorrect, although I can’t claim I understand enough about that to say what exactly was wrong. I believe it was adding DUN (yes, uppercase) to the APN type list that finally made it work. I left the default APN untouched, created a new one from scratch and used that.

See screenshots of my settings below, working with a Giffgaff SIM card (approx. three months old as well) in the UK.


Hi @linusg, I was having the exact same problem! Tried adding DUN to the APN list as you show and now the data is working fine! Thank you very much :slight_smile:


I found all the automatic systems from Virgin failed, so in the end manually entered detailed settings for ‘APN’ etc, rebooted, and it worked fine. I used this site:

good luck!

Thanks @linusg, this worked for Giffgaff on myFP3 too, thanks a lot! Just to add, if you want MMS to work I think you need to add the MMS proxy address from to the new APN.

Thank you! I had the same issue and this fixed it immediately