FP3+ no data since changing sim from giffgaff to giffgaff

Two days ago I switched to a new sim (giffgaff to giffgaff) due to problems with battery drain and speaker (changing sim was advice from fairphone support).

Changing sim solved the battery drain and speaker issues, however now I cannot connect to data, which was never a problem before. Calls and texts still working ok.

I’ve tried:

  • Changing APN settings using this advice among others.
  • Swapping with an iphone’s giffgaff sim: The iphone had data using my sim, while my FP3+ had no data using their sim!
  • Putting the sim in slot 2: Mobile data icon wouldn’t even turn on so I couldn’t explore further.
  • Restarting the phone after every change.

Any ideas appreciated, thank you.

1 Like

If it wasn’t for the hassle of backing up your data and re-installing apps, I might have suggested resetting device to factory settings and try starting from scratch with Giffgaff in SIM 1. Whilst no data upon device might be worth resetting and also trying initial set in SIM 2 slot.

Could you put both SIMs (yours plus another) in the FP3 and check what happens then? Is there something in the settings called “always ask”? This setting def exist for calls and SMS when using dual SIM however there are a very few reports for german SIM cards, where there seem to be this setting for mobile data as well (Normally this setting does not exist, so might be a strange bug)… So if yes, change to your SIM and it will hopefully work still when the second SIM is taken out again.

Thank you for your suggestions.
I tried inserting both sims at once and both did not connect to data.
I also tried performing a “manual roam” - still data not working.
So looks like I will backing up in preparation for reset.

Since you changed APN settings and both SIMs won’t connect to data now, did you also try to reset them?

1 Like

Did you check if there is a always ask feature? So what exactly happens when you change mobile data from one to the other SIM (normally it should not be possible to enable for both). Above you linked to a topic from 2.5 years ago, reg the APN settings, did you ensure they are still correct? Did you check with GiffGaff? Any chance to test a SIM from another provider?

Yes I tried resetting APN settings and using the automatic settings

When I have two sims in the phone, in order to use data I go into network settings and select which sim to use for data. I tried each sim consecutively, with no improvement. There only seems to be an “always ask” feature for making calls and sms (I get asked automatically which sim to use to make a call), but I did not encounter anything like this for data in the settings.

Yes, I used the giffgaff guide, and when that didn’t work I tried all the variations I could find on the giffgaff and fairphone forums.

I posted on the giffgaff forum.

Well… ultimately I want to stay with giffgaff, so reluctant to go through process of getting sim from another provider unless I have reason to think it will help… resetting the phone seems easier :grin:
Until 3 days ago, this phone was connecting to data perfectly with an older giffgaff sim.

1 Like

This was just mentioned to see what happens, so to see if its a GiffGaff or general issue with your phone, just to troubleshoot further, not to change network provider.

Yes dw I didn’t think you were suggesting changing provider :blush:

1 Like


I left mobile data on all day. In the afternoon, I noticed the data signal on (switching between LTE and 3G, but mostly LTE). I tried accessing websites and… it worked!

There is a rather odd data usage pattern (10.28MB used in a matter of hours, and just 2MB in the last few minutes). “ConfigUpdater” is using most of the data. I’m attaching a screenshot if this is of interest.

I’m interested in ideas about what’s going on, although I’m hopeful it’s going to be steady improvement from here onwards without needing to fix anything :crossed_fingers:

Here an explanation what this system app is doing

Not sure if the data use is normal

1 Like

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.