Getprop /setprop / system locals


I’m using tasker to read Mails, Texts, Messages etc while driving, to answer them etc, I also use it for quite a lot of other stuff, for instance to tell me when to leave work (because I’m working overtime if there’s no external reminder of me having a family -.-)

Ok. Here’s what happend: I let Tasker read everything in German since it’s my mothertongue. That worked till last saturday or sunday very well. Then Tasker began to read everything in american english when read first, when repeated, Tasker read everything in German. I first guessed an issue in Tasker and I’m still not sure. I will put that in the tasker forum, too.

I used the shell command getprop persist.sys.local and it says “de-DE” which is German. Then I used getprop ro.product.local which gave “en-US”.

Now: Is it possible that the differences in sys.local und product.local are somewhat responsible for what Tasker does? If so: Is there a way, to change that without (would be nice) rooting the device? As far as I know setprop needs root.


Hi Mike, I have not real idea or answer, just reading a comment in the play store that someone had/has language issues caused by the recent Google Speech Services update? Probably its worth to contact the app support?

Let me guess… the update came say friday/saturday night? Thank you. I check…

In the settings under language and “Sprachausgabe” you can select system language or change to German, could that help for the time being?

Ok… well… very well… oh my :nauseated_face: :face_vomiting:

Nope. That changes nothing. But what I found yesterday is, that en-US is installed as a language and I can’t remove it. I can remove any language from the system, but not en-US. Seem you hit the jackpot.

I’ll check that back within the tasker forum. Thanks.

Ok. You’re right. Speech Services is…

For anyone having the same issue, here is one(!) work-around. Not my idea. Cudos to the more intelligent ones.

Google Groups / Tasker / Language Problems


Second solution: Make an Rollback and uninstall all Updates.

Works very well.


Doesn’t work anymore. The upgrade broke the rollback solution