English

🇩🇪 [gelöst] Update Lineage auf 16.0

Hallo,
ich benötige eine Anleitung, wie ich mein FP2 von LineageOS 15.1 auf 16.0 updaten kann. Dazu auch, woher ich die nötigen Dateien kriege. Ich will auch weiterhin die Google Apps nutzen.

Dass ich alle Daten sichern muss, ist klar. Ich glaube allerdings, letztes Mal seien die Daten erhalten geblieben (beim Upgrade auf 15.1). Das wäre jetzt natürlich auch wünschenswert.

LG
Micha

1 Like

Hallo Micha,

hier gibt es die Anleitung:

https://wiki.lineageos.org/devices/FP2/upgrade

Hat perfekt geklappt. :slight_smile:

Viel Erfolg!

1 Like

Danke! Beim Download steht überall, dass das nightlys sind. Ist das normal/war das bei 15.1 auch immer schon so? Oder kommt da demnächst eine stable Version?

Danke,
Micha

Inzwischen stehen fast täglich Updates zur Verfügung (ist immer ein Vollupdate, deshalb kann man problemlos welche auslassen und braucht dann später nur die dann tagesaktuelle Version updaten), die laufen dann immer unter der Bezeichnung “nightly”. “nightly” ist also jetzt quasi der Standard.

Im Namen war es schon immer “nightly” (im Gegensatz zu “unofficial”): https://stats.lineageos.org/model/FP2

2 Likes

Danke euch! Dann werde ich mal mein Glück versuchen… Vorher noch Akku aufladen…

Micha

Zip-Signatur kann nicht bestätigt werden. Was nun?

Micha

Aktuelles TWRP installieren … https://twrp.me/fairphone/fairphone2.html.

Hm, laut PlayStore habe ich die aktuelle Version. Die ist aber von Januar 2019.
Im von dir verlinkten Text steht, die neuste Version sei vom 19.5.2019. Aber wo kriege ich die nun her? Der Link " No Play Store? Download the latest version here." liefert mir nur Versionen bis 2017.

Das Ganze scheint komplizierter zu sein als gedacht…

Herzliche GrĂĽĂźe
Micha

Der Link ist Teil der “App Install Method” … es stehen noch “TWRP Install” und “Fastboot Install Method” zur Auswahl :wink: .

Lieber AnotherElk,
danke fĂĽr deine Geduld. Ich habe jetzt das ImageFile gefunden und wollte es mit der Fastboot-Methode installieren. Aber ich erhalte eine Fehlermeldung:
FAILED (remote: image is not a boot image)
Für heue muss ich wohl aufgeben. Aber ein weiterer Tipp wäre nicht schlecht.

Micha

OK, md5 stimmt auch nicht.
Aber auch erneutes Herunterladen hilft nicht. Ich erhalte immer eine 6,76 KB kleine Datei.

???

Micha

Einfach mal mit links draufklicken und nicht mit rechts und “Ziel speichern unter” die HTML-Seite speichern, wo’s sonst die Datei gegeben hätte :wink: (Ok, reine Mutmaßung anhand der Dateigröße).

Image-Datei gibt’s hier: https://eu.dl.twrp.me/FP2/twrp-3.2.3-0-FP2.img.html
(Hab’ mal die 3.2.3-0 verlinkt, die ist am pflegeleichtesten.)

Ja, stimmt, das ist eine HTML-Datei. Aber wenn ich mit links klicke, passiert da gar nichts.
Doch, jetzt mit anderem Browser probiert, da klappt es. Ich kriege nur eine Warnung, dass img-Dateien Schäden anrichten könnten. Vielleicht wurde der Download darum blockiert…?

Danke, jetzt kann ich weiter probieren.

Micha

Ich glaube, jetzt habe ich ein richtiges Problem…
Ich habe die lineage-16.0-20190523-nightly-FP2-signed.zip per sideload installieren können.

Wenn ich direkt anschlieĂźend nun die GoogleApps installieren will, dann erhalte ich die Meldung
This GApps pkg is for Android 9.0.x ONLY. Please download the correct version for your ROM: 8.1.0 (SDK 27)
Ich dachte, ich hätte gerade Android 9 installiert?! Und neu starten darf ich laut Anleitung zwischendurch nicht…

Micha

Zum Nachvollziehen: Wie heißt die Datei genau, und wo gibt’s die?
(Nutze selbst LineageOS for microG, also ohne Google Apps.)

Edit: Hab’ gerade zum Testen mit TWRP lineage-16.0-20190523-nightly-FP2-signed.zip und open_gapps-arm-9.0-pico-20190523.zip installiert … keine Fehlermeldung beim Installieren, bootet ohne Probleme, Google Zeugs ist da (Open GApps pico ist das minimale Paket, um den Play Store nutzen zu können).

Edit2: Allerdings habe ich vorher das Testgerät komplett gelöscht (wie hier).

Der Datei heiĂźt open_gapps-arm-9.0-mini-20190523.zip und kommt von hier https://opengapps.org/?api=9.0&variant=nano0.

Das Löschen der Daten möchte ich aber vermeiden, ich habe zu viel drauf und eingerichtet.

Kann es sein, dass ich genau die gleiche Google-Version benötige wie ich vorher hatte (einmal mini, immer mini)? Das weiß ich nämlich nicht mehr, was ich da hatte. Die Fehlermeldung sagt ja aber etwas anderes.

Ich probiere es später nochmal, jetzt muss ich erstmal arbeiten.

LineageOS 16.0 basiert soweit ich weiĂź auf Android 8, also musst du auch die Open GApps Version fĂĽr Android 8 und nicht fĂĽr Android 9 herunterladen. So verstehe ich auch die Fehlermeldung. Funktioniert es dann vielleicht?

Nein! Lineage 16.0 entspricht Android 9.0. Zeigt es bei mir (LOS 16.0 ist installiert) auch an.

2 Likes

Was mir noch nicht klar ist: Wenn ich mich nach der Anleitung richte, bleiben dann meine Daten, installierte Apps und deren Einstellungen erhalten?