🇬🇧 🇩🇪 Random reboots with (official) Lineage OS?

no, it does not yet. :slight_smile:

Ask me something easier. Maybe still from the old Android 6?

You should get a dmesg from the running android system, not from twrp :slight_smile:
Chris

1 Like

I switched back to the first boot.img and created a new dmesg_08112017.txt and uploaded it.
now switch to second boot.img :slight_smile:
-> first boot with second image rebooted my phone. uploaded new last_kmsg_08112017.txt file. :slight_smile:

is there any news for me? :smiley: Hardware broken or something else?

You seem to have a lot of issues with your sdcard? Could you remove it and see?
Chris

Yes, I’ll take it out again.

So, reboot without sdcard. I have the latest last_kmsg_09112017 file uploaded.
Internal error: Oops - BUG: 0 [#1] PREEMPT SMP ARM? :smiley:

StevenHachel,

Chris

PS: If you get bored, let’ me know.

  • Adiutor is deinstalled.
  • Before I installed lineage, I did a factory reset.
  • yes, i flash this image. :slight_smile:

Steven

(First post after months of “forum abstinence”…)

One of the last_kmsg’s indicates that your (Apple?) router offers two WLAN’s, because the MAC addresses listed are almost the same, just slightly different.

Does your Fairphone 2 connect to a 5 GHz WiFi hotspot? Maybe other (Lineage OS) users do not experience this behavior because they are using the 2.4 GHz band…

1 Like

I’m using the 5 GHz band at least at home, didn’t check what band is used elsewhere … no problem so far.
(And welcome back :slight_smile: )

1 Like

Whether it is now a 5GHz hotspot, I would have to look at the company tomorrow. But it is true that it crashes in the company very often and hardly at home.

2 Likes

Be aware that in LineageOS there is no setting anymore to disable any WiFi band in case this would be the culprit … thanks would go to Google …

So to troublecheck you would have to change the settings on the hotspot side or deliberately connect to a 2.4 GHz network (if the hotspot offers both).

2 Likes

Wow. I expected exactly the opposite, because usually realizing a good coverage of 5 GHz hotspots should be more expensive than with 2.4 GHz.

Reading one of your logs it seems to me that your Fairphone establishes a connection to one (2.4 GHz?) network of your router first, then another (5 GHz?) network of the same router (assumed according to the very close numbering of the two MAC addresses) pops up … and :bomb: !

Maybe this crash/reboot only occurs when both WiFi bands (2.4 and 5 GHz) are available and offered by the same router. Also the respective SSID names of the two networks might have an impact if they are the same. Unfortunately I cannot verify this, since I do not have a Fairphone 2 here to check things out…

(Thank you! :slight_smile: )

That could well be, but my router at home offers both bands using the same name, and occasionally my phone connects via the 2.4 GHz band instead, also without problems, I should have mentioned that.

1 Like

Since @StevenHachel (probably) is using a router from Apple, the default topology (802.11?) could be another than yours. It would be interesting to know if a) this is the case and b) it is possible to change it.

@StevenHachel : Which router model was your Fairphone connected to when it crashed?

It’s definitely a router from Apple. Can not tell you whether 2.4 GHz or 5GHz. Do not come without my admin to the data. Only on Monday again.

At home I have a Fritz box of AVM with 2.4GHz. I rarely crashed there. Mostly when the phone gets too hot from playing games. :slight_smile:

@edit the apple router has only 2.4GHz.

1 Like

Thank you for the information. It seems the Apple router in your office is offering two WLAN’s, but that is something which might not affect your system.

Instead, please ask your IT which type of Apple router you are using in your office, and - probably more important - which topology (802.11b, 802.11g, or 802.11n) is available. Then, maybe @chrmhoffmann can/would like to do further research to find out if this setup is causing an issue with Lineage OS.

Oh … then I might have a quite simple explanation for the crashes you experience in your office: You play games at work excessively! :grin:

1 Like