🇬🇧 🇩🇪 German Simyo SIM shows roaming in Germany

Hi

I’ve got my fairphone in August 2014 and I have been very happy with it. I live in Germany and have two SIMs (a Simyo and a Telekom) and it was nice that I could use both in the same phone.

Since 1st of April however, the Roaming icon for the Simyo SIM card is present and my fairphone tells me I’m roaming, specially when calling or activating the 3G network. I know that german networks are not that strong and specially when you are near the borders you might see the foreign networks but I live in Freiburg and that’s not near any border so that this would upset my phone. Besides, since I’ve got my fairphone this has not been an issue at all. And the Telekom card is not showing this behaviour.

If I manually select a “simyo 3g” network then the roaming icon disappears for a while and then it reappears after a couple of minutes. I checked my card with my old samsung galaxy but it didn’t show this behaviour. I even started with the fairphone without the simyo card, swapped the slots… it is always roaming.

I haven’t done any firmware updates (still on Cherry 1.6) so it seems strange to me. What is going on? Does anybody (german with siymo card) else have this issue?

Did you check this post:

And this one:

? Does any of the solutions provided help you?

Hi Stefan,

selecting manually only helped for a couple of minutes. I’ll try entering an own PLMN later.

Thanks

I have another question related to this: the fact that my phone shows me roaming right now doesn’t mean I get extra charged for roaming, does it? Does my network provider also think that I’m roaming?

No it shouldn’t. @kgha, for instance, reported that they lived with the roaming notification for some months and didn’t have problems with charges.

You could of course check with your operator Simyo directly to see if they recognize your phone as being in the national network, just to be on the safe side.

Hi Stefan,

I looked online the PLMN values for German Simyo and I got the value 26203. So I went to Settings -> Mobile Networks -> Preferred networks -> Simyo and I got a long list of networks. Then I clicked on NEW PLMN, where I entered the value, I left priority = 0 (or should I use 1 instead? I assume that the smaller the number, the greater the priority) and in Network Mode I chose Dual Mode. I then clicked on the settings buttons (the button left from the HOME button, I don’t know how it’s actually called) and a menu poped up: Save / Cancel. I selected save. I expected a new window where I could put the name, but I didn’t get anything, the list with the PLMN was displayed instead.

I couldn’t find the entry with the 26203 entry either. After telling the phone to automatically select the network, the roaming symbol disappear. But after a while (this time more than an hour later) roaming came back :frowning: and the phone kept switching between local network and roaming. Did I miss something with the PLMN list? Where exactly is this list saved? On the Telekom card I get a completly diferent list.

then that’s fine, as long as I don’t pay more I don’t really care.

I already did, but the answer I got was just an standard answer explaining me what roaming is.

Thanks

Simyo uses the Eplus Network. Eplus and O2 have agreed on joining their networks (I think data only) so as to have better network coverage. As far as I know it’s shown as roaming.

2 Likes

Hi

that’s interesting, do you know since when eplus & O2 joined the network?

Seems to have been middle of march. Found this: http://www.teltarif.de/e-plus-o2-national-roaming-umts/news/59031.html

My guess is that a permanent solution requires that new network IDs (changing when networks merge) must be added to the FP OS in the next update.

When I (and a number of other users) had this issue a year ago, FP support asked for my network data. Using the app “Sim Card” from gsmdev (in the PlayStore) I grabbed the following:
SIM operator code
SIM operator name
Network operator code
Network operator name
and sent to support.

For me, the SIM operator code and the network operator code differed. which of course was interpreted by the OS as roaming. This was solved with the 1.3 OS update.

Maybe it would be a good idea to send the information for your SIM/network to support and ask the developers to take it into account.

Id you are quite sure that the roaming warning is false, you can disable the ‘R’ symbol with GravityBox, a module for the XPosed framework.

1 Like

I think @Samuel_Roberts nailed it.

On April 1st, the O2 (who bought EPLUS) activated internal roaming between the two 3G networks. On the long run, they will probably join these, but for now this solution should give you better reception and speed.

1 Like

Hi,
it could be you have a “Dual IMSI”, it’s something some operators use to offer roaming when traveling without having to test all operators.
I would not be surprise Simyo use this system.
Your SIM has two identifiers:

  • the one of Simyo , to be used when you are in the UK
  • the one of another mobile operator, to use when you are abroad.
    Your phone should automatically switch to the local identifier when you are in the Germany, but it seems its not the case, try do it manually:
    look into your “SIM menu” there should something called “roaming” and change the settings from there.
    I cannot be more precise because it depends on your operator, how they have done the menu.

I wrote a post on this, which can be found here:

https://forum.fairphone.com/t/falsche-roaming-warnung-in-deutschland-seit-april-2015/5468?source_topic_id=5406

It’s a wiki post, please consider improving it! :slight_smile:

1 Like

Bei mir bewirkt das Roaming leider auch, dass ich nicht mehr auf das Internet zugreifen kann.
Kann mir da jemand helfen?

Habe einen Vertrag bei “Klarmobil”, einem Billig-Anbieter, der das O2 Netz nutzt.

I was in contact with simyo today, they are a eplus provider.
If you have problems using data, their advice was to manually select simyo.

Btw. This also affects other devices, for example dual sim devices from Acer (using Mediatek as well).

:de: Also, wenn du Probleme mit dem Internet hast, solltest du deinen Anbieter manuell auswählen. Wenn das nichts hilft, kannst du nachschauen, ob Daten-Roaming für deine SIM-Karte aktiviert ist. Geh zu Einstellungen > SIM-Verwaltung > Roaming > Daten-Roaming und aktiviere das Häkchen bei deiner SIM-Karte.

:gb: If it doesn’t help, see if data roaming is activated for your SIM. To do so, go to Settings > SIM Management > Roaming > Data Roaming and check your SIM card.

2 Likes

Alles klar - so funktioniert es :wink:
Vielen Dank!

Thanks - that worked!

2 Likes

Hallo zusammen, da man leider auf den Wiki-Beitrag nicht antworten kann poste ich meine Frage jetzt hier: weiß jemand, ob sich dieses Problem irgendwann beheben wird? Bei mir schlägt das angebliche Roaming wohl leider auch auf die Akku-Laufzeit durch (so wie beim “echten” Roaming auch). Es ist schon ein bisschen lästig. Aber auf jeden Fall danke für den Hinweis, ich war zur Zeit der Umstellung ausgerechnet im deutsch-schweizerischen Grenzgebiet unterwegs und schon völlig verwirrt wegen des dauernden Roaming-Hinweises auch nach der Rückkehr :wink:

:de: Wir hoffen, dass die neuen Netzwerk-IDs beim nächsten Fairphone Update dabei sind. @Chris_R hat das auch schon an das Fairphone Team weitergeleitet.

:gb: We hope that the new network IDs will be included in the next Fairphone Update. @Chris_R has already forwarded this to the Fairphone Team.

4 Likes

hallo,
ich nutze auch fairphone FE in Deutschland und habe als primäre karte eine yourfone(e-plus) und als sekundäre eine vodafone.
Habe aber genau die selben probleme mit der roaminanzeige.
soll die irgendwann mal verschwinden? Mich nervt es einfach. egal ob keine gebühren anfallen stört mich das R über meiner anzeige

1 Like