English

Front facing 3+ camera colour cast

I received the FP3+ on Monday and I have just noticed that I had the same problem… I also hope this can be solved without having to change any part.

3 Likes

I have the same problem with a brand new FP3+.

1 Like

Exact same problem here with FP3 and both new +modules. My workaround is to use the Nikita GCam port and activate the “Google AWB” funktion. Then all colors turn out fine as they get automatically corrected.

7 Likes

Same problem here as well, and indeed Nikita’s Google camera port fixes it with Google’s auto white balance set on in the settings.

@BertG do you really think we all should contact support? As I’ve found this workaround, I wouldn’t think it’s worth it (as well as with other issues which have a workaround like the muted microphone that can be reset with a reboot), especially knowing the support is overwhelmed since Android 10 Update and FP3+ release, and they’re working on software updates anyway…

3 Likes

True of course.

On the other hand, they do need to know how big or widespread the problem is and if maybe just a certain batch is affected. For that they would need numbers and reports as accurat as possible.

A workaround is always good to have and I really love this community and it’s inventiveness.
It’s absolutely perfect for the techie and the enthusiastic community.
Still, for the mass market, that’s not gonna work (at least in the long run).
As quite a few threads by now show, there are more frustrated users out there, than can be considered desirable. Most likely for deciding how to react, Fairphone will need to know the severity of the problem. Once it affects a certain percentage of users, they might want to address them by mail with an apology, a status report and a hint to the workaround.

Well, at least that’s what I thought, when I asked everyone to report the troubles.

3 Likes

Instead of contacting support I’ve added this bug to the List of bugs with Android 10.
Does Fairphone team know about it? If not, maybe @rae could transmit it to the dev team…
BTW could we make a poll of this list (while still being an editable wiki?) to show the extent of who has which problem to the dev team? I can’t put the suggestion in said topic as it is closed…

1 Like

I noticed this problem as well when I installed the front camera, then removed and reinstalled it and finally gave up - using Googles AWB (= Auto White Balance) instead. I wasn’t sure if this was normal behaviour with artificial light conditions, so I didn’t add it to the bugs list back the - but the comparison with the rear cam shows it’s indeed a bug. Having to use the sideloaded GCam can’t be considered as a workaround, in my opinion. And as GCam has the same problem if you don’t turn on AWB, I guess it’s a hardware rather than a software issue. :frowning:

Does Fairphone team know about it?

I raised it with support on 15th Oct. It’s been ignored so far.

I wouldn’t consider this a hardware issue solely based on this. In fact, if it was a hardware issue, I think it would probably affect all photos, not just the ones with artificial light… But this all guess here, I’m no expert, maybe I’m wrong…

EDIT: On another hand, it appears in all 3 photo apps I have (Standard camera app, Nikita’s Gcam & Open Camera). So it might indeed be hardware related…

4 Likes

I guess it your mail has not been answered. Though this definitely should have happened, it doesn’t have to mean, that they ignored your hint.

To make sure, that edits to the bug-report wiki will reach Fairphone, I have invited/linked the forum-representative Rae to this wiki.

1 Like

Hi @pcm, I have shared this issue internally. Thanks for flagging it. I will loop back as soon as I have an update.

9 Likes

My theory is that this new front camera reveals the hidden truth: we live in the Matrix!

6 Likes

I have to revise my solution:

My workaround is to use the Nikita GCam port and activate the “Google AWB” funktion.

It is not a satisfactory solution. And that’s because sometimes it’s simply not possible to just use the GCam port. For example when I want to shoot a selfie from a messaging app in order to send it off instantly: Then there’s no color correction and my greenish face looks terribly sick in the photo. And even worse: When I use the front camera for a video call or a video conference, there is no opportunity to correct the colors. I always send greenish video which is absolutely not desirable. I paid quite some money for the new camera and it seems to have a general fault. That is really annoying and should be fixed by Fairphone as soon as possible.

2 Likes

Update on my journey with support:

They asked me to update to the latest OS version: v.054 (Build number 8901.3.A.0054.20200929) and clear storage/cache for the camera app. I tried this with no effect.

They also suggested I tried a different camera app (unclear why Fairphone would think this would cure it), which I tried but with no luck.

I was then asked for proof of purchase, so it’s not sounding like they have a fix at this point. Very disappointing / frustrating.

1 Like

Hi, same problem here with a FP3, and reported to support.

Support told me to perform a routine of steps and see if the problem gets fixed. I pointed to this thread, but they insists in to do all the steps. Now I’m in the “factory reset” step, which I anyway will do because the last update (october) put on my FP3 a persistent notification of a network operator that I don’t use.

3 Likes

camera records yellowish with light

https://i.imgur.com/Er3CkOg.mp4

some tweak to fix this? thank you :slight_smile:

I moved your post here as it’s a known problem, and I don’t think there is a great difference between yellowish and green. Please have a look around :slight_smile:

I just upgraded my cameras, same problem. The rear camera is friggin awesome but the front is green. I’ll send in a bug report to help communicate the scope. Hope it’s a setting or worst case a bug fix.

To be useful: does anyone know if the camera generates a data log that we can submit with the bug report.

Another thing of note: after the upgrade, my phone’s date was wrong, the wlan was buggy and a few other small things seemed cleared or slightly off. I restarted and everything seems to be better now.

Oh and PSA: I didn’t use the Fairphone screw driver but my own jeweler’s tool with a wide grip. Yeah, I def overtightened 3-4 screws on the camera modules. Be careful! The screw heads are supposed to just sit on the plastic, not go into it! There is not much surrounding plastic on the modules so it can easily deform! If you’re unsure if they’re in far enough, look at the other side of what you’re screwing in and you’ll see the nut that the screw goes into. The screw shouldn’t peek outside of the nut, and definitely shouldn’t stick out above the plastic!:v::sweat_smile::nut_and_bolt:

3 Likes

Me and my mother have exactly the same problem, the front camera is greenish under LED light. Is there already a solution? @pcm do you still have the problem?

2 Likes

Same here. I’m looking like Hulk during WhatsApp video call…

3 Likes