Freezing widgets

I don’t know if anyone is experiencing similar problems with widgets and have not found a post about this yet.
I do have a few widgets on my first page, which often “freeze”. One is a calendar-widget (Calender Widget+Status FREE from evozi) to show my appointments and a notes widget (ToDiList widget from F-droid). After a restart of the phone they work just fine. But normally after a few days they stop to work properly. But they do not have a clear behaviour.

  • Calendar
    Sometime it does not react at all if I touch it. Then the date of the calendar also freezes. Often the date is adjusted, but I can not switch between months. So it does not react only partly. After a restart everything is fine.
  • ToDoList
    Ofen I want to add notes, and the editor opens. I make changes like new notes or delete old ones, but after closing the editor the changes are not shown. When I open the editor again, the changes are there. So it saves the changes, but does not transfer them to the screen. When I do a restart of the phone, the changes are shown normally and for a certain time changes are directly applied.

This really confusing. I have also tried different widgets, and it always the same! Before I had crushr from F-droid, which I prefer to the one I have now, but switched because I blamed it on the app. I thought the calender thing might be a problem, because I am missing updates, but it is the same with F-droid widgets with proper updates. I had the problems in Lollipop and still in Marshmellow. Of course I have tried to reinstall the apps, but with no success.

I general I have the new FP open 17.06.4 (Marshmellow), Xposed, XPrivacy, GravityBox, MicroG, no encryption.

Any ideas or similar experiences?

Thank you for the detailed description of the issue! My guesses:

  1. Any permissions denied with Xprivacy?
  2. Do you have Autostarts from F-Droid installed? That app let’s you disable some features of widgets.


  1. For notes I have no permission denied except “identification”. This should not hinder the function.
  2. No, I have not installed Autostarts.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.