FP4 without OS is locked

Hi there,

I installed last year /e/OS on my FP4 (I’ve had unlocked it) and everything went well.
Today I wanted to install LOS 20 instead /e/OS and everything went very bad !!!

I do not have any more OS on the phone … I’ve got only “Recovery screen” and screens of LOS for ADB and Fastboot, and my phone is locked again.

So I don’t know haw unlocked it without OS !

Any ideas ? help ?

$HOME/Téléchargements/platform-tools_r34.0.5-linux/platform-tools/fastboot flashing unlock

My result is:
FAILED (remote: ‘Unrecognized command flashing unlock’)
fastboot: error: Command failed

Maybe your FP4 is not in the correct fastboot mode. Have a look at this topic:

My FP4 is in fastboot mode of LineageOS

Ok. And I assume you did follow my link and read all the 14 posts there, right?

I did read in diagonale as we say in french and I didn’t see similar pb since My phone is lock and I can’t find out to unlock it. I checked my cable, version of ADB , version also of LineageOS, etc.

what point do you think would help me in this post?

That the user received the same error message as you

Then mentioned this fastbootd menu:

And after this comment

finally noticed that the phone had been in the wrong fastbootd menu, which solved the problem and the fastboot command finally worked:

Yes, thank’s, I did notice all these points, but on my phone I’ve got LineageOS tool (like TWRP) … I’m going to carry on tries and tries …

Are you referring to this one?

yes indeed

That’s perfect! Then select “Reboot to bootloader” (twice “vol down” and then “power button”) and wait for “bootloader” to start.
As soon as the “bootloader” (the “other” “fastboot” mentioned in the topic above) is started, then please reissue your fastboot command.

1 Like

I understand know what you meaned but I always got the same pb, my phone is always lock.

fastboot flash recovery recovery.img

Sending ‘recovery’ (98304 KB) OKAY [ 3.416s]
Writing ‘recovery’ FAILED (remote: ‘Flashing is not allowed in Lock State’)
fastboot: error: Command failed

Ok, the necessary command in this moment would now be…:

$HOME/Téléchargements/platform-tools_r34.0.5-linux/platform-tools/fastboot flashing unlock

in my “first fastboot mode screen”

fastboot flashing unlock

< waiting for any device >
(… and nothing happen …)

in my “second fastboot mode screen (lineageOS”

fastboot flashing unlock

FAILED (remote: ‘Unrecognized command flashing unlock’)
fastboot: error: Command failed

You’ll only be able to unlock your device in the “first fastboot mode screen”!
So if you get <waiting for any device" then your phone is not correctly recognized and you can just try

  • to fix your drivers
  • to use other cables
  • to use another USB port
  • to run the command as sudo

Or you have a look at these search results:


And it’s really true that the flash command mentioned in this post

worked, but the flashing command mentioned here

leads to < waiting for any device >?

Can you please double check that?

So I stay in the “first” fastboot mode screen
Now I’ve got the follong error message (with SUDO or not)

fastboot flashing unlock

FAILED (remote: ‘Flashing Unlock is not allowed’)
fastboot: error: Command failed

Oh, then I’m very sorry, but it doesn’t look good… :frowning:
You’re now probably here:

What you might try now:


fastboot flashing get_unlock_ability

I’m afraid it will show “0” (which means OEM unlock is disabled and that’s why unlock is not allowed…)

You can only enable “OEM unlock” if you can boot your system.
So did you already check all ways to boot your LineageOS installation?
I assume you already tried a “factory reset” and test if LineageOS boots then?

If you do not manage to enable “OEM unlock” then you’ll probably have to contact FP for a repair at Cordon repair service…

fastboot flashing get_unlock_ability

(bootloader) get_unlock_ability: 0
OKAY [ 0.000s]
Finished. Total time: 0.000s

I just undestand it’s a bad news, right ?!
I didn’t installed LineageOS. I had /e/OS and I begun the procedure to install LOS ans when I restart my phone I’ve had the pb !!!