Is something wrong with the bootloader partition of my device

To start this out. I have unlocked bootloader through various methods on many diffent devices befor. I have followed the guide on the fairphone website to the letter including the fastboot commands that should be used if the regular ones do not work.

To the problem i got myself an unlock code and activated oem unlock in the developer settings, so far so normal. Upon entering fastboot and trying to use the normal commands i get:

C:\Program Files (x86)\Minimal ADB and Fastboot>fastboot flashing unlock

FAILED (remote: Unrecognized command flashing unlock)
finished. total time: 0.002s

So can anybody help me with this one. Is the bootloader not unlockable and if so why is there already a bootable version of TWRP if i cant even get it into the memory.

Bootloader is sure unlockable :wink: i doing it without problem on Linux using this official howto:

in Windows maybe look again to section about install all drivers, install right adb, going to right installed dir (if you have other/older adb installed in different location, make sure in right dir using ./fastboot, because fastboot i think use binary from %PATH% where maybe you have wrong version)…

BTW: about TWRP - not tried, i unlock bootloader (on FP5 and also on my two previous AndroidOne phones) only for making root with Magisk, not for TWRP or alternate ROM’s …

does “fastboot devices” make a correct answer?
If yes: perhaps the cable is unsuitable?
If no: telephone and computer don’t know each other yet!?

Booting and installing are different things. TWRP can be booted (fastboot boot …). But you don’t need an unlock for this?

Thank you for the answers.

That is the “the guide on the fairphone website”.

I always do something equivalent to that if it is even required because my fastboot came with an cmd here exe.

I have adb fastboot on my laptop is because I wanted to flash something on my lg v20 and I was to impatient to wait until I got home so it has been tested recently. And I also just reflashed twrp 3.7.0 on us996 to make sure no space radiation came down and switched a transistor or something.

“BTW: about TWRP - not tried, I unlock bootloader” sorry I dont understand what you mean here and I dont want to miss any possible solutions.

Yes something fastboot.

The cable is the same one I have used for 4 other devices over the course of the last (I think) two years. It is a fair question as I have cables that dont want to cooperate but they get gifted away rather quickly.

Yes and I have told to remember it for next time.

Yeah thats what this part “a bootable version of TWRP if I cant even get it into the memory.” was about. To be fair I didnt know it until I read it in the guide of the Fairphone developer.

If “fastboot devices …” is OK and Cable is OK maybe ‘fastboot’ is outdated?


so using the SDK Platform tools without the intention to unlock I can confirm that in general fastboot works for me on the FP5 tested with fastboot devices.

In case fastboot devices does not work, either try still another cable as fastboot can be picky here or check for fastboot driver manually

Fastboot behing outdated would fit the commands working on my V20 but not on the Fairphone.

Not to doubt you but i have never heard of fastboot behing picky with a cable provided that the cable is able to transfer data. I only installed the driver a month ago on my laptop. I am more inclined to think that an older version would work better at this point as this is the newest as far as i am aware.

I can try it on my tower as this is the only pc I have with an unmodified version of windows and the device i usually use for everything android.

It is highly unlikly but maybe I ripped something out of the laptop that i shouldnt have. Maybe windows microsoft edge, windows stock music player or god forbid cortana is needed to use fastboot properly for modern phones. I dont know at this point :rofl:

I just hoped that i frogot a step that would be so obvious for an fairphone owner that they didnt mention it in any guide.

Well fastboot devices works as stated befor. But to dispell the cable theory i just tried it with 4 additional ones.

I can’t find it quickly and I don’t even remember if it was here or on the /e/ forum, but fastboot 34.0.x (the newest major version) was the problem that could be fixed by downloading the latest 33.0.x very recently.


Update: It worked even less there but only to the extend that i had to set the fairphone up as an adb/fastboot device in the device manager first. When that was done the outcome was the same as befor on my laptop.

I will check the exact version it would be my kind of luck to have an outdated version on my tower and a broken version on my laptop.

Is this the correct menu. The phone shouldnt not show up as a fastboot device but still.

1 Like

You need to reboot into bootloader


Was that the problem have i already been in fastboot mode and the just happen to have a enter fastboot in the recovery too.

Edit 1: Yep i read the section hardware buttons again. If i didnt explore the bootloader befor doing trying to unlock this this would not have happen :rofl: :rofl: is there a reason there are two fastboots (no idea if thats the right term.

Edit 2: yep its funny I did intend to start my first message with I feel stupid for asking. Now i really do feel taht way, but still why two.

Dont know the difference however both exist on the FP4 as well. I used adb reboot fastboot and landed in fatsbootd as well, what I think does not happen on the FP4 however thought it was a coincidence. How did you boot into it also with adb?

Edit: @Ice_Fire the correct command is adb reboot bootloader just for the record…

Exactly i did go there the first time using commands because i was curious if i could boot directly into fastboot on this phone because the v20 would always just restart leaving me to go there the manual way. After that i just went there manually.

It worked even though i was using an older version of adb which is the reason i expected some manufacture difference in software design to be the cause. (more like hoped for)

The fastboot that is reached when using the command adb reboot fastboot has (to my current understanding) the functions to unlock the bootloader disabled on only rudimentary fastboot functionality which would explain why it understood fastboot reboot but not fastboot flashing unlock.

Edit 1: Now knowing that Fastbootd is not some weird typo or necessary evil and after a quick google search i know that fastbootd is its own thing it was intruduced with android 10 (so 2 depending on view 1) android version after what i used to. What it does, not clue and off topic.

Thanks to everybody here that helped me with this.



Fastboot mode is already active in the bootloader menu. Disregard the one in recovery. The correct command would be adb reboot bootloader.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.