FP4 with /e/ stuck in bootloader mode and not recognized anymore by fastboot or adb

Hello everyone,
I am stuck when trying to flash /e/ on my Fairphone 4:

  • I received today my FP4 and tried right away to install /e/ by following the instructions from Install /e/ on a Fairphone FP4 - “FP4”
  • at first I managed to go up the the last instructions, no error message appeared when flashing /e/ (just a warning “******** Did you mean to fastboot format this ext4 partition?” appeared when I entered “fastboot erase userdata” but I don’t think that too much of an issue).
  • At the end, after “fastboot flashing lock_critical”, /e/ boots correctly. I then reboot into bootloader to do “fastboot flashing lock”. After that, I got a “device corrupt” error message and then the phone went back to fastboot mode.
  • I followed the instructions here Fairphone 4 "locked in fastboot mode" about the active slot, did the whole process again and added a " fastboot --set-active=a" at the end. The same error happened.
  • I tried as suggested in the same discussion to flash the files from IMG-e-0.21-r-20220112156786-stable-FP4.zip instead of the latest ones. At the end the result was the same, and I am stuck in fastboot.
  • this time, fastboot devices doesn’t return anything and the other fastboot commands get stuck with “< waiting for any device >”. It looks like another issue discussed here Fairphone 4 fastboot devices doesn't work in fastboot mode [SOLVED], but changing the port, the cable or even the computer (Ubuntu and windows) doesn’t solve the problem…
    So now I can’t seem to do anything, the phone remains stuck in his fastboot mode
    If you have any idea to solve this issue, I’m interested…
    Thank you very much for your help!
    Sidere

Open a support ticket and send it in for re-flashing.

2 Likes

Looks like a simalar problem as talked about in https://forum.fairphone.com/t/install-fairphone-os-offline-failed-but-locked-the-bootloader