FP4 Root Access is possible, maybe a bit risky

My phones keep rebooting after the update. It starts as normal, then it says “Systemupdate wird beendet” and whilst the bar fills up it reboots and the vicious circle starts again.

Any idea how to get around that?

Remove SIM card? Do you use a SD card and how is it formatted?

I am not sure what to answer. I did not use an SD card, I wouldn’t even know how to use an SD card for a system update. I did a “regular” system update, meaning I restored the image in magisk, clicked the message, installed the update and went back to magisk to reinstall into the other slot after OTA and rebooted. Just like everytime before this update, when it went absolutely flawless every single time :slight_smile:

I use an eSIM. How can I remove it? And will removing the simcard stop the constant reboots?

Well that your phone is rooted is quite important information, so I moved your post to the root topic.

Well, I understand why you did that but I am not sure if this is helpful to me, since this topic tells me how to root and re-root my phone, which I know how to do.

But my issue is very much related to the system update since the update can’t be completed due to the repetitive reboots.

Well and I would argue its related to the fact that your system is rooted… And this topic here is handling such issues as well

Edit for others: the update you tried to install is FP4.TP2G.C.0119.20240509

I didnt ask because you should use it for the update, but SD cards can cause weird issues especially when formatted as internal extension.

Reg the eSIM: no idea if this could be deactivated in the recovery or so. At the end its just an idea as it does not seem your issue is a general issue for this update.

Maybe you hit the second problem @hirnsushi described here:

(updated Magisk in between? … then posts below give a couple of more useful hints and explanations even I think, it was the first case there)

This would mean you did not have the real “original boot image” in Magisks backup and during install after OTA that one was reinstalled.

Anyway I think as long as you can access the bootloader you can flash the original boot.img (which belongs to FP4.TP2G.C.0119.20240509 → normally included in the factory zip, which you can download here: https://support.fairphone.com/hc/en-us/articles/18896094650513-Installing-Fairphone-OS-Manuallyhttps://fairphone-android-builds.ams3.digitaloceanspaces.com/FP4/A13/FP4-TP2G-factory.zip )

As soon as you are able to boot into the OS again → re-root as described.

2 Likes

I did not mess around with magisk in between the update. In fact, I’ve never touched magisk at all. I only restored the original boot image in magisk prior to the update. This is the regular way of updating a rooted system since the update won’t even succeed with a patched boot image.

Of course I can try to flash the original boot images manually as well, but I am very sure it will not solve my issue. My phone is booting like always (therefore the boot.img can’t actually be corrupt). But when it has started, already within my regular OS, the system update needs to be completed. And within the completion, the phone crashes about 15 seconds after unlocking the phone.

EDIT: Which slot should I flash the downloaded boot.img into? Both? Or just the active one?

Now, after the like 37th automatic reboot it worked just as I would’ve expected in first place. Don’t know what that was all about.

I had this from my first OTA onwards: I was never able to install the OTA on my rooted FP4 as described using the inactive slot. I have given up to find a solution and I always re-root the phone after an OTA update.

And maybe I was just too impatient as I have never waited for so many reboots to complete :wink:

I never had this problem, it always worked as described. Temporary unroot, installation of system update without reboot, reroot to inactive slot after OTA and then reboot. Works like a charm every single time. I have never had a problem with root. I also never had to wait like a trillion reboots for root access, never. And if I only had the problem for a manual reroot, I simply wouldn’t care much.

But in fact, my issue is not related to root at all as I have mentioned already. Why do I say is and not was you may ask. Well, all of a sudden, after working normal for like 18 hours, my phone just started to reboot constantly again for like half a day. Then, all of a sudden, it worked normal for like an hour or two and now the reboots are back :roll_eyes:

The whole issue started right after the system update as I have mentioned. Therefore, it is very much related to the update.

What could possibly be the cause for constant reboot after the system starts up and sometimes stays up for some time before the restart(s) occur again?
And even more important: What can I do to resolve the issue since it is my daily driver? I backed up system and userdata via Titanium Backup.

You could try to run the OTA from the ota.zip even if that means a factory reset. Maybe this could fix whatever broke during the update.
However this means a whole lot of time to restore the apps. Please be aware that messenger like Whatsapp or Signal rely on their own backup/restore mechanism and will not work with a recovery from TiBU.

I exercised this process once as it was proposed by support to fix battery consumption problems. But is definitely time consuming and something you do not need!

Sorry, but IMO this is the only idea to possibly fix your probs.

Thx Lars! You’re right, I will most likely have to reinstall it. I was just hoping for some some general ideas about the issue, but my post was almost instantly pushed to the root-thread and therefore out of the main focus.
Wanna know, what I found out? My phone is actually pretty stable after each reboot and stays on until it runs out of power. Problem is, that I cannot unlock it. Well, technically I can unlock it of course, but then the “15-sec-timer” starts before the system crashes and reboots itself. Isn’t that weird? :face_with_raised_eyebrow::joy:

Reading on the fairphone website, it says that one of the Pros about sideloading an OTA is that I can keep my data. Is that correct? You just said that it will be all wiped. If yes, this could by my first step out of this mess.

As I said, I backup up system and userdata via Titanium Backup. Recovering wouldn’t be such a big deal even though it might take some time.
But do I want to recover system? Might not be the greatest idea since my issue could very well lie within system, right? Anyways, how can I access my backup? It’s still on the phone. :blush:

I also thought about backing up my userdata with fastboot and then simply flash it back after a clean installation. Good idea and if yes, how can I do that?

Hi, I am not sure i.e. forgot what was actually wiped during the ota sideload, when I did that some time ago.

You say the phone is starting correctly and is stable until the power runs out. Does that mean it works one power cycle after a sudden reboot? Can you enter SIM PIN and the lock screen PIN directly after the reboot?

As TiBU has problems with writing performance to external SDs I guess you wrote your backup to the internal storage, right? Can you access the phone via adb? Then you could download the stuff via adb pull.
Or you try to sideload some recovery from LinageOS and mount your partions there and download the TiBU data via adb.
You could also try find out what actually causes the problem leading to a reboot with adb logcat and then try to delete the data of the process that leads to the crash.

Anyway these are of course no comprehensive instructions how to fix the problem but maybe you can use some of these ideas and wild guesses to actually solve it for you without having to use the “big cannon” with ota sideload and installation from scratch.

I use rsync to sync my backup to my local machine regularly, even if it is on the external and shared SD after I switched to SwiftBU as TiBU did not perform anymore since A11.

I appear to have the same issue as you do. After I updated to C.119 this week my phone freezes several seconds after entering the SIM PIN, and instantly reboots. I had it running twice for half a day without any issues though. I did some minor digging but was not able to narrow down the issue, apart from the fact that it is most definitely in some way related to the current update. I don’t have too much free time this week, so I probably wont make any major progress until the weekend but as a workaround you can simply use fastboot to directly boot an old boot.img (fastboot boot boot.img) (patched or not, does not matter). Until this is properly fixed though you will neither be able to use WIFI nor the microphone and the battery appears to drain slightly faster, but at least you can actually use your device without it freezing. My device has been running like this for the past 24 hours and appears stable, but now would be a good time to copy your backup to a save location.

Obviously no guarantees, but right now I am pretty hopeful that this issue should be fixable without reformatting or data loss. If you can live without WIFI and microphone for a couple of days I would recommend the aforementioned approach.

2 Likes

Not sure if it is possible as userdata is encrypted… So if you take a full image of the partition (with dd ?) and push it on a fresh install perhaps it will be unable to decrypt?

Is LineageOS recovery able to decrypt userdata?
TWRP recovery is not, so I’d be happy if there is another solution :slight_smile:

Reading this topic it’s not clear to me if this is the SIM PIN or the lock screen PIN that trigger the reboot…
In both case it’s possible to deactivate the PIN, could be an idea to try if you can do that within 15s :rabbit2: :wink:

I am not sure regarding encrypted user data. What works is the extraction of boot images to the /sdcard/Download dir and get the file via adb pull from there to the computer.
So it depends where TiBU writes the backup data…

I have a similar problem, after the update it ran fine for a while, then it crashed and after every login crashed again. I turned it fully of and on again, and it ran, but without WiFi, audio and more, and after accidentally turning off mobile data, I couldn’t turn that on again. I did a full reset to at least get mobile data running again.
Adb logs revealed, that there are files missing for the WiFi driver, so the service can’t run.

I am just going to reinstall the OS this weekend to hopefully fix it

The thread to my issue with logs

1 Like

Only one comment:
I personally would not use TiBU anymore, as it did not get updates since a long time. This might be the issue @Wutze ? Did you also restore data via Titanium during/after your first root attempt (after system setup in general?). Did you restore system Apps?

Anyway I would recommend:

1 Like

Reinstalling the OS worked for me, even after installing root. Maybe you should try dirty flashing the OS (not data wipe), that should work since it’s the system files, that are missing, not any userdata. (Don’t forget to backup anyway)