FP4 receiving SMS but not sending SMS to every contact, just certain

Hi, I am Ben and new in here,

received my first FP (the 4) a couple of weeks before - pleased so far, but…
there are some issues.

  • I have a Drillisch group contract (handyvertrag.de) with O2 network: SMS where received from every contact and also SMS service numbers like provider or bank.
  • But first I couldnt receive **any** SMSs.
  • tried a lot, checked APN / SMSC, switched off/on flight mode and/or Volte, put SIM (9 months old) out and in, etc.
  • solved the problem partly, by switching Volte off again and restarted FP4 and waited couple of minutes before sending a SMS.

Now the recent problem:
Now it is working for some contacts, but not all of them??? Why?

  • checked the numbers, looked fine
  • switched the SIM with the one of a friend: still the problem, that some SMS won`t be send from my FP4 and his SIM; with his phone and my SIM everything is fine?

Has someone a glue, what I can still check?

Would be happy, if someone can help me out there!

Some other issues I have / had:
Tried to contact the support. Received no answear since 09.03.2022, is this normal?
Solved the problem with no mobile network connection (or just for a small moment), caused by that my provider has no 5G and FP4 was set to default 2G/3G/4G/5G instead 2G/3G/4G - why is the default 5G setting not working in 4G but is called 2G…5G?

Hi and welcome to the forum.

Just an idea. If the phone is set to select 5G and it finds a 5G signal it may channel hop and as your provider doesn’t use 5G the phone has a problem settling down, so some connections for SMS are lost.

Hi there,

thanks, right now it is set to 4G, because with 5G it is hopping nowhere :wink:
With 5G I have no mobile connection at all. That`s why I switched to the 4G setting.

1 Like

Has someone further ideas?

Have you disabled any Google stuff, if yes what?


Hey, thanks for Your reply.
Checked it. I`ve found the following disabled:

  • Android Auto
  • Carrier Services
  • Chrome
  • Digital Wellbeing
  • Drive
  • Google Play Filme & Serien
  • Calculator
  • Soundrecorder
  • YouTube Music

What`s Your suggestions?

1 Like

You’ll have to enable Carrier Services again, that has been an issue before, see:


Hirnsushi, You are great!

Big hugs, Bro!

Problem solved after enabling the Google Carrier Service and restarting FP4.

Case can be closed!


Also big thanks to You, yvmuell for the crucial hint of direction to search :star_struck:


What do you mean by you’ve found? You must have disabled those yourself.

Best wishes,

Hi Thomas,

yeah, You are definitively probably right. I did mean, “I have searched and I have found.”
Sorry, english is not my mother tongue.

Btw and OT, there is an orthographic mistake in the self description / subtitle of Your profile as a corporate communications professional.

Cheerio, Ben

Problem solved, over and out.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.