FP4 randomly stops recognising SIM


Hi all,

hope I can get a bit of support, within the last month my FP4 has randomly stopped recognizing my SIM card, a restart fixes it, but it has become increasingly frequent. Today it stopped recognizing it 3 times, while before it might have been maybe once a week.

I’ve tried to resit the SIM, but it had no effect. I’ve tried to look through the forum, don’t know if maybe I’m not searching with the right things, but no similar issues. Furthermore, I’ve done the online troubleshooter, but it also gives nothing, considering the SIM works fine, but the phone randomly stops recognizing it.

I’ve already submitted a FP support request, but was wondering if anyone here has a quicker solution.

Here is some additional info, in case you need it:
Model: FP4 128GB
Android Version: 13
Build Number: FP4.TP20.C.087.20231122
Activation Date: 29 April 2022

Also, mobile operator is Labas in Lithuania.

1 Like

I believe there were two ideas mentioned in this forum

  1. the SIM card was not properly inserted
  2. the SIM card was older than two years old

perhaps someone would have a better idea

good luck


Like I said, the SIM card was reseated a few days ago (and the problem still continued), while the SIM card is only about 1.5 years old.

Just want to give an update. Updated to build number: FP4.TP25.C.095.20231219 a few days ago and the issue continues.

I run out of ideas, but

  • please consider checking a different SIMcard with your phone, or this one in a different phone
  • you might also ask your provider for help
    I cannot find in the forum any other references to your provider but perhaps you will be able to locate any fairphoners in your local area to compare the experience?

Hi, sorry for not seeing your reply earlier, the problem here is that the issue is very random. It could happen in a few hours or a few days, and I can’t keep a swapped sim for that long.

I’ll see if there are any people with FP, but I have doubts.

I’ve the same issue on both the physical and the esim. Support has no answer yet. Only since the last update with 5G enabled.

It’s just possible there might be a problem with the SIM’s contacts, or those of the slot. In an older phone I’d have suggested moving the SIM to the other slot, but of course you only have one.

Try cleaning the contacts of the SIM with a cotton bud soaked in high-grade surgical alcohol. Allow to dry well before re-inserting the SIM.
As already suggested, you could request a new SIM; they do sometimes have problems.

If that doesn’t help, I’d say you have two options: wait for a response from official Fairphone Support with a view to repair under guarantee, or ask your network operator if they can provide an e-SIM.

Well for me this happens also with the esim so it’s not related to the physical sim it seems.

1 Like

Ok it does only happen with the esim. Totally random and suddenly: phone lies in front of me with approx 75% connectivity and suddenly it’s gone.

So weird.

New workaround: only turn off the data connection for a second and back on, and all’s fine.

The esim is my standard for data connection.

1 Like

We might be seeing two different problems here.

@bm90001 Yours (update, 5G, e-SIM) points to a software issue, and probably related to the last update and related to a specific network operator(s). Only hope there is to contact Support which you’ve already done.

@Traydr 's problem might be either the same or related to the SIM. But apparently not related to update, and increasing frequency of incidents for me points to the SIM, in which case using an e-SIM might still be a solution for them. If possible use the guarantee, but that will probably mean sending the phone back, so you’ll need to do your backups (those should be regular anyway!) and hopefully you’ll have a backup phone available. If you decide to do that, before sending the phone back, do a factory reset just in case that solves the problem. Support will likely ask you to do that anyway.
Check whether turning mobile data off then on helps, as indicated by bm90001.

1 Like

Ok with the latest Fairphone update from 19.02.2024 the connection isn’t lost anymore so far. Let’s see on the move and public transportation how it’ll behave…

I had this problem and it was difficult for me to know how to solve it, I glued the SIM well on the inside with tape since it did not make good contact.

Update: tried troubleshooting as said by support but nothing changed. Only since the pre-last update been ongoing so 100% certain that this caused it. With an esim it’s also certainly not related to that as it’s being updated automatically in the background in case the provider changes things such as Apn or something alike.

Seems to be caused by some malfunctioning connectivity code within the pre-last Update I suppose.

Temporary workaround: shortly turn off and on again mobile data, this immediately forces a new connection it seems and all good until the next time. Then same procedure. Annoying but at least a workaround for now.

1 Like

Update: unfortunately so far Fairphone didn’t find a solution. The issue is in particular very irritating while being on the move as e.g. on a fast train. Before the mentioned Update this issue never happened. Being stationery the workaround is still very briefly turning off and on again the mobile Internet connection. On the move that doesnt solve the issue. Seems something with the triangulation is wrong, meaning that the FP doesn’t flawlessly switch between cell towers but rather loosing the connection totally while switching to another cell tower. Happenes with two different Providers both on 4G/5G.

Anyone else can report something on that issue and might have found a workaround that’s any different?

So also with 5G off? Did you try with VoLTE off? Did you test with only one SIM enabled?

1 Like

Tried all that but nothing helped.

Short update since @yvmuell triggered an idea: tried again all various setting combinations and maybe I by accident found a (kind of weird) solution: the secondary sim (physical) was only allowed to use data while being on a call. Turning VoLTE off for that sim didn’t do it though it then shouldn’t use data. Now also preventing it to use data during a call seems until now to fix it. Couldn’t test it yet at higher speeds as e.g. trains or motorway but at least locally and indoors I didn’t experience that issue again so far. Perhaps this helps someone else too.

Once I have more experience with that new workaround I’ll post it here.

1 Like

Can you specify that setting?