FP4 keyboard disappears

after the update to Android 12, my FP4 occasionally “looses” the keyboard after some days. Then, whichever application I start, the keyboard is missing, until I restart the phone.
Any experience with this strange behavior?



Hi Thomas,

I’ve never heard of the keyboard becoming totally inaccessible. What happens to me sometimes is that it does not automatically activate when text input is required. In that case it it usually enough to tap into one of the text input fields once more. Have you tried that already?
Is there anything else “non-standard” about your setup in terms of apps that modify system behavior, rooting, alternative OS, etc.?

Hi Michael,

thanks for your reply!
Yes, I tried to reactivate the keyboard the way you describe, also trying by restarting Nova Launcher, the only modification I did to the system. Nova ran perfectly on my FP2 and does also now on my FP4. I will send a bug report there and try using the default launcher. Maybe that’s the source of the problem.
It may not be a bad idea to restart the phone every 2-3 days anyway, which is the only way, so far, to reactivate the keyboard.
Still, strange…


1 Like

Out of curiosity . . you don’t have an SD card formatted as an extension to the internal memory ?

Hi amoun,
no, I haven’t. The Sandisk Extreme Pro 256 GB, which worked fine with my FP2, does not work in my FP4. So far, I’m happy with the amount of internal memory…

1 Like

I use Nova as well since FP2 times - now on FP4 - and have never seen such a problem. So while possible, I consider this an unlikely cause. I have no more idea at this point, unfortunately :frowning:

1 Like

Hello bmw247,
I have the same problem as you described. Indeed, restarting the FP4 resolves the problem. I don’t know how quickly it reappears. Thanks for chairing your experiences. Makes it less frustrating for me.
Best regards

Hi all. I have the same issue, but for my specific case I found a simpler solution then rebooting.

I have two different keyboards, standard and SwiftKey, and usually have SwiftKey by default. When the keyboard is not appearing it is sufficient to open SwiftKey settings and force termination. The system automatically switches to the standard keyboard, which is correctly working. At that point I can select again SwiftKey, and it restarts.

I don’t like this, but at least is better than rebooting the phone.

Hi Michele,

I tried reactivating the keyboard by changing the settings, unsuccessfully :frowning:
But I’m happy that it works for you! As you mention… much better than restarting each time.
So, I try to regard this like Dieter does: being glad for not being the only one. And always look at the bright side of life… . :wink:


I have the same issue described here. I use AnySoftKeyboard and Lawnchair 2 launcher. I fix this by going into Settings > System > Input > On-Screen keyboard (Names may differ) and deactivating, then reactivating ASK.

I’m not sure if everybody here has the same problem. There seem to be two different issues here:

  1. the original keyboard stops working
  2. a user-installed additional keyboard stops working

From what I understand force-restarting the user-installed keyboard fixes the issue for those people. Extrapolating from that: Has anyone who has issue #1 tried to force-stop the Gboard app from the settings?

Wondering if everyone reporting the issue has a third party launcher installed?

I have a cautionary tale about force-stopping GBoard on a new phone:

I’m about 2 weeks into using my FP4, and it’s so fresh I haven’t even put my Google Account on it (yet).

As a result, the only keyboard I have is GBoard (as far as I’m aware), and to see if the standard keyboard would kick in (because wanted to see what would happen) I force-stopped GBoard, Disabled it, Restarted my phone…

…and now I have no keyboard at all, to enter my passcode to access any of my phone.

I hadn’t even put my dialling contacts into it yet, so it’s no big loss to me to Factory Reset, but I suspect that’s the only thing that will quickly fix this.

If I could somehow hook up a physical keyboard to the phone then I would just do that, but this is a problem I could fix this evening, so I’ll do that.

For the record: I’ve not tried to flash this device yet, but I’ve accepted every update, and the phone is currently running Android 12.

If anyone does have a better idea: please advise.

Edit: after doing some more reading, I tried “Safe Mode”, no change. Factory Reset for me! Approximately 30 minutes later: GBoard installed by default, but alternative appears to be in use. Interesting… 10 more minutes “playing” shows only GBoard is installed. “Urgh”. Have adjusted “share usage” settings…

Welcome to the community!

That certainly looks like trouble. But the problematic part seems to be the one about disabling the keyboard outright. I don’t expect such trouble to occur from simply force-stopping the app. It should be restarted automatically in that case.
Still, a fascinating experiment you did there :smiley:


I’ve had the same bug with the keyboard. It freezes and no further input is allowed. I also found changing the keyboard made no difference. At the time I was running Hyperion launcher and had open keyboard installed. I am running Nova launcher and SwiftKey Beta and the issue seems fixed now. I have set SwiftKey as my main keyboard and turned off gboard in manage onscreen keyboards.

Same issue here. Keyboard just doesn’t come up so nothing can be written. Only solution is reboot.

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.