FP4 - gcam-port

Yes, I have. When running the apk, it does not ask me if I want to update an existing app.

Hmmm :thinking:

Could you try adb install GCamPhotosPreview-1.apk, I just tried it again and that works for me.

1 Like

Vielleicht über ADB Commando deinstallieren

adb shell pm uninstall --user 0 PACKAGE

That’s not enough, that only “uninstalls” it for the main user, you need com.google.android.apps.photos completely gone.

so you need root for this, because ?

 That’s why, if you omit the –user 0 and -k part of the uninstall command, the command won’t work. These two flags respectively specify the system app will only be uninstalled for the current user (and not all users, which is something that requires root access) and that the cache/data of the system application will be preserved (which can’t be removed without root). 

1 Like

Yes you need root to uninstall or overlay it with Magisk, or a custom ROM without GMS.

But you can also use something like Shelter to create a Work Profile, copy over the FPCamera (or GCam in this case) and install the GCamPhotosPreview in there, just tried it and that works :smiley:

Edit: But make sure you have a way to get the photos out of there:

I’d set up a Syncthing backup just in case!

2 Likes

on the FP3 I just use an older GCam Port (Version 7.4) , because on my FP3 v8… slows down the whole device, I dont see any benefit reg. quality and with v7.4 I still have the preview using a third party gallery…

Das habe ich mir bereits gedacht. Das es komplett weg muss und nicht nur im User-Kontext.

Da ich den calyx Fork ja auf meinem iodé nutze hatte ich damit nicht die Probleme.

Ok, I see. I only uninstalled for the user and don’t think that I want to try that shelter thingy. So I’ll return to my previous solution of a Google Photos that is blocked by firewall.

Or changing the OS, what may result in peace and happiness

2 Likes

Hello!
I’m using the GCam_Wichaya_V1.5_Snapcam for several month now, and I’m quite happy with it.

This weekend however, I noticed a strange bug: when doing a selfie in a sunny environment :sun_with_face: the colours are somehow mixed, some blue points appears on the face and some browns points are present in the sky:

The poor guy in the background wasn’t really like that, at least I hope so :rofl:

I noticed the bug later on, so I couldn’t make the same trial with stock camera. I’ll investigate next time I go to the beach :sunglasses:
Does any of you already see something similar?

5 Likes

Wild guess: Maybe the sun reflection on the sunglasses (frame) played a part in it?
(Or maybe just a built-in anti-Berlusconi filter in the cam)

6 Likes

Try deactivating white balance or try bigkaka port

I think it’s the weird vibes coming from the alien behind you, it’s the alien filter you unknowing activated that warns of lurking strangers. I think it is meant to happen on all screens when volatile strangers are near.

Type alien in the search box to see if that directs to the toggle, when you feel safe, at home.

6 Likes

What port are you guys using at the moment? Wichaya hasn’t received an update in months so I wondered if I should switch ports.

1 Like

I’m using BSG at the moment.

I’m using the development version: BSG: MGC_8.5.300_A10_V5
There’s also the stable version, about 2 months old: BSG: MGC_8.1.101_A9_GV2a

It doesn’t have an option for third party gallery apps, does it?

Not that I can find, nope :expressionless:

Hi, thinking of getting an fp4 as my fp2 is creaking now. Does gcam solve most camera issues? Do I need to root the fp4 and does that bring consequences? Like banking apps not working etc.

Is it likely fairphone will publish camera-api2 updates soon to allow 48M and ultra wide lens access?

Cheers

Hello. In my opinion, it solves most of the issues, but to be fair, the stock camera app also got much better over the last updates. You don’t have to root the phone to use gcam. You just need to enable installation of apps from unknown sources. (It should prompt you when you try to install the apk file.)

Is it likely fairphone will publish camera-api2 updates soon to allow 48M and ultra wide lens access?

Yes, but we currently have no idea how long it’ll take. (Note that the issue has been reported for more than 7 months.)

4 Likes