FP4 - gcam-port

I found this explanation

org.codeaurora.snapcam is the package name for a specific Google Camera port mod developed for non-Google devices. The package name is solely used to denote the mod version of GCAM for non-Pixel users to utilize Google’s rich photography skills.


there’s a mention of the Auxilliary cameras option in the settings, but so far I haven’t been able to switch to the wide angle, no matter which ID I’d try.

edit: I’ve also checked Open Camera, and according to its FAQ there should be an option in settings to enable a button for switching between multiple cameras, but it isn’t there on my FP4. perhaps it’s an issue on Fairphone’s implementation of the multiple camera thingy, then.

Gcam Wichaya V1.5
when I click under More → Playground, the app crashes. Is that only for me that way?

It also crashes on Wichaya V1.4


No, it crashes here too. The stock camera app crashes when I try to open the gallery (Simple Gallery here). And there were a few other crashes of several apps on my FP4 so far. That’s why I think it is more likely a problem of the phone than of a specific app. At least the FP4 doesn’t reboot like my FP2.


Gcam and Stock Cam crash when the Google Gallery app is disabled. is the app deactivated for you?



Yes, the Google Gallery App is deactivated. The stock app crashes, GCam doesn’t crash and works fine with Simple Gallery (but crashes when tapping “playground”).

if you have Google Photos disabled, go to GCam settings (swipe down, then tap on the cogwheel icon), then scroll down to Advanced and enable the “Use a third party gallery” toggle. Simple Gallery works fine that way for me. I don’t see any way to fix the crash in the stock app for now, though.



First you reported that you are using the Snapcam version. Now you say that you tried the version without name suffix (GCam_8.1.101_Wichaya_V1.5.apk). So your experience now is that the version without name suffix works better than the Snapcam version (GCam_8.1.101_Wichaya_V1.5_Snapcam.apk), right?

they’re two identical versions, the only difference is in the package name.


As @noodlejetski already answered, it’s just the file name and how the app is then unpacked in the file system.
The versions themselves are the same size except for the bit.

I did not let this rest and I have researched in this regard. And it is really so that it is only about various file names.

So it is up to each himself which version he pulls and which flavour he prefers.


If somebody is interestet in my Wichaya’s XML config file:

Can be imported under: Settings / Advanced / XML Config


what does your config change?


Changed some settings in the normal settings dialog

Changed some settings in the normal settings dialog and Developer Settings

  • third party gallery is displaying actual taken photo and not the last before…
  • no social media in menue
  • etc…
    Managed Nextcloud
1 Like

Importing the config doesn’t seem to work for me. I get this message but no settings are changed

Try to create a folder in filesystem:
and put the xml files in there.
The folder GCam should still exist
It’s on the same level like Documents, DCIM, Downloads, Music, etc…

Then try again to import via the dialog
or better:
In camera app touble-tap in the black field around the shutter button. Then you could also load xml files. But not save, only load

Thanks, that worked

This didn’t, though. If I don’t wait for about a second before opening gallery I still don’t get the most recent photo .

Have you used the XML with Dev options?

Yes, what specifc setting is it? Then I could play with it myself.

Hello. I have a problem with basically any gcam mod when I want to access the front camera in the video mode. Wichaya’s mod doesn’t seem to be able to access the front camera at all. It just gets stuck or crashes. (I’ve tried both v1.4 and v1.5.) Nikita’s mod sometimes works, but it randomly crashes. It feels to me like the camera2 implementation is a bit wonky when it comes to the front camera. I cannot access it in any other app like IP Webcam. Does anybody experience the same behavior?

Edit: Clarified this is about the video mode.