FP4 fingerprint sensor makes multiple attempts without lifting finger

Within a second without giving you the chance to even lift the finger? Then yes its this problem, else its a different one and I will move the posts to e new one, just confirm
And one comment: the forum is no official way to contact Fairphone support you have to contact them via E-Mail or contact form on the homepage

1 Like

Yes, without a chance to lift the finger, exactly as described several times in the other posts in this topic.

For now, the suggestion by @amoun is helpful, I configured 3 versions of the same finger, and now it works better. Some people mentioned that newly added fingerprints work fine until they “grow older”. If this happens in my case, I’ll think of contacting support. However, as this topic is about a year old, I presume someone must have done so before.

1 Like

I would be happy for you if I would be wrong and I’m sure the issue will not go away by adding the same finger multiple times, as this has no influence on the (over)sensitivity of the sensor.

Even if someone did contact support before, it was done for themself only, i.e. this would not help you with a potential warranty case of your phone

Again, the issue isn’t that the finger isn’t recognized (at least in my case it works perfectly fine), but that every part of the finger / hand is detected as a finger to scan, which triggers “too many attempts” :roll_eyes:

The threshold for what gets detected as scanable is too low and the time between repeated attempts needs to be higher.

1 Like

The sensor takes any capacitive contact as an attempt. If I hold my FP4 in my right hand, the skin between thumb and index finger triggers the sensor and I can feel it vibrating with each attempt perhaps 4-5 times a second.

My opinion is the frequency for checking prints on the sensor is too high and hits the limit in only a handful of seconds. That means having to enter my PIN which isn’t onerous if it was only on occasion but it happens more often than I prefer. If the frequency was slowed down to 2 times a second then it would be less likely to hit the limit in a short time.

Surely the thread shows that there are a lot more than a small group of people who see this sensor behaviour as a problem.


I know the problem and experienced it a year ago as well until a software update fixed it for me. I’m trying to figure out the common denominator here. As I also proposed previously to enroll other people on the affected Fairphones as well. Just to figure out if its a problem with the hard or software, or maybe it’s a biological issue, meaning the fingerprint pattern or maybe how oily the fingers are (which of course can still be fixed by FP, unless it’s a hardware issue).

Maybe try the suggestions? I’m also okay to forget about this issue, since for me it works fine. Just trying to help.

Edit: okay I’m out, it happens more often that my well intended posts are removed by a mod, my suggestion just got removed. Nvm then.

This isn’t helping. This topic has looped around so many times I’ve lost count and the issue is well described at this point.

The sensor is too sensitive and the cooldown is too short, that’s it.

For the amount of testing I’ll refer you to my post just a little bit above:

I’m not willing to argue about user error, my fingerprints get recognized just fine, it’s the part that’s not a fingerprint that’s the issue here.

(To be clear, I haven’t deleted your posts)

1 Like

I have an idea who it might be though, a bitter person it seems.

I’ll stop trying to pinpoint the cause. The fix you describe has been implemented already, but for some reason doesn’t work for all. My guess it’s because of different fingers or maybe different hardware. But no way to rule it out if people don’t try stuff to rule things out. The problem is clear, not the cause.

The behaviour hasn’t changed for me since I’ve had this phone (end of 2021), it’s been very consistent.

It will still happily scan any part of my hand repeatedly and time out before I ever get a chance to put my finger on the sensor.
As I said, my actual fingers get detected at close to :100:% of the time, that’s not the issue here.

The attempts should be limited to once per second or something. It’s very common that there have been to many attempts already when I try to unlock the phone. So common in fact that I tend to use pin unlock instead


This! ^
It always scans on burst mode, so if you accidentally touch the sensor with your hand, your available number of attempts are wasted in a second.
Tuning it to only make a single scan/second would give you time to change your hold. Yes, it means it wouldn’t unlock instantly, it would take a heartbeat to do so, but it would still be faster than entering your pin…


As there have already been so many repetitions in this thread anyway, it won’t do more harm to repeat again that this does not always happen on all devices!
On e.g. my FP4 it only scans twice and then waits until I move my skin on the fingerprint reader until it scans (two times) again…


I was unaware of that. :open_mouth:
So, how do you get this to happen? On mine, if I trust the vibrations, it scans in machine gun mode as long as it is touching something skin-like. Always has, since I bought it.

(For the record, I have set it to only unlock if it’s first waked up, else the chances of touching the sensor accidentally are way too big.)

Didn’t do anything for that. As for e.g. @UPPERCASE the fix came with some OS update (in my case /e/OS) months ago. Don’t know why it has not yet been fixed for everyone.

For me although I have the issue its def not always and just sometimes, so normally it stops.

And to repeat myself

1 Like

Now that you’ve mentioned that I can also reproduce the problem. In case I touch the sensor in a very soft way it also triggers the “machine gun multiple attempts”. But only in this case.


I made a point of counting it today. I used the skin between my thumb and index finger again. I’ve tried softly and firmly, it makes no difference.

10 vibrations in around 2 seconds and that’s it, you have to enter PIN after that.

It happens with any skin contact that isn’t a recorded fingerprint. This has happened since the day I got the FP4 and I’ve had to work around the extreme sensitivity.


Maybe it’s already been said (though I did do a quick search in this topic), but this difference of experience, some users with the problem and some not, leads me to wonder whether there’s not a manufacturing problem with some devices1. Maybe graphing incidence against manufacturing date would shed some light. I suppose only FP could do that with any accuracy and it would require plenty of input from users, or logging specific data.

Hey, an idea for the MyFairphone app :smile:, use it to get info from users about known issues.

1 Edit - seems this has already been stated by FP, sorry:

(I will resist the temptation to repeat my own experience on this :wink: )

Apparently the answer to the first question is “no”, and to the second “nobody knows yet”… :grin:

Seriously, any volunteers?
For me that problem isn’t annoying enough to send my phone in for a probably lengthy repair session of uncertain effectiveness. It’s my work phone, I need it daily, more so since I’m currently far from home and have thus no landline to fall back.

There’s being annoyed by the issue (used to it at this point), and sitting through weeks of back-and-forth with FP support, not doing that again if I don’t absolutely have to.

Besides, I’m not running stock, so I’d probably have to flash it back to FPOS again for a longer amount of time I’d be willing to put up with it (any amount of time basically).

In my opinion there are already enough tickets raised, FP is seemingly aware of this issue, but as with several other issues it’s either waaaay down on the backlog or they don’t have it fully figured out either.

1 Like