FP4 does not charge

Hi there,

I have an annoying problem: my FP4 will not charge.
When I restart my phone, it charges again, but after a short time it does not charge anymore. Does not matter if slow or fast charging.
I am using the original FP4 charger, and when I dial ##2886## while charging, the following test results come back:

USB:ok
Charging:NOK
Current:NOK
Current:0 uA

The FP4 system is up to date.
Has anyone had the same experience?
Is this a software issue?

Thanks a lot for the help!

Have you tried if the problem is also there when using a different charger?

Same outcome with a different charger

And different cable?

Different charger, different cable, different socket…won’t charge

I think I cannot give you any other advice than to contact support. Sounds like a faulty device or battery to me.

Perhaps a #fairphoneangel is in your neighbourhood to test the battery.

Thanks for the help. I will try to find and angel.

Out of curiosity: When I restart my phone, I can charge it again. How is this related to a faulty battery or device?

Hi

Do you mean it’s OK now or when you switch it off again it fails to charge.

Clearly the battery and charging system are fine, so it seems like a software issue if it happens again.

A few checks

a) Basic do not have an SD card formatted as Internal
If it happens again

b) Do a safe mode restart

You can try a dismantle and reassemble in case there is a loose contact, it could even be a dodgy cable or charger if it is intermittent.

c) Do a factory reset

Got the exact same issue this weekend - after updating to the current firmware. Plugged it into my power bank while out camping and didn’t gain any charge over night. Different power source or cable made no difference. Battery icon changed to charging, but nothing happened.
Works again after a reboot.

Do you mean it’s OK now or when you switch it off again it fails to charge.

I mean in the case I cannot charge my phone a restart helps. After that, the phone charges again. After a while (let’s say 2-3 days) the phone does not charge anymore and I have to restart it.

Thanks for the suggestions

Oh pity, let me know I you find out more

Maybe you could tell us in which region you are looking for support, maybe there is someone nextvto you with an FP4 to try with his Battery or components.

I ran into this problem today. FP4 displays the charging icon but does not charge. After reboot, charging works correctly again. For the record: with the same charger. Strange…

Hello, I am having a similar problem to the original poster. I think my phone gets into this state of not-charging when it reaches higher temperatures (e.g. playing a game).

When I restart my phone, it charges again

Yep, only restart fixes it. Different charger/cable/socket doesn’t help. It seems to be a software issue, because after restart it immediately can start charging.

It’s getting a bit annoying, having to restart daily. Any tips on how to diagnose or fix it (without factory reset and other drastic measures)?

Same happened to me, but only sometimes. It’s tricky to spot the problem: the small batterie icon always changed to charge mode, but there must be also the message on the lock screen or the first screen: “device charging” or “device charging quickly” or “device charging slowly” (something like that, I only see these messages in German (Gerät wird geladen, Gerät wird schnell geladen, Gerät wird langsam geladen). If there is no message like this you can change to settings/Battery(?)(in German Akku), there you may see the simple message “device not charging” (in German: Gerät wird nicht geladen). This is very odd, because there is no other warning to be seen.
When this happened to me for the first time, I found a totally drained phone in the morning (still connected with a loader). It took some minutes of fear and patience connected to the original loader until the phone shows the first signs.
Mostly a reboot helped for me, but one time, I had to use another loader, although the first one mostly works fine.
It might be a problem of delivering not enough current, in my impression it occurs mostly with older charger connected with adaptor from micro USB to USB C, maybe also when the connector does not plug in properly, so that the phone “thinks”, there is a weak loading device, and refused to use it.
But it would be very helpful, when the battery icon would reflect this properly and won’t show charging when the phone doesn’t do it.

2 Likes

Maybe try to clean the USB port from debris and/or open the FP to see that the module is properly connected

I took a hardware problem in accout, but I’m quite sure, it is not. Otherwise the problem wouldn’t dissappear after a simple reboot. And my phone don’t stay in the pocket of my trousers but in it’s own holster at the belt, so quite clean. And the phone sees the charger (battery symbol) but nevertheless won’t charge.

1 Like

I have the same symptoms as @Roland768

  • fp4
  • I use the same usb charger and cable for months, and other cables and chargers, everything with the hardware works
  • suddenly, the phone turns into “I won’t charge anymore” mode and will not charge with any of the devices that worked before.
  • In “won’t charge” mode, it shows a charging icon in the status bar on top (the flash symbol next to battery) but when clicking through the menu as described by @Roland768 , it says “won’t charge”
  • reboot solves problem
  • after reboot, it charges again on the same hardware

Clearly a very annoying software problem. Hiding the message “I won’t charge” behind an icon that indicates it charges is confusing, wrong, an error.

It really destroys daily life - you charge your phone as every night plugging it in. The next morning, you want to leave home, suddenly you have 5% battery. You cannot charge the phone on any charger in your flat or at work. No single cable or charger works. Sheer panic follows. How do I log into my bank account without my phone? How do I live modern live with an unchargeable phone? It’s not only useless, its an end to modern life. Etc.

If you need your phone for work or life, this is a real problem.

It is unusable until reboot. I only found out by using my phd in computer science instinct that rebooting may help.

clearly annoying and in case of a software bug, only resolvable by Fairphone so I advise to #contactsupport