FP4 Camera does not store GPS location data

The general settings of my FP4 has Location ON, location permission for the camera ON while using the app, and in the camera app settings Save Location information is ON.
But no location info shows up when looking in the EXIF data using Affinity’s “Photo” application. A photo taken years ago with my iPhone 6S shows the GPS data perfectly (using same photo editing app).
What is missing?
Thanks for all reply.

Location is on and are you sure its working? Maybe its just not having the location in time?

Generally, if you need location in the photos, it is better to start a mapping app before taking the photo, just to force the phone to acquire position. Otherwise, it is somehow lazy in this regard and it seems to me the camera app does not try to get location very pro-actively.


Let me start by saying I generally do not look at the gps data in a photo, but today I needed it. There seems to have been no location data since the beginning (2022-08-31).

  • NavMii also does not get the location
  • PeakFinder tells me it can’t get the location data.
  • GPSTest does show the satellites in view (US, Russia, China, EU)
  • Sensor test does not show any GPS sensors, but I suppose that is normal.

So it looks like something is wrong hardware wise?
I restarted, which took a very long time. PeakFinder seems to work OK, but from Camera still no GPS data and Navmii also bombs.

So how long did you wait to get a fix? Did you check the other topic?

I did check and I did wait.
PeakFinder shows the correct images from the correct location after about 5 to 10 seconds.
Navmii consistently bombs now.
Camera EXIF gives this in Affinity Photo:

whereas on an older iPhone photo gives this:

But one taken just now gives nothing…
Stellarium gives my location as 46º20’0”N 6º4’0”E and the iPhone tells me 46.2680N 6.0947E.
which corresponds. Google Earth says 46º16’04”N 6º05’40”E.
But all this is moot, as the only relevant aspect is that there are no GPS data in the FP4 photo’s EXIF.
But maybe I’m looking at all this wrong?

Just checked and using the stock cam indeed nothing in the Exif data, using GCam Port I see it in the Exif data…

Edit: I tried again and see it in the Exif Data also when using the stock cam app…
Btw I use the simple mobile gallery

So are you saying that what is in the EXIF data is not completely shown depending on the app one uses to view it? That is indeed possible/probable.
I drag photos onto my Mac using Android File Transfer, then file them somewhere. To edit I use Affinity Photo (which is a no-subscription alternative to Adobe’s PhotoShop). Affinity Photo shows me all of the EXIF data (as per screenshots earlier).
I have no clue why Navmii suddenly started bombing out.
According to the very precise aerial navigation charts I have, my current location should be 46º16’04”N and 6º05’40”E, which corresponds exaclty to what Google Earth thinks.

I installed Simple Gallery Pro (from FDroid) but it does not show anything in the EXIF:

So are you sure its turned on in the Cam App and also the permissions enabled to use location?

”Les mystères de l’informatique”: now it works.
But I had to restart the machine twice, and also uninstall Navmii, then re-install it.
That now also no longer bombs.
Maybe Navmii prevented other apps to get the gps? No idea.
In any case: I did NOT change the access to location settings of any app (including camera) and had the location on by default.
Peakfinder also seems more accurate now:

(coordinates correspond to those from Google Earth and flying maps)
No, it can’t have been Navmii blocking anything. It must have been some kind of sensor process that hung.

Unsatisfactory: it works again but we don’t know why.
Actually, it works now, when in fact none of the photos I took since the start have location data. So perhaps it was a bug or hang or something inside the system. Strange.
Thanks for your help and patience,
(the peakfinder view is when looking south-east from here, but a tree has grown to obscure the view of the Mont Blanc) :wink:

1 Like

I had again a few photos with no GPS data, but they were taken inside. As soon as I was outside, with better gps reception, the data was there again.
So it seems gps reception on the FP4 is not as good as on my old iPhone6.
But at least I now know.
This is also confirmed by Navmii not working on the train or tram, despite sitting next to a large window: the glass coating diminishes the signal enough that the FP4 does not use it. This could be improved…

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.