FP4 Battery Drain Since Last Update

Hi,

Since the last update, my FP4 drains battery, it lasts about 6 hours. I first did a factory reset but then I also did a full reinstall of the system (with fastboot and recovery mode). But the problem remains. And I didn’t install new apps since this issue - I also reduced the number of apps after I did the reinstall of the system.

I can also feel that the device is warm (not much but it is clear, that it doesn’t sleep deep) - so it is also clear that the phone works too much, but why.

If I do a “logcat *:E” is get nearly every second this message:

07-02 11:09:05.591 1552 2449 E BatteryService: getUsbNTCTemp temp30.9
07-02 11:09:09.828 1552 2449 E BatteryService: getUsbPresent version1

What happened?

Thanks for any help.

Hi and welcome to the forum.

Sounds like a question for official support given the basics you have done, hopefully you are aware this is only a user forum.

Hey! You can just answer the previous post via the reply button you don’t have to quote the previous :slight_smile: especially not all of it :rofl:

Bottom right of each post :heart: | :chain: | · · · | :left arrow [Reply]

The two way of contacting are

  1. Use the web interface and you should at least get an auto reply with a ticket number
    https://support.fairphone.com/hc/en-us/requests/new
  2. Send an email via support@fairpone.com

Thanks for your answer. I can try too, but on my last message nobody answered.

How did ask for support officially?

The battery of my FP4 is also draining quickly since several days (battery life about 12 hours when on standby). From the output of top and logcat, my problem seems to be very similar to this one:

https://forum.xda-developers.com/t/android-12-cellbroadcastreceiver-permission-denial-causing-high-cpu-usage-in-com-android-phone-process.4529991/

Mine is currently also draining fast er, however for me already before the update and not each day the same… Didnt check on this further. Maybe its good to send your logcat to support?

I have the same issue after the recent update.

I managed to fix the problem by setting the preferred network type to 2G (reachable on my Dutch-language phone via Instellingen → Netwerk en internet → Mobiel netwerk → Voorkeursnetwerktype). The battery drain (and the error messages in logcat) only seem to happen if the network type is set to 3G or higher.

Credit for this idea: [4.5.0.18] (still) battery drain on XA2 - Bug Reports - Sailfish OS Forum

Just to add that here: That’s not a workaround working everywhere, as there are countries/providers that have no 2G networks anymore.

Coming in here to mention that I have the exact same issue! I been noticing a drop in 30-40% every night, and I don’t have the option to charge my phone at night, so this is REALLY annoying.

Has anyone contacted/heard about it from the official support yet? I contacted them this morning via E-Mail, will have to wait a few days for a response likely…

I also tried checking if any apps are draining my battery in “Battery Usage” in my settings, however every morning when I check, all it shows me is ~ 2% Screen and 3% Mobile Network, nothing else.

I reported the bug to support on 26 July and sent another message with the workaround on 28 July, but haven’t gotten a reply yet.

Looks like support is on a hiatus. I didn’t receive any message from either of my two open tickets after a week of waiting.

let’s hope theyre on a hiatus, because theyre sooo busy trying to fix this battery drain issue!

The support got back to me and told me to do a factory reset… after saying that I’d rather not factory reset my phone for an issue that apparently seems to be caused by their Android update (and thus likely will just happen again once I update my phone), they told me to replace my battery…

Can ANYONE ELSE confirm that this issue is fixed by factory resetting your phone or replacing the battery?? I’d really rather avoid messing around with my phone like that, only for the issue to reappear, but the support seems to completely ignore the possibility that this issue is caused by the Android Update and should be fixed by them.

What have you done to find the route cause of the issue? Doing a factory reset btw does. Ot touch the OS so if the OS is the issue really it will not help.

I haven’t really been able to find the root cause of the issue myself yet, all I know is that it’s been happening since the last Android update and that the battery doesn’t drain if I put my phone on airplane mode.

I’m very hesitant to simply try a factory reset if I’m not even sure that this would fix the issue, though, since that would mean hours, and likely weeks of effort to try and restore everything necessary on my phone and then still lose a ton of stuff. And doing all that, when it might not even fix the issue seems painfully counterproductive.

Try safe mode dic:safemode

Try to take out the SIM.

Do you use a SD card and how is it formatted.

Is the Wifi connection stable…

1 Like

My Wifi connection is stable (and turning of Wifi itself doesn’t solve the issue, only airplane mode from what I can tell) and I’ve already tried Safe Mode with no difference. I will try taking out my SIM.

so i’ve had my SIM out for about 4hrs and left my phone to mostly idle and can report a power loss of about 2-3%, which is significantly less of the 5% per hour i had before