Fp4 and SD card

Good evening,
A 256 GB Sandisk memory card cannot be installed.
Fp4 and SD card

Did you have a look at this topic?


How is it formatted? Internal or external?
What do you mean with “can’t be installed”?

For general advice about SD-cards, please read the #sdcardguide.

1 Like

The card seems to be formatted but not recognized by the phone. Software installation does not work even formatted on another device.
256 GB Sandisk extreme
External device
I use the same card on the Fp3+ without problems

Same result with my new FP4. I tried Sandisk extreme plus 128GB and Sandisk ultra 200GB, formated as external storage. After a while copying stops with the message, that some files resp. folders couldn’t bei written. In /BugReports/shell some files are written - size 0bytes.

I tried partition types GPT and msdos as well, using different sizes (32, 64, 128GB), ending up with always the Same result. My old 32GB works well. Both new cards are fine with an Xperia XZ1 compact running HavocOS and an Android 10-LG.

Is any success Out there using SD cards with a size more than 32 GB storage…?

I had an Sandisk 128 gb micro sd card in my old nokia 7 plus, formatted as external storage. But I couldn’t get it work in the FP4. Then I tried a 128 gb samsung from my husband. It worked. So I bought a Samsung Evo Select 512gb UHS-1 , formatted with FP4 as external storage and all works fine now.


my 64 GB Sandisk worked fine out of the box without me having to do anything.

1 Like

I wonder if the version of Sandisk is relevant??

I use 128Gb Ultra A1 (Not in an FP4 though as I don’t have an FP4 ~ yet)

None of my SD cards are working, they are not showing in File Explorer.
No recording possible on an SD card.
No white balance in the camera app etc…

There are currently known issues when formatting the SD card in the FP4. I understand you did try to format outside the FP4? What do you mean with software installation is not possible?
Please see here as well

Thank you for the explanations.
i have to buy another smartphone to format my sd card?

No, you can use any PC.

Seems to be a problem with the kernel modul. As described above I tried the cards by formatting with others phones, a PC running Linux and Win10.

After spending more than 40 € on two Sandisk cards, I prefer to spend the next 20 on some glasses of König Pils and wait for the next Update :wink:

Merry Christmas!


I’m using my FP4 with a Samsung EVO Plus 512GB and it worked as mobile storage out of the box.


I just noticed that we didn’t have a SD wiki for the FP4 yet so I just created one:

Everyone with a working SD card, please add your findings there.

Unfortunately I don’t know what exact model my SD card is. :laughing:
Some SanDisk 128 GB I already used in previous phones.

Edit: I managed to find the printed receipt from 2017 and was now able to add my entry :rofl:


Thx for creating that wiki.
I added my SD card.


Lexar 1 TB (https://www.amazon.de/gp/product/B08W4MLPJD/) FP4 formatted as extern, copied the Data on it with my PC (musicfiles, took some hours). Fully functional!

Had a SanDisc 1 TB before - did never work correctly, but functions perfectly in my Steamdeck.

1 Like

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.