FP4 and LineageOS

In a few weeks or so…maybe.
Nobody know it, actually

1 Like

Hi Hulk, (is this because you bought the green model of the FP ? :slight_smile: )

OK, I can live with that. Thx!


1 Like

It seems /e/ sources are now published: e / devices / Fairphone 4 / android_device_fairphone_FP4 · GitLab


And also /e/ ROM :wink:


U can use iodeOS

6 posts were merged into an existing topic: FP4 - Rollout of the very privacy-friendly custom ROM iodéOS has started as Beta

We are working on it. You can already compile LineageOS for FP4 yourself if you have a device to pull blobs from:


Hi! first thank you for the hard work.

Could you provide a quick status on device support completion ? (ie. what works / doesn’t work, any known quirks, what’s left to do, anything you’d need help for…)

I’ve been eagerly watching your repo for a few weeks, but before taking the time to try my own build, I’d like to know if it can produce something in a usable state for me at this point.

btw, are there any special build instructions besides what can be found on LOS’s wiki ?
do you have another communication channel besides this forum to discuss LOS development on FP4 ? (most other devices have dedicated sections on xda forums, but I can’t find anything about FP4 there, except a few general threads from people asking the same questions…)


I have managed to build it myself and @Aaanze seems to be running it on his Fairphone 4. You can read more about how we figured out how to build it here and here.


oh great thanks! did someone actually try to install it ? :smiley:

Yes, I’m running it currently…
So far I did not notice any issue, it’s pretty smooth.
Only thing is for some reason (apparently system partition too small), I wasn’t able to flash openGapps, so if you count on using Google services, think twice before flashing it as there is no way back for now.
I will try to make another build with pico Gapps bundled and see how it goes.


That’s great news.
Would it be possible for you to share your ROM?
I don’t mind the no-Gapps restriction, not wanting anything to do with google is precisely the reason why I’m refusing to even use my FP4 with stock android.

1 Like

Sure why not.
You will flash this at your own risk though :smiley:

You will need:


1. Reboot to bootloader

adb reboot bootloader

2. Flash Lineage recovery:

fastboot flash recovery recovery.img

3. Reboot to recovery.
If stock recovery boots instead (happened to me at first) just go back to bootloader and run:

fastboot boot recovery.img

4. In recovery: wipe data / Factory Reset - there’s no way back to FPOS (for now) after this

5. Still in recovery: Apply Update → ADB Sideload → Install from ADB and run:

adb sideload name_of_the_lineage_file.zip

6. Attempting to flash GApps will probably fail due to lack of space on system partition (although nothing prevents you from trying if you want to give a shot, please report if it worked)

7. Do not flash Magisk as it will throw you into a bootloop. You will be able to root the old way later like this:

a. Downloading boot.img on your device
b. Installing Magisk apk
c. Patch the boot.img with Magisk
d. Copy the patched file on your computer
e. Reboot fastboot and fastboot boot your_patched_boot.img
f. Open Magisk and run installation
g. Reboot

8. I “THINK” you should reboot bootloader before boot and run (untested):

fastboot erase metadata

I didn’t do it and have a “E: couldn’t mount metadata” error everytime I try to flash something in recovery, though it doesn’t prevent lineage installation.
It appears to be the last instruction in /e/ OS installation procedure.
If you run this command please report :blush:

That’s about it. I only ever built 2 ROMS and they are both iterations of this very one which gives you an idea of my level of expertise. Bottom line: don’t expect high end support (I’ll do my best though). I find myself constantly asking for help around here :smiley:


Hey @dk1978 ! Thank you for the info. I know, asking for ETA is ugly, but could you please give a some info on what is the show stopper at the moment, so that we can get a feeling if we try @Aaanze 's build (and do a fresh installation if official LOS comes available) or if we should wait another few days (or weeks)? Is there anything a non-developer can help you with? Shall we donate to team LOS or do you Fairphone guys have a donation page?

Best and fair regards! :slight_smile: :heart:

I have a device ready and happy to start testing, I did not really even bother to start setting it up, as in the current state without de-google-ing it has no use for me, so no need to worry about data lost and etc, of course I don’t want to brick it, and of course I prefer to build the release myself, or at least able to validate the hash, but if you need more testing, count me in.

Would be awesome to get it on the officially supported device list. :crossed_fingers:

Yes, no ETA from my side. There is no show stopper unless you consider limited free time to work on the stuff as a volunteer. Not much you can do about it either, unless you want to become an Android dev.
That being said, you might get away with running an unofficial build and upgrading to official later without losing data. No guarantees whatsoever - but that has worked in the past for 17.1 and 18.1.


Great work @Aaanze, I just flashed your pico build and first impressions are good.
Am able to install apps from the Play Store, will have to test location quality later.
I did not do the fastboot erase metadata and also did not install magisk.
Thanks for creating this build!


Wow awesome ! Thank you so much for testing and reporting, I was actually just going to flash the pico gapps version myself as I definitely can’t stand the “degraded” maps performances.

1 Like

4. Wipe data - there’s no way back to FPOS (for now) after this

5. Install Update → Install from ADB and run:

adb sideload name_of_the_lineage_file.zip

What am I supposed to do here? When I boot into the LOS recovery I can’t use any adb commands (adb: sideload connection failed: device unauthorized.). And the only way to wipe data from the recovery is factory reset but after that USB debugging is disabled. Am I doing something wrong?

You should be able to perform a factory reset or data wipe from within the recovery. After you’ve done that, you select “Apply Update” and then “Apply from ADB” or something similar.