FP4 and (unofficial) LineageOS

Wow awesome ! Thank you so much for testing and reporting, I was actually just going to flash the pico gapps version myself as I definitely can’t stand the “degraded” maps performances.

1 Like

4. Wipe data - there’s no way back to FPOS (for now) after this

5. Install Update → Install from ADB and run:

adb sideload name_of_the_lineage_file.zip

What am I supposed to do here? When I boot into the LOS recovery I can’t use any adb commands (adb: sideload connection failed: device unauthorized.). And the only way to wipe data from the recovery is factory reset but after that USB debugging is disabled. Am I doing something wrong?

You should be able to perform a factory reset or data wipe from within the recovery. After you’ve done that, you select “Apply Update” and then “Apply from ADB” or something similar.


Thank you, that worked

Edit: Finished the installation (with gapps), right now everything seems to work.

1 Like

Sorry about approximate instructions, I updated those ones, hopefully to be more understandable :slight_smile: Glad it worked !

1 Like

Did you already try apps that depend on Play Services (like Whatsapp backup or Google Drive)? It says “Your device does not support Play Services” for me

Hmm I’m running Google maps without any issue, drive is flawless too.

I did erase metadata partition in the installation process but I can’t see how this would be of any effect on play services

Yeah drive itself is working but apps depending on drive for backups can’t access it and just say “can’t run without play services”. Downloading a play services installer didn’t work and the play service info app says that play services are installed.

You shouldn’t have to install play services, it’s embedded with the ROM.

You did flash the correct ROM with gApps ? Did you have a the play store installed when you first booted ?

Yes to both. The installer also told me that play services are already installed but the apps I’m trying to set up don’t seem to care about that.

There’s something that went wrong with your installation then…
WhatsApp backup with drive is fine here

I would suggest try all over again and not forget to wipe everything. After the first factory reset, before flashing the ROM, go back to bootloader and run > fastboor erase metadata then back to recovery and sideload the ROM.

Reinstalled, same problems. Whatsapp is a weird exception because it can’t restore any backups but it can create new ones but I still get the same error message everywhere else.

Could you try it with this app: https://play.google.com/store/apps/details?id=net.daylio&hl=en_US&gl=US ? When I go to settings/backup I get the error

Hmm went fine:

I don’t get it… What am I doing wrong? I haven’t even rooted the phone yet thinking that might be the problem

Could you try updating manually to latest Google framework ?

No, same as before. The installer tells me that play services already exist but that I can install the update. After installing and restarting I still get the error

Alright… what about:

  • going to settings → apps → show system apps
  • clear cache + data for Google services
  • reboot
    Check in play store if a Google service update is not pending if so do it
    Then try again…

I can’t even find the play services in the play store… I suppose that’s part of the problem but I have no idea what to do about it. Clearing cache and data didn’t work, sadly

I’m usually not fond of those “articles” but procedure is worth a shot too

I mean we already tried all of that. Just tried it again (and updated with the apk) but it didn’t fix it.