English

FP3 very slow after drop

Hi!
I dropped my FP3 two days ago. It was a relatively small fall (0.5 meter). Suddenly the phone doesn’t react as always.
Fingerprint reader doesn’t work anymore. I have to press more than once the power button to get to the lock screen to unlock it. When it happens, the message of “too many tries with the fingerprint” is always there. If I try to unlock it with the pattern it fails sometimes. Then everything is slower: opening apps, pulling down the notification bar, swapping desktop screens… When I lock and unlock it 3 secs later it takes a whole second to go from black to the unlock screen. If I wait more than 3 secs, I have to press repeatedly the power button again…
I let it die, recharged it and turned it on again and took longer to ask my the pin. And now the touchscreen doesn’t work at all.

It looks like the processor died or got broken or something like that. Did anyone have an experience like this? Does anyone know which part is to be replaced?

I would apreciate any help.
Thank You!

1 Like

Hi Garflik,

it’s hard to know which part has been damaged without swapping parts: do you have an Angel living nearby, so you could try to exchange parts?

In the waiting time, you can try to disassemble & reassemble the modules of your Fairphone and see if it changes anything.

I’d suspect your screen to be disconnected and the fingerprint reader as well, or worst, the core module to be damaged, but for this you might need to contact the support. Hoping they’ll take in within the warranty, otherwise it might be pricey, I don’t know what’s their policy with small falls…

5 Likes

It’s likely not the processor, nor anything at the core – usually computers die if something vital breaks. Would guess for some lose connection, which keeps the phone busy (e.g. bad sensor or bad connection, causing a lot of weird signals or retry-to-connect-loops).

I would not expect something on the circuits to really break from 50cm drop, but you actually wouldn’t know.

Dis-/Re-assembly would also be my first suggestion. Swapping parts for testing my second.

5 Likes

Thanks @Antoine and @swhcz for your suggestions.
I decided to try the dis-/re-assembly and I noticed something that seems weird to me:

I removed the display module and found that the metallic “frame” is a bit loose on one corner. When I press on the corner marked with a red cross it moves down a little and makes a click sound (picture taken from a Youtube video). It looks a little bit loose to me but could be normal too…

imagen

2 Likes

There is just a flex-cable connector at this spot, see here on ifixit. That shielding also looks rather safe (and not that difficult) to remove for checking underneath (though I have not tried it).

On my FP3 this corner doesn’t seem to move at all when pressing it (also no clicking).

Have you tried enabling Developer options -> Android debugging and checking the adb logcat output? If there are connection problems with a submodule you might find some related error messages.

2 Likes

Hello again. I took all modules apart and put them all together again and it seems to work well again. The hypothesis of the loose connection seemed to be right. Thanks for all again.

9 Likes

Nice!
Happy to hear!!! Crossing fingers it’ll hold up!

1 Like