FP3 touchscreen experiences ghost inputs

Update: Ghost inputs and freezing screens have started to appear again after being absent for 3 - 4 weeks, as seems to be the case with other users here. Will take the phone apart again and do the same thing (humidity is not a factor with me, as it has been getting colder!)

I realised I never updated this topic:

I’m not convinced that pressing on the display module connection is the solution; I disassembled, tightened and reassembled the phone multiple times whilst trying to figure out what the problem was. On the other hand, when I sent it off to be repaired it came back working perfectly and hasn’t had a single ghost input since - that was 6 months ago.

It’s possible that there’s 2 potential causes to this issue, but IMO at least one is faulty hardware.

Now we are in a low coverage 4g area and the problem is worth.
Maybe the problem came from the base-band something like that which take all the resources and make the phone like laggy.
how can i record the process usage, or processor consumption ? .

Plug your phone into a computer, make sure you have adb working and enter adb shell top. Otherwise you can also enter su then top in a terminal app like Termux on your phone.
You should get all the processes using the processor.


Thank you Moaxle,

Your tip solved my problem (request #408252 on Fairphone’s troubleshooting page).
Now my Fairphone 3 works like a charm. Hope this will last!!




I don’t think that’s what causing the ghost touches. A few days ago I did activate an overlay in the developer settings which visualizes the locations where the touchscreen registers inputs (I think the menu option is called Pointer Location). The locations of the ghosttouches become visible and you can take a screenshot of them. They are usually single spots, placed randomly all over the screen - I observed up to 10 “ghost fingers” at once. I don’t have my phone with me right now, I’ll probably upload some of the screenshots later.

1 Like

You don’t think that’s what causing the ghost touches but lots of people, on other phones have problems based on lake of network signal. that a feeling that i recognize.

Other things always before random touch there is a phase like freezing or delay. I explain you have to touch like 1 second to make the touch effective then release.

on eloo forum i post a video of my ghost touch. https://gitlab.e.foundation/e/backlog/-/issues/1398 the blurk arrive just at the end

Keeping this post alive!

It has became too much annoying. When you need to use your phone, it makes it useless (touching and scrolling screen wherever it randomly wants. Causing lot of troubles!)

  1. For the first time ghost inputs were in my phone for about 3 weeks then dissapeared (still had a faith in the cause)
  2. After month or two it came back. So I contacted support.
    Got thru given steps like: developers menu, testing screen, etc.
    Nothing given helped
    After a week or so the problem disappeared by itself and I couldn’t continue with problem solving
  3. It’s been back again a while… I AM RETURNING THE PHONE. It ain’t fair enough


Did you try the tip suggested in post#28?

1 Like

Yes, I did.
I also found, thanks to this, some marks on the inside around one contact that probably shouldn’t be there. Will post it later in reply.
That might be the problem but considering that it comes whenever it wants I suspect OS more than that

Martin, this is odd. I ended up getting a replacement display from Fairphone and I went through support before you. I would insist that they send you the replacement display. It’s a documented fix for an issue that they have. Please have them see Request #396847

1 Like

Another suggestion I have is to carefully take off the metal covering in post#28 with a spudger (I looked under because I was curious) and de-, then re-seat the connection that is under there, replacing the metal part afterwards. This may fix your issue, although I am not sure if it is under a list of possible actions that may void the warranty.

I already tried Moaxle’s solution from post #28 but it didn’t help. My satnav became unusable just now because the ghost touches are messing up the navigation screen, leading to a bit dangerous situations.
I will try again, go this step further (remove metal plate and reconnect the connector) and report back here. If that fails, it’s time to ask for a replacement screen I think.

Here’s my situation from the begining:

  1. I checked this and other topics for “ghost touch inputs” NO CHANGE
  2. I contacted support PROBLEM SOVLED ITSELF
    2a) Did the following recommendations:
  • display tests
  • reset
  • reboot
    2b) closed the support ticket
  1. after a few months problem is back and I checked updated topics PROBLEM IS BACK
    3a) post #28 (resp. #27 @Moaxle’s tip)
    3b) phone reassembly
    3c) reset
    3d) NO CHANGE
  2. I contacted support
  3. Now I am ready to recieve new display module from FP and change it KEEP YOU UPDATED


The software update 8901.3.A.0077.20201221 released yesterday should address this issue. Did you try that already?


I updated to the latest version and had no ghost touches since. It’s early to tell of course, but I have high hopes.


Just wanted to drop in and mention that I had the same problem, ghost touch inputs near the top of the screen, and it seemed to be related to being connected to a 4G network (at least the frequency was much higher). After trying things in this thread like pressing on the display connector the problem persisted. So I contacted Fairphone support, and they asked me to provide some information on how and when the problem occurs, and asked for video evidence. In the end they determined that I am eligible for a display replacement. After swapping the display myself the problem has not reoccured for more than a week now. So all in all I am very happy with the service provided by Fairphone.


I lived with this for months, and finally after trying @Moaxle’s approach the second time it occurred to me to make sure the open connector above the silver one in the images was well connected.

So I cleaned it with alcohol and then when reassembling the phone, I very slightly over-torqued the two screws which holds the two sides in the connector together.

Now it’s been a week, and I have had no more issues.

Hopefully it won’t be necessary to disassemble the phone very often because I worry about tightening the screws that tightly, but it works!


Hi. Is the problem solved ?