FP3+ stuck during boot and entering factory reset

I just rebooted my phone and now it is not booting anymore:
It gets stuck during the blue boot animation and after a few minutes it enters a factory reset screen where I can choose from “Try again” and “Factory reset”.
Tried “Try again” several times without success.
SIM card is removed, no sdcard installed.

However, I do not want to do a factory reset, before I can make a backup of my phone data (my last full backup is half a year old).

The phone is running official Fairphone OS with bootloader still locked and it got the latest update a few days before.


  1. How can I get the phone back running without loosing my data?
  2. Is it possible to mount the data partition from within recovery and e.g. transfer files via adb?
    I only found the option to enter adb-sideload mode from within recovery.


Out of curiosity when you had the SD card was it formatted as Portable/External or Internal.

If Internal then data on the SD card is encrypted too :frowning:

There never was a SD card inside.

1 Like

Yes apologies I clearly didn’t read you first post properly

No problem.

I for sure know, data partition is encrypted. But maybe there is some mechanism to decrypt it from recovery which I can successfully boot into?
I remember from earlier phones I used, that TWRP for example was able to mount the data partition and also to create backups directly to SD-card…

I wonder why a phone destroys its own file system while rebooting. Never had such an issue with any phone ever before.

I would need to add that some weeks ago my primary mic stopped working, which was the reason that I searched today in this forum and found out that with other people a comparable issue disappeard for some time after the phone has been rebooted. This was what I wanted to try.
Prior to the reboot I did the mic test from the service menu which indeed recorded only some noise from mic1, whereas mic2 was working properly.

TWRP is available for FP3 so I would give it a try, however the normal TWRP back-up does not include data/files…if you can Boot to TWRP you can probably use MTP to transfer files to your PC

1 Like

How could I install TWRP when the bootloader is locked?

Sorry I missed that and I think unlocking it will rease all data.

I’ m not sure if this works with a locked bootloader but did you try to change the active slot?

This topic might help at least with getting the phone back to work (about data I’m not sure if you manage to keep them).

There are several other topics to trouble shoot “bricked” phones, maybe one gives you some hint

Unfortunately, as of the locked state, the phone refuses to boot into TWRP using
fastboot boot <twrp-image-file>.

As you suggested, I tried switching to the other slot (a):

fastboot --set-active=a

which results in the phone rebooting directly into the “data corrupt / try again/factory reset” screen, so I switched it back to slot b.

In the above “TWRP for Faiphone 3” topic @k4y0z said:

How exactly to do this?
Sure, I still have my pin :wink:.
I guessed from the fastboot help output and tried fastboot fetch userdata ./userdata.img, but the phone answers, that fetch is not supported on this phone.

Another idea:
Would it help to again flash the latest OTA-Update with sideload mode?

I doubt you can flash anything while the bootloader is locked.

Here some further threads…

This seems possible:

But only under those special circumstances. And I think you’ll need to enter recovery for sideloading which seems impossible here…

1 Like

the stock OS script is not made for this, or? so how to extract neccesary files? For any other ROM I guess you would have to “install” first another recovery? Not sure if this is possible through stock recovery via SD card?

hi, i have the exact same issue with my fp3 as the OP. wth is going on? is this some kind of hw problem?
since it is possible to enter recovery (at least in my case) where would i find the right file to sideload over adb? i downloaded FP3-REL-Q-3.A.0136-.gms-7c69ec7e-user-fastbootimage and decompressed it. not sure which one of those files should be used.

ok, managed to fix mine by following fastboot flashing instructions from here: https://support.fairphone.com/hc/en-us/articles/360048050332 with the exception of not unlocking the bootloader the standard way. i unlocked the bootloader before applying the instructions and relocked it afterwards with these instructions..
haven’t lost any data. \o/
now to quickly backup everything ^^;
@unclelutz i hope this helps you and i am not too late.

Hi @flup,
I just tried your solution, but it did not work for me, same behaviour after flashing the official package. Also tried SAFEMODE, same result.

Please update the link in your post, it is not pointing to the instructions but only the gpx-file:

I also tried to unlock, install TWRP, and re-lock bootloader again.
The phone is now telling me directly after power on, that it is corrupt and refuses to boot. After unlocking, it simply boots into TWRP every time - hm. Also, TWRP does not even ask for a PIN when mounting data partition - I don’t know why.

I have now given up to restore any data. Will try to install LineageOS now, because I lost my data anyway.

I’m really upset that a phone bricks itself. My wife is kidding at me for buying such a phone - “You should have bought a real one, HA HA…”
(Meanwhile I switched back to my old S3-mini to have a working telephone - this device is still working with a custom ROM after about 10 years!)

The file to be saved from the link is devinfo-unlocked.gpx. Searching for this filename results in

But yes, the general lack of proof-reading and proof-link-checking nowadays is to be lamented.

1 Like

hi, sorry for the wrong link and i can not correct it anymore. @AnotherElk found the relevant post. thx.
so flashing the official package succeeded but the phone was still dead? :thinking:
seems like nand corruption is common with modern phones nowdays.

Hi. This is my first post on this forum. I started following topics about unbricking fp3 just 2 days ago. A lot of learning… Thanks to everyone contributing and sharing their knowledge.

I have almost the same issue with my fp3 as unclelutz (including previous problems with microphone). Only difference is that my phone had suddenly reboot itself and never worked again since 2 days.

I will try to follow procedure which @flup did, within next few days. However before that I’d like to prepare and understand a bit more. I consider myself a novice in flashing process. I’d like to ask more experienced members of community a couple of questions.

  1. Are files devinfo-unlocked.gpx and devinfo-locked.gpx generic or specific to someones phone? And can I use files downloaded from this forum or I need files dumped from my phone. I’m asking because @k4y0z mentions in his post since unlocking causes the decryption-keys to change wiping data is still necessary (as it can’t be decrypted anymore). I guess here is my lack of knowledge. How to do it to still have a chance to get back data?
  2. Is it better to follow procedure FP3(+). Install Fairphone OS offline or use a script from topic “I bricked my FP3 and I hated it” mentioned by @yvmuell here

I’m asking these questions with the hope in my mind to get back the data. Do you have any advice to increase my chances?

Kind regards

Just to let you know that I did follow @flup 's solution, and it worked without any data loss :sunglasses:
To answer @Adam.W 's questions, the .gpx files are generic, and I followed the official fairphone guide (i had to upgrade android as the device was on 10 and only last 11 release is available, it was not an issue). The bootloader was locked and ADB not activated.
So the workaround is this (I’m just regrouping the infos as I wasn’t totally sure of them) :

  • Boot into fastboot mode (hold Vol Down while booting)
  • Download devinfo-unlocked.gpx (1 MB)
    -in a terminal with adb installed on your computer:
    fastboot flash devinfo devinfo-unlocked.gpx
    fastboot reboot bootloader
  • Then download the last Fairphone OS release and run the script to flash the OS update
  • Say no if it asks to wipe data or lock bootloader
  • When it asks for reboot hold Vol Down to reboot straight to bootloader
  • Flash devinfo-locked.gpx (1 MB) with fastboot flash devinfo devinfo-unlocked.gpx
    and finally fastboot reboot
    Good luck !
1 Like

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.