Fp3 sound recorder not recording

fp3 sound recorder not recording

Hi and welcome to the forum

That’s to say the least a bit minimal, you don’t say what you have tried . .

It may help if you say

  • What OS you are using
  • What version?
  • What app?
  • What are you trying to record?
  • Do you have an SD card and how is it formatted.
  • How much memory do you have left?
  • Have you tried a safe mode start, which disables custom apps.
  • Can you save personal data and do a factory reset.
  • Which microphone are you using?

You can test the mics
Dial *#*#66#*#* then Service test > Test single > Microphones The top one is a bout a quarter as quite as the bottom one

I’ve moved the post to a more suitable category.
Did you find other such issues by searching?

2 Likes

Thanks Amoun. The Android version is 11. I bought the phone a year or two back (build number 8901.4.A.0022.0), but have only just started using it as a main phone. Certainly I can phone successfully with it, talking, hearing and being heard. So microphone must be OK. There is an app on it called Sound Recording, which I tried to use this morning. It asks some permissions, access to files; I didn’t give it access to phone. When you open it, it has a screen which says “press record” though there is no icon called ‘record’. There is a button with largish red dot in it towards the bottom of the screen, which will click, but not record, and not change to another appearance. I am sure it is something simple; it seems to be like How to Record Sounds in FairPhone 3 – Voice Recorder App - YouTube, but does not record.

1 Like

If its missing permissions it cant record and especially file the record, so check the permissions to ensure alll required are enabled

3 Likes

The app (Sound Recorder) has access to the microphone and to all media and files - that should be enough should it not?

Cant check I dont use the preinstalled recorder, if any permission rejected I would enable it or if you dislike the permissions requested try another app like the one from simple mobile tools

1 Like

Thanks, yvmuell. If I give it phone access permission (in addition to permission to use the microphone) it starts recording. So, may try one of those simple mobile tools you pointed out. Thanks. Don’t see why it would require permission to access phone, which it asks for separately on first use, in addition to accessing the microphone.

If the app hasn’t access to the phone, how should it store the recorded data?

I understood that to mean ‘access to phone calls’ - in the permissions screen that has a phone icon (handset icon) next to it. It has been given access to ‘files and media’ and ‘microphone’, so surely it has access to the phone in general.

There is no permission to ‘phone in general’. I guess in order to record something, the app uses the telephone app functionality.