FP3 Software update: 8901-4.A.0021.0

According to another thread, you have to switch off and wait a bit to solve the problem.

Installed the update yesterday and - so far, so good, no problems :slightly_smiling_face:

Haven’t tried the camera yet though.

Just installed this update:

  • Booting to TWRP (adb reboot bootloader; fastboot boot twrp.img) no longer works, probably due to the “improvements” for managing system partitions. This essentially killed Magisk (used for full backups of the device, mounting of etx2 partitions, AdAway a.s.o. ) for me…

  • The support for a PIN-less second SIM is still broken: It always results in the PIN-less SIM being selected for telephony, ignoring any other preferences set.

I’ll admit to somewhat special requirements, but having updates break functionality is still frustrating.

4 Likes

Hi!

As an FP3 owner, I would be interested to know if the fp3+ owners noticed an serious improvement in picture quality ( I am not very optimistic by the way).

As the picture quality is not really good, if the camera + would be much better now , it will surely help me to keep the phone longer…

Regards

Michel

Hi

I didn’t notice an improvement, but then I don’t use the camera for anything ‘special’.

I’m sure there is some but the video in bright light is somewhat over sharpened.

Personally if I had a FP3 I wouldn’t rush to update the camera.

ideally find someone with an FP3+ or FP3 with the 48Mp camera and take the same picture to compare.

By the way, the 48MP is a 48MPs Quad Bayer so the output is 12MPx

After the update I opened the stock camera app for the first time in probably two years, took one photo, noticed it still introduced grainy noise even in the brightly lit clouds in the sky, and decided not to bother again.
If you want better quality photos, use a Google Camera based app. Neither the updated module nor this software update improve things in a meaningful way.

2 Likes

Hi. Thanks a lot for your replies! So as I expected it is not worth it to change the module.

Regards

Michel

1 Like

I updated yesterday evening.

At the moment nothing seems to have been broken which is quite a good result to me. :slight_smile:

One thing that always scares me is when I reboot the phone to complete the update and it doesn’t connect to the internet. I usually have to reboot twice or to play a bit with flight mode (enable it and then disable it) to have data connection working again.

This is a funny behavior that started some 3-4 updates ago and it’s till there.

Before updating I got a picture with my OpenCamera and then again the same picture after the update but didn’t notice any difference. I know this is not the right way to test a new feature but I didn’t feel like inventing a better test bench.

Ciao,
Max

1 Like

Hi everyone,

I have not installed/bought the"new" camera modules for the FP3 and was wondering if the quality improved with the last update. Comparison pictures before did not convince me to make the purchase.

Does anyone have an update on this?

See above. Nobody so far has seen a difference, and even if there is one the image quality with the stock camera app is still very bad compared with the Google Camera based apps. Use one of these if you want better image quality, don’t bother with the new module.

Edit: Back in 2020 I posted a few pictures taken with the old module and a Google Camera based app here. IMHO it’s a far cry from the stock software, and almost hard to believe it’s the same hardware.

1 Like

Both issues bother me, too. Sadly, I didn’t find any way to restore root again…

After installing the latest system update last night, the same “no mobile data for EE UK network” problem has returned.

As this refers to version 19.1 not 21 and has been solved [Solution] please delete the post here and add it to the current update topic, though I imagine the issue may be the same.

See you there :slight_smile:

Could you solved it by adding a new APN as before?

Moved your post to the current update topic.

1 Like

A possible problem.

In response to a topic I can confirm the Fingerprint Test via the Service tests > Test Single does not work.

Apart from the text on the screenshot below there was a brief message the bottom of the screen that states Not installed

Screenshot_20230226-152420_1_1

Can someone check this please ?

Thanks

The fingerprint reader does work, it’s just the test that seems a problem

1 Like

It seems to have resolved itself without adding a new APN this time :+1:

3 Likes

Anyone using Termux (or identical apps) for letting scripts run on the phone? Seems to be broken after the update.

By the way, with this new update the selfie camera of my FP3 (standard camera module) works again in applications like Nikita’s GCam mod :smile:

1 Like

Can you describe the problems in more detail?
I am using termux (and tasker) for quite a bunch of things, and cannot confirm any problems with that update.

1 Like

I am using Tasker without root and this work-around to start adb-wifi on (re)boot of my device:

It worked marvelous before the update, but not thereafter. I thought there might be an issue with termux, but I tested somewhat and find, there is an issue with adb-debugging over wifi. The phone simply does not pair with the wifi. If you have any suggestions, I’d be thankful for sharing.

I just have seen, you’re from Germany like me, we could switch to German, if you like.