FP3 - SD Card as internal storage - Data Lost

I can imagine, :woozy_face: it’s not a well communicated problem. Luckily I just used an old SD card from another phone and only read about it here.

I think people that are used to using an SD card as a backup would not select the ‘internal’ option as it is not portable.

But the current situation I agree is apauling. Fairphone get a license to use Android and have to pass over 500,000 tests to be ‘allowed’ to use it and it is baffling as to why this option hasn’t been sorted since Andoid 6

My cynical thinking is that google want people to use their cloud and are not putting any effort into resolving this and it seems beyond Fairphone’s ability to resolve it internally.

Rather disturbing and very upsetting for those that fall foul of this failure.


I can very much understand that issues such as this can be really hard to solve reliably, especially when it’s not something phone manufacturers screw up themselves but inherit from up the software stream.

But there was a (too) short while back in Android 9 times when this feature was not easily available via GUI.
So I can’t understand why hiding this feature or at least a big fat “use at your own peril” warning shouldn’t be possible.


I just expireiced a very similar situation. I added a SanDisk microSD Card with 256 GB and after a restart all pictures that were stored on the internal storage were gone…

Hi and welcome. Sadly if you have read all the similar posts and other topics you will find it difficult to retrieve.

The SD card cannot be read in another device as using it as internal memory means, like the inbuilt SSD, the SD card is encrypted.

The only home made hope you have is to connect to computer and scan for the files and especially any deleted files and try to recover them to the computer.

Then of course reformat the SD as Portable.


Same thing happened to me.

Camera-app requested more space. Insterted a new blank PNY 128GB sd-card.
Ran default setup as suggested (increase internal storage), and accepted to transfer all photos to the sdcard as suggested by fairphone/Android after formatting. Then after reboot, no photos or videos.

sd-card is 100%, no problem with it.
Via PTP not possible to access the SDCARD/DCIM/Camera folder:

“Sorry, could not display all the contents of “Camera”: libmtp error: could not get object handles of 00000001e”
Same problem with SDCARD/Pictures folder.

Seems to have lost 12 months of data.
Of course I should have made backup before this stupid attempt to trust Android moving images for me.

Is there a way to use testdisk/photorec on the Android internal storage to try to scan for the deleted files?
Is there a way to find the encryption key on the Fairphone android to try and mount the sdcard on linux?
What filesystem does Fairphone/android use for internal storage?

I urge Fairphone to add a warning to this approach stating that this method may lose your data, and that you should try to make a backup of the photos prior to moving files this way

Fairphone is a great product, except for Android which is shit.
Maybe I should go back to Sailfish OS. At least there I felt safe and were in control and were able to make perfect backups of everything for 8 years without involving a google-account.


Well… Some tried to guess, but it’s hard to tell…
Here an example, where the answer was:

Part of the key is what you put in for encryption, parts are taken from the phone (motherboard serial number, etc.) And they’re built on the fly, not stored. That’s why you can’t put an encrypted card into another phone, then decrypt it.

Now… people on the forum tried before you.

You will find documentation here:


Unfortunately, this is just way over my knowledge.

One last useful link I just found: Adoptable Storage  |  Android Open Source Project

which states:

Because the contents of an adopted storage device are strongly tied to the Android device that adopted it, the encryption keys should not be extractable from the parent device, and therefore the storage device can’t be mounted elsewhere.

So the answer is: Google made it as hard as possible not to find out the key. You can try to find out, but I doubt you will manage.

The one thing I see you might want to try is the following workaround on another topic about this issue (which you can read for tips if you wish) the time for you to backup your data:

It might not work. I just think it’s worth a try :slight_smile:


You can’t run photorec on the SD-card as it can’t be mounted elsewhere, and I doubt you can have it run on the storage of the phone… Experimenting shouldn’t hurt as it works in read-only. Good luck!


Thanks for the tips!

Luckily i made a raw backup of the phone bit over a month a ago with adb, and luckily the images and videos was included in that file. So, my real frustration is how badly the encrypted SD-card thing is implemented in Android, and the fact that is it near to impossible to recover it. Might be this way because they expand the internal storage instead of format it as a separate encrypted partition. Should have read more about the subject before i tried it out.

Strange observation was that the camera-app was not allowing me to store more data, even though I had more space left on device… I could still use signal to take pictures and videos. Why this limitation?

Anyway 15 years since I last time lost some data, due to erroneous “rm -rf” command as root. Guess that karma finally caught up with me again…

‘They’ didn’t do anything, it’s a user selection when inserting the SD. It just so happens that a) the Internal option is the top|default option b) for those that don’t want to think about it.

For those more people with more simple and common use, then their personal videos etc. are encrypted, which makes sense. For those who are more able to manage day to day security of data they can choose the unencrypted option to format as external.

I’m trying to estimate. Out of the hundreds of thousands of FP2/3/4 users I may have seen 100 people who have a problem with an SD card formatted as internal, how many people format as internal is obscure.

I had this frustration some time ago when my phone died due to a factory defect. The data on the card wasn’t recoverable. Luckily, I only lost a month of data as well since I also had a backup. It’s rare to see people who do it regularly, many think of doing it only afte having lost one year of data…

Indeed you are right. If you haven’t stumbled on it yet, please have a look at the #sdcardguide.

Well… I can’t tell, I would believe it’s due to a bug which blocks the whole internal storage from working properly, more or less severly, and depending on the apps.

1 Like

Hi, I have had a similar issue - phone ran out of storage, so I added an SD card and chose the option to move the data to the SD card. Now all my photos are gone, I can’t take new pictures and I can’t download any pictures. Plus some of my apps are buggy. We tried photo recovery apps, a computer shop and I emailed Fairphone but they just pointed me here and advised backing up and a factory reset. I assume the photos are lost, has anyone got any advice? THanks, R

Hi nd welcome to the forum.

Regarding recover of photos etc. The cost of recover would be £$££%$ as the memory chip would have to be removed and decoded probably.

The option to move data to the SD card is not really the issue, it’s selecting expand Internal memory which then encrypts the data on the SD card.

All you can try is to uninstall any custom apps which may free up enough space to get the SD card to respond.

Also I’m not clear about what you did.

  • Insert SD card
  • Was it pre formatted?
  • Did you select to format as Internal
  • In or immediately after formatting did you select the option to move data and apps to the SD card
  • did you then immediately have a problem or was that later

Hi, thanks for the reply. I…

  • inserted San Disk 128gb card as my photo storage was full
  • clicked the option to move the photo storage to the SD card (there wasn’t an option to format as internal)
  • as soon as I clicked it, the data and apps stopped functioning and still don’t

Any help gratefully received as they are baby photos and I am devastated, R

I would pay for data recovery (within limits) if I thought it would be possible to retrieve the photos.

You may have not noticed the format ‘catch’

Can you now not move them back as in. Removing the SD via the inbuilt option?
With the phone off

  • Remove the SD card and insert in a PC
  • Read the SD card memory

If you can read it then is there a difference between the recorded size, not the advertised and the free memory: Indicating that the images or something has taken up space

If the usage is unreadable then you did format it as internal

You may notice that Android created a lot of folders on the SD card, check them individually.

if you can copy the whole saved files, readable or not then do that as a backup.

Once you have a backup try to restore via any inbuilt SD options, even if that means reformatting, it may provide an option to move the images.

Before you try moving them back, you will need space on the internal memory, so check how much you have.

  • Clear the storage and cache of every app ~ time consuming ~ well ten minutes.
  • Remove any apps you can just re-install later

Hi thank you, the SD card is not readable by external devices, does this mean I have formatted it as internal? Thank you for your suggestions, we will try them and see if we can recover anything this way.

As, from what I can gather, your phone is still working, you can check the status of the SD card in the phone.

With the SD card in the phone switch on and go to
Settings > Storage

You should see an SD card entry
If it is portable you will see an eject icon to the right, if not then sadly it was formatted as Internal . . .

Hi, thank you again. The SD card is readable and has visible folders (most of which are empty) and there are some photos on there but a fraction of what I had. It doesn’t have an eject option though.

B is trying to help me, but doesn’t understand what you mean when you say about backing up and reformatting the SD card - how would you do this? The SD card isn’t visible when plugged into a computer.

We have contacted a data recovery service to try and get some of the photos back :crossed_fingers:t2:R

Ps apparently I have lots of space (now, because my photos are all gone) and the SD card is responding :slight_smile:

So it isn’t clear but with no eject icon then yes it has been formatted as internal and encrypted, so only readable on the phone.

You cannot remove the SD and start the phone without it without also having some more problems.

The SD is responding to what the phone or a PC?

It’s functioning as an SD card (I think) but my phone is still not able to take photos or send and receive them in WhatsApp. I will reformat it but I first want to try and get the photos off it, via a data recovery service (if at all possible)