FP3 - SD Card as internal storage - Data Lost

Hi @Grass Welcome to the forum.

Do I understand that you have reformatted the SD card and hence have lost media and docs you had stored only on it whilst it was formatted as internal?

Apart from the issue of formatting as SD cards don’t last forever I always keep at least one backup of all my docs etc. on a separate SD card

Probably you find EN instructions for this and there is a way to recover

Same issue here.
Inserted SD card - since the camera app told me that is was running of out space on the SD (no SD was installed previously) - but so i thought to top up my storage by adding an SD card is not a bad idea. Fairphone forum suggested to do so too.

Only the Pictures that I took are lost - all other data are there. camera app does not save pictures anymore and downloads also don´t function any more.

Hi. @greenpeacealbert
As far as images not being saved along with downloads, have you checked the saving options?

Before this option arrived, with Android 6, it was simple. Use an SD card to store images and the phone memory hardly ever got used.

I have an SD card that I have moved through 5 phones with all my videos, images, music, documents, contacts, messages etc.

Never had a warning about memory.

It’s a really poor use to encrypt an SD card so that it can only be used on the phone that formatted it.

I have always seen SD cards as portable storage and back up, why anyone would do otherwise baffles me a bit, though I can see

the camera app told me that is was running of out space on the SD

would prompt some action but why not just insert the SD card and move the personal data, without encrypting the SD card ?

Surely if someone doesn’t keep an external backup they must know they will loose everything if the phone dies and who’s going to backup every message and image at every event. And why trust a cloud to keep my data safe??

Not quite sure if I understand that comment

  • the camera app told me that i was running out of storage space (and referred to the storage as SD - even though no SD card was installed at that time).
  • I have not encrypted my phone; i feel that my understanding of the hard- and software is there for too limited.

the storage setting of the camera was set to phone. As the SD was for mated as phone memory (the subject of this thread) - i could not change the camera storage.

I wanted to report the issue - being unable to download thing, trough the browser or even whatsapp pictures, in the context of the SDcard.

my pictures were uploaded to my google account (bad privacy, I know - but incredibly continent), so I lost the high resolution pictures.

I now ejected the SD card (thanks for the guide @Alex.A), after some difficulties. And hope that everything is now back to normal -
At least I now got 20 Gb of storage for my pictures free again…

3 Likes

The phone uses an internal solid state drive more properly called an SSD

The memory is automatically encrypted, so the only option is to have an SD card inserted and fomatted as Portable to stop it being encrypted.

These two things are at odds

For historical reasons in Android, the internal storage is sometimes called SD-card. In this case it refers to the internal storage.

AFAIK FP3s are encrypted by default.

3 Likes

This happened to me as well. Inserted an SD-card. Got two options. Did not understand the difference between them. Just clicked the first option (that must be the recommended solution, right?).

(…) waiting (…)

Next:

  • Images, video, recordings… everything lost.
  • A lot of apps not working properly.

ADB restore got me back. But data are still lost.

WTF…

LineageOS next!!!

… which should give you the same choice for the SD card, with possibly the same consequences. But it has other advantages, of course.

4 Likes

I have the same problem: I bought a new SD card (256 GB), formatted it as internal storage and started taking photos and installing apps. For one week everything worked fine. Since then the SD card is only partly recognized: The apps installed on it still work, the system shows me how much space on the SD card is occupied, but I cannot access the data anymore.
Is there any way for recovering my photos?

Hi and welcome to the forum.

You can try deleting the cache on as many apps as you can.Maybe even delete some to free up and kick the memory access.

Starting in safe mode disables all your custom apps but not images.

This is a difficult issue to resolve

I bought a SD card of 256 GB because my local storage was almost full.
At first I had issues for the phone to recognize the SD card and finally I was able to set it up but I lost ALL of the pictures I took in my phone and maybe 1/3 of apps are fucked up and cannot start even after clearing local data and restarting the phone.

This is ridiculous to have such a bug. How can you pretend to have a durable phone with such an enormous bug… And pretending that you didn’t solve it because it’s not possible to reproduce it is ridiculous…

You need a f*** guide to explain how to install a SD card in a Fairphone… come one … How I am supposed to know that I should read the community forum before doing one of the most basic things : extending storage. And of course now it’s too late and I lost everything.

I don’t think I am gonna recommend this phone any more to my friend, this amount of bugs is too high. FP should invest more time in the software.

Hi and welcome to the forum, I note your annoyance, but apparently this is not exclusive to Fairphone or Android 10

ok, sorry I miss that out due to my frustration. Another friend that bought the phone had the same issue…

I can imagine, :woozy_face: it’s not a well communicated problem. Luckily I just used an old SD card from another phone and only read about it here.

I think people that are used to using an SD card as a backup would not select the ‘internal’ option as it is not portable.

But the current situation I agree is apauling. Fairphone get a license to use Android and have to pass over 500,000 tests to be ‘allowed’ to use it and it is baffling as to why this option hasn’t been sorted since Andoid 6

My cynical thinking is that google want people to use their cloud and are not putting any effort into resolving this and it seems beyond Fairphone’s ability to resolve it internally.

Rather disturbing and very upsetting for those that fall foul of this failure.

2 Likes

I can very much understand that issues such as this can be really hard to solve reliably, especially when it’s not something phone manufacturers screw up themselves but inherit from up the software stream.

But there was a (too) short while back in Android 9 times when this feature was not easily available via GUI.
So I can’t understand why hiding this feature or at least a big fat “use at your own peril” warning shouldn’t be possible.

4 Likes

I just expireiced a very similar situation. I added a SanDisk microSD Card with 256 GB and after a restart all pictures that were stored on the internal storage were gone…

Hi and welcome. Sadly if you have read all the similar posts and other topics you will find it difficult to retrieve.

The SD card cannot be read in another device as using it as internal memory means, like the inbuilt SSD, the SD card is encrypted.

The only home made hope you have is to connect to computer and scan for the files and especially any deleted files and try to recover them to the computer.

Then of course reformat the SD as Portable.

2 Likes

Same thing happened to me.

Camera-app requested more space. Insterted a new blank PNY 128GB sd-card.
Ran default setup as suggested (increase internal storage), and accepted to transfer all photos to the sdcard as suggested by fairphone/Android after formatting. Then after reboot, no photos or videos.

sd-card is 100%, no problem with it.
Via PTP not possible to access the SDCARD/DCIM/Camera folder:

“Sorry, could not display all the contents of “Camera”: libmtp error: could not get object handles of 00000001e”
Same problem with SDCARD/Pictures folder.

Seems to have lost 12 months of data.
Of course I should have made backup before this stupid attempt to trust Android moving images for me.

Is there a way to use testdisk/photorec on the Android internal storage to try to scan for the deleted files?
Is there a way to find the encryption key on the Fairphone android to try and mount the sdcard on linux?
What filesystem does Fairphone/android use for internal storage?

I urge Fairphone to add a warning to this approach stating that this method may lose your data, and that you should try to make a backup of the photos prior to moving files this way

Fairphone is a great product, except for Android which is shit.
Maybe I should go back to Sailfish OS. At least there I felt safe and were in control and were able to make perfect backups of everything for 8 years without involving a google-account.

TL;DR: No

Well… Some tried to guess, but it’s hard to tell…
Here an example, where the answer was:

Part of the key is what you put in for encryption, parts are taken from the phone (motherboard serial number, etc.) And they’re built on the fly, not stored. That’s why you can’t put an encrypted card into another phone, then decrypt it.

Now… people on the forum tried before you.

You will find documentation here:

https://source.android.com/security/encryption/metadata#configuration-on-adoptable-storage

Unfortunately, this is just way over my knowledge.

One last useful link I just found: Adoptable Storage  |  Android Open Source Project

which states:

Because the contents of an adopted storage device are strongly tied to the Android device that adopted it, the encryption keys should not be extractable from the parent device, and therefore the storage device can’t be mounted elsewhere.

So the answer is: Google made it as hard as possible not to find out the key. You can try to find out, but I doubt you will manage.

The one thing I see you might want to try is the following workaround on another topic about this issue (which you can read for tips if you wish) the time for you to backup your data:

It might not work. I just think it’s worth a try :slight_smile:

Edit:

You can’t run photorec on the SD-card as it can’t be mounted elsewhere, and I doubt you can have it run on the storage of the phone… Experimenting shouldn’t hurt as it works in read-only. Good luck!

3 Likes