FP3: Pixel camera app / Google Camera Port

I actually see a note on the gallery icon (blue circle like a notification symbol) when the processing seems to take place, so this probably helps to determine how long to wait. And as I said, I find the pictures very good, too.

As long as you are patient to wait and you dont want to take a few pictures in a row you are fine then. Would drive me nuts :wink:
just wanted to say that normal HDR+ mode already makes good pictures, so you could try if its less disturbing/slow/interrupting music (in case you use the super HDR ++ mode instead)

I checked and I apparently left the HDR+ status as it was – I guess same as yours.

After the 2nd /e/OS 0.23 update tonight, the screen generally seems to turn on much quicker again than after the 1st, maybe that comes with general performance improvement, too.

1 Like

By the way, i have had one longer and a shorter photo walk after the most recent /e/OS update, and the problems have been nowhere as severe as described (on 11 April) then. For the time being, I think it was a temporary /e/ issue.
Still quite happy with going GCam, although I have started to wonder if the better results might simply be down to HDR being default on GCam. :thinking:

1 Like

You should be able to deactivate to test?

1 Like

Comparison (on my FP3+)
GCam Port (default: HDR+) [left] vs. /e/OS Camera app (Open Camera) set on HDR [right]





I have now reached a point where for the first time ever since using a smartphone, I feel like I can leave my trusty old digital camera (from the year 2005, 5.1 MP) behind. Until now, nature photos were always what made me unhappy with smartphone cameras. The only thing still missing for me is a real (“optical”) zoom. But even in this respect, the resolution actually allows some acceptable cropped image details.


I have become much happier recently with my FP3+ camera since switching to the GCAm port. No feeling of needing any hardware upgrade at all. :slight_smile:


Seems very good, given that an optical zoom is indeed missing.

Do you recommend by the way using ‘Videostabilisation’? Is there also a quality improvement regarding the videos in the latest version you are using?

1 Like

Sorry, I cannot provide any experience there, I’ve never used really used video with any of the camera apps.

1 Like

Admittedly, I selected the best of 7 butterfly shots I took in the late afternoon today, but there were at least 3 more out of these which looked quite crisp and 99% equally presentably, too. Of the other three, some blurring on parts of the animal was visible on really close viewing – there was a gentle breeze that kept blowing against the plants from time to time. Fortunately the butterfly wasn’t shy at all and let me get like 15 cm (or less) close-up to her or him. Second picture is an exact 1/9 detail from the first (first picture automatically reduced in size from 4000x3000 when uploading, second picture not reduced).



thanks to @hirnsushi I found Gcam Photos Preview and installed this and now also preview works. I switched now from 7.4 to 8.2 as 7.4 started to be a bit sluggish after some time with Iode 3 (Android12) will see if 8.2 is better.


Dear everyone, I need your help: I cannot install some of the above APK apps.
When I got my Fairphone 3 two years ago, I managed to install MGC_6.2.030_RazerPhone2_V5.apk.
But recently I was very unhappy with photos against the light, so I tried installing several Nikita’s GCam APKs, unsuccessfully: after a few seconds, I systematically get “App not installed”.
The only APK I could install is PXv4.3_GoogleCamera_7.2.014.apk.
Even more disturbing: I thought it came from my old APK camera app, so I uninstalled it, and impossible to install it back.

I tried all the tips found on the internet associated to “App not installed”…
Could it come from the different updates of Android (current version: Android 11) I made since I have the phone ?

Hi and welcome to the forum.

A few basic checks before you try a specific app that ‘we’ can follow.

How much memory do you have internally?
Do you have an SD card and if so and formatted as Internal that may be the underlying problem?

Thank you for your prompt answer. I have 17 Go left, and no SD card.
For the record, I tried “signing” the APK file, disabled Google Play protect, cleared data and cache of Google Play Store and Services Google Play…

1 Like


Yes it could come from A11

How are you installing, via a direct download form Firefox or an APK download from maybe ‘apkpure’ etc. and then try to install.

If Firefox etc. check the following:

Can you check Settings > Apps and notifications > Advanced > Special app access > Install unknown apps

The A10 option Settings > Security > Unknown sources . . . doesn’t exist.

I directly download APKs with “Samsung Internet” (old habit), and unknown apps are allowed with this app in the settings.

1 Like

Hello, first things first, thank you all for this amazing thread! While having a lot of troubles with default camera app this GCam port works so much better.

I’m looking for a recommandation though, what “Device model” do you use for FP3+ cameras? For now I use default “Pixel 4”. I haven’t got much time for testing yet, though I see some small differences.

Cropped and original resolution (thus cut off at the sides) | Not cropped, but downsized

Sorry for repetition, but I heard/noticed the butterfly was (unintentionally) held captive under my skylight upon my return from a long walk out, so I had the opportunity to get really close up today (safely released minutes later). :innocent:


Hello! I’ve been looking for a new camera app, because the standard one randomly crashes sometimes and the pictures taken with it aren’t as good. I installed Open Camera as an alternative, but it’s slower in taking pictures and you can’t take pictures and videos in the dark because it refuses to trigger.

I’ve seen people on here saying that the Google Camera port takes better pictures, so I tried to download it from apkmirror, but it crashed after opening it. I tried a few different versions, but the exact same thing happened. Did I download the wrong version, or why doesn’t it work? Or does anyone have any recommendations for other camera apps?

I moved your question here … generally the GCam ports can be found here: Google Camera Ports Download. Recently most of us opted for the Nikita versions.