English

FP3 / PC / Win 10: Sd card not shown

Hi there,

after my sd-card slot physically broke on my… 2 year old FP2, I bought a FP3. Then I tried to install some things like Blokada, fDroid etc via the sd-card I put into the FP3, but to my surprise, the sdcard is not shown in the explorer in win 10. Here’s what I did:

  1. I unlocked the bootloader but did nothing else, Especially, I did not install twrp, another OS or something like that, I did not even install any other app at all.

  2. I set “MTP” for file transfer to no result other than Win10 detecting the phone as a device but not displaying it in the WinExplorer.

  3. I set “PTP” as a work-around following the instructions here:
    https://support.fairphone.com/hc/en-us/articles/360032831351-Connect-your-Fairphone-3-to-a-computer-Windows-Mac-and-Linux- Result is, the phone is now shown in the Explorer, but internal storage only, not the sdcard.

  4. I took another sdcard, this time empty. No other result.

  5. I formated the empty sdcard through FP3. No other result.

  6. I de-installed my ADB-driver on Win10 and re-installed it. No other result.

  7. I locked the OEM-Bootloader again. No other result.

  8. Then I did something I wanted to avoid badly: I logged into my WLAN before installing Blokada, updated the phone and tried 1-7 again. No other result.

  9. I set the device back, deleting everything. Starting from the scratch in case I missed something. I formated the sccard again, just in case, you never know until you look. No other result.:face_vomiting:

Anything I might try (again)?

Just in case: I use the original USB-C cable which came with the FP.

Night.

PS: Edits only grammar and spelling.

OK… I don’t get it. Here’s one thing, I did not until right now: I used another, this time 10 year old, PC with Win10 Pro. It works.

I honestly wonder why and I like to understand the… phenomenom.

2 Likes

Thanks. I try immediatly and come back soon.

That should take care of driver trouble.

If that doesn’t help, we wouldn’t talk about a Windows 10 N here by chance? (“N” = without Media Player, result of an old antitrust case)

A Windows N version would need the “Media Feature Pack” before it can do MTP. This should be installable via Settings - Apps - Apps & Features - Optional features (or something like that, German locale here) in current Windows 10 N, for older Windows N versions there were dedicated downloads …

https://support.microsoft.com/en-us/help/3145500/media-feature-pack-list-for-windows-n-editions

1 Like

Works*. Thanks a lot.

*With a caveat, though. I wanted to use the old FP2 though with a broken sdcard slot as a test phone for different OS like Ubuntu in case they come out for FP3. Won’t be fun without adb, but there’s no way to win all wars at one time.

Ok… next time I will read the links someone provides from start til end.

Thanks again.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.