English

FP3 not recognized via USB on Windows 10

Hi everyone,

I’m new to Android, so I might have just missed something. However I’ve been reading through several related threads which unfortunately didn’t help.

My plan was to install an alternate OS on my freshly bought second-hand FP3 (Android 10), so I went through part 1 of the official guide to manage the boot loader.
My PC (Windows 10) does not recognize the FP3. When connected via USB, the FP3 is charging, but nothing else happens. USB preferences are greyed-out. No entry in the Windows Device Manager (not invisible either). No optional Windows Driver Updates found.

I’ve tried all USB slots on my computer as well as two different cables. To make sure both cables work for data transfer, I tried them on my friend’s Shift5me - my PC can access that without problem. Same situation on a different Windows 10 laptop. I also removed quite a lot of debris out of the FP3’s USB port.

Any advice would be appreciated!

Hi @Wippi Welcome to the forum.

Settings > About Phone > tap build number 10 times
Settings > System > (Advanced) > Developer Options > ON

Then look at
Settings > Developer options > Default USB configuration.

I did not know that developer options should be turned on when connecting via USB…

1 Like

Not saying they have to be, just something to look at. :roll_eyes:

Hi @amoun,

Thanks for your reply, I forgot to mention that: Default USB configuration is set to “File Transfer”.

Also, I have no SIM card installed yet, if that makes any difference…

Maybe a dumb question: Have you tried to reboot the FP3?

I wouldn’t have thought so.

Do you have an SD card that is formatted as portable, which is therefore unencrypted and may be read via USB or are you trying to access the encrypted SSD storage?

Also have you downloaded ADB (Android Debug Bridge) to your pc?

This does not make sense, because …

@DeepSea I did reboot the phone, but it made no difference.
@amoun There is no SD card either. The phone is in factory state, and I was just trying to establish a connection with my PC so I can follow part 2 of unlocking the boot loader.
Therefore, I downloaded SDK Platform Tools (apparently including “adb”) to my computer but am not sure if they are properly installed as I couldn’t find instructions.

As this is a used FP3, you may want to disassemble and see whether the ribbon cable of the bottom module is not damaged and firmly connected to the main PCB or not…

2 Likes

So I gather you acted upon Part 2 of FP3(+). Manage the bootloader – Support

DeepSea’s idea may produce something but then having removed some debris could mean there is either a) some left or b) damage

My only experience of connecting the FP3 to a computer is to a Rasp Pi

I

@DeepSea Good idea, I just opened it up, dis- and reconnected the bottom module. The ribbon cable looks fine.

@amoun I was using a thin metal needle to carefully clean the USB port. Do you think that could have produced damage? (I’ve done that on my old iPhone many times without problems).
I’ll check out the ADB thing tomorrow…

For now, thanks for your quick replies!

2 Likes

ADB will work only when the device is recognized by the OS, which obviously is not the case here because you have mentioned that no such hardware (“Android device”) is listed in Windows Device Manager. Still I suspect a physical issue with the bottom module, maybe a broken USB data pin…

1 Like

Not having a gui output of the connected device on my desktop once adb was installed, without unlocking the bootloader I can access the phone via the command

adb devices

this shows there is a connection and the device ID/number

I just powered the FP3 off, then entered fastboot mode while connected to my PC. Windows now detects a device called ‘Android’, listed in the Device Manager under ‘Other Devices’ and with a yellow exclamation mark. It says that drivers are not installed yet and not available.
In the FP3 fastboot screen it says DEVICE STATE - locked. (Not sure if that could be relevant).
As soon as I start Android however, the connection drops and ‘Android’ becomes grey in the Device Manager.

According to FP3(+). Manage the bootloader - Support it seems like a Windows driver issue:

Unfortunately, Windows Update still won’t show me any available Google drivers.

I was trying to install the Google USB Driver but it didn’t work. I tried to install the file android_winusb.inf via the Device Manager > Other Devices > Android [right click >] update driver > search my Computer > [update folder location].

With the FP3 on fastboot, I just searched for Windows Updates again. Finally it offered me “Google, Inc. - Other hardware - Android Bootloader Interface” which I successfully installed.
Now, while on fastboot mode, a new device is listed in the Device Manager called “Kedacom USB Device > Android Boot Loader Interface”.

However, once I proceed to start up the Android OS, Windows remains unable to detect the FP3.

I downloaded SDK Platform tools including ADB, then ran a command prompt from the containing folder:

Screenshot_5

the Kedacom device indicates that you installed the correct fastboot driver…as long as the FP is in fastboot mode adb devices should not work, but fastboot devices should work… if not reboot the phone and try again…

5 Likes

Awesome, fastboot devices did work, while FP is in fastboot mode - the FP serial number is shown in the command prompt. Thanks @yvmuell
Okay… now I kind of want to go ahead and unlock the bootloader in order to install LineageOS.
But… shouldn’t I wait and try to fix the Windows drivers first? Any thoughts?

2 Likes

Not sure…did it ever work and stopped at one point or is it the first time you are trying? Now that you could install the fastboot driver did you try to find “normal” driver updates through Windows updates? Still all USB functions instead of charging are greyed out?

If you want to install Lineage OS, this installation guide could be helpful:

https://wiki.lineageos.org/devices/FP3/install