FP3+ & LineageOS: sideload installation stops with errors

I’m trying to install LineageOS 18.1 on my FP3+ following instructions from this forum and (mostly consistent) the LineageOS wiki.

bootloader is unlocked, LineageOS recovery is flashed
lineage-18.1-20211220-nightly-FP3-signed.zip downloaded and checked for integrity (hash code and also this LOS “Verify Build Authenticity” was successful)

adb devices says: serial no. xxx recovery (I always need to enable adb on the FP in recovery=> advanced).
Running adb sideload performs the zip download up to 47%.
Then the FP interrupts installation with message “signature verification failed”, error 21
continue installation anyway => yes.
Then installation step1/2 starts, running 20-30s and aborting with error 29:
error applying update : 29 (kdownloadoperationhashmismatch)
error in /sideload/package.zip (status 1)
(adbd status 10)
I found an error log containing these error messages (among many info/some warnings):
191.240118: update_engine_sideload E 01-25 07:31:22 513
error:delta_performer.cc(1853) hash verification failed for operation 271 expected hash =

error:delta_performer.cc(1856) calculated hash over 698272 bytes at offset: 182313237 =

error:delta_performer.cc(707)  mandatory operation hash check failed

error:download_action.cc(336) error errorcode::kdownloadoperationhashmismatch (29)
in deltaperformer's write method when processing the received payload -- terminating

error:prefs.cc(85) storage_->deletekey(key) failed.

(Also tried TWRP once by booting, not flashing it. But with this one try the download aborted after 10%)

Any help what goes wrong here would be appreciated very much :slight_smile:

Hi @maiwolf and a belated welcome to the forum :slightly_smiling_face:

Did you make any progress? Is there anything on this in the LineageOS site?
Just mulling over your post, two things occur to me:

  • Just because a download passes a hash code integrity check (which should always be done :wink: ) doesn’t mean that it doesn’t contain errors, it just means that the file you downloaded is the same as the one on the server that enabled the hash code to be generated. I haven’t really looked round Lineage, but I see that there’s a pretty frequent update rate (weekly?) - which is all to their credit, but wonder how much testing gets done.
  • Did you try with a different, more recent, download file?

Maybe someone who’s more familiar with Lineage could advise.
Anyway, good luck with it!

1 Like

Hi OldRoutard,
thanks for your comment - and welcome :slight_smile: Indeed you’ve got a point in looking for more recent files. I hadn’t checked for that all the time!

Meanwhile I got a hint from one of the FP Angels proposing to install it from an SD card and this one was successful in the end (just 2 days ago). Btw here it was still the same old zip file.
So LOS is running for now, thanks to Steffkist, next installation steps yet to come…


Good news! Thanks for posting back and well done.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.