FP3 Lineage update to 17.1: phone stuck in start screen

Dear all,
yesterday I tried to upgrade my FP3 from LOS 16.1 to LineageOS 17.1 (Android 10), and now the phone is not starting up anymore. It got first stuck in the LOS recovery saying “Can’t load Android System. Your data may be corrupt”. I Duckduckgo-ed it :slight_smile: and I could manage to get into TWRP, BUT it did not ask me the encryption pattern so in TWRP all files were encrypted and I could not flash the ROM again.

I tried from another article in this forum: adb reboot "dm-verity enforcing", and now I am stuck in the Start screen:

Whatever I choose, I always return to this screen. I cannot reboot neither to System, nor to Recovery, nor to Fastboot. So I am literally stuck there now. Also connecting the phone via USB to Laptop for adb didn’t work anymore.

I hope you can help me, cause I just changed from my old Samsung device to FP3 and now all my data is on the new FP3.

Thanks for your help!


Hopefully your data is on the SD card as external storage ~ and safe?

nope… Since I couldn’t manage yet to format the SD card as internal storage (encrypted), I didn’t use it yet. All is on internal storage… :frowning:

Ok a bit strange and sad as I would never format the SD card as internal and always keep it as external so I can use it else where. :frowning:

I agree to that, but then the data is not protected/encrypted in case of theft or loss, right?
However best would be to find a way to fix the phone :slight_smile:

1 Like

Yes I hope someone can be more useful.

The thing is: SD cards as internal storage seem to not work in general (on the FP3). The problem is all over the place. You shouldn’t do that before a confirmed fix exists.

1 Like

ok thanks, I wasn’t aware of this.

However, it would be good also to see not only how I can access the system again, but is there actually any way to reset the whole phone, even if that means losing all data? (only if there’s no other chance of course)

thank you

Ultimately if everything else fails you can use the manual install method to get back to a known good state

1 Like

The reset to factory is under System > Advanced > Erase all data ~ and as suggested do not connect/ or disable wifi / SIM card removal may be ok but as I had no wifi and no network signal there was never an issue on setting up.

Encryption only applies to the data partition.
Installing something with TWRP should still work without access to the data partition.
If it didn’t work, probably something else went wrong.

With this screen you are in Fastboot Mode. Device state is unlocked.
If fastboot devices finds your phone in this state you should be able to boot TWRP with fastboot, for instance.

Thank you for your replies.
Since I cannot get out of the above screen anymore, I tried to connect the phone to the PC (Linux), but using “adb devices” no device was found.
I also can’t get into TWRP anymore.

I haven’t tried the “Manual installation Fairphone OS” yet, cause I would probably lose my data, since currently I was running LineageOS.
Therfore my questions:

  • is it possible from the above screen to go to TWRP? Before using “adb reboot “enforce dm-verity””, it still worked.
  • is there any chance that I can access the data on the phone?

Thank you guys

As @AnotherElk already posted this screen is fastboot mode, not adb mode. Try fastboot devices.
I once had the same problem and I had to do a fresh install to get the phone back working and TWRP to ask for the PIN/pattern. Of course that wiped all data. I am sorry that I don’t know a trick to keep your data, I hope someone else does.

1 Like

This screen is Fastboot Mode. ADB doesn’t work in Fastboot Mode, only the fastboot command does.

With this screen on, connect your phone to your computer via USB and try fastboot devices. If this finds your phone, then locate your TWRP image on your computer and simply fastboot boot twrp.img (or whatever your filename for the TWRP image is).

@AnotherElk I tried, and I could find the device. So I tried to boot into TWRP, but it gave an error:

$ ./fastboot boot twrp-3.5.0_9-0-FP3.img
Sending 'boot.img' (29490 KB)                      OKAY [  1.158s]
Booting                                            FAILED (remote: 'unknown reason')
fastboot: error: Command failed

Any idea…? I’m starting to get :weary:
And according to Murphy’s Law, this afternoon my old phone, that I am now using again, fell to the ground and the whole screen broke… :neutral_face:

What does fastboot getvar current-slot give you currently?
If it says “INVALID”, you could set an active slot with fastboot --set-active=a and see whether you can then fastboot boot TWRP again.

Else … since you are using Linux you might want to make sure to use the current Android SDK Platform Tools , if you didn’t use them already. There were some incompatible fastboot commands around in Linux for a while.

1 Like

@AnotherElk thanks very much, I tried and I could switch from slot B to slot A.
I am a little confused, could it be that the LOS 17 upgrade was applied to the wrong slot?
Now that I’m in TWRP, I was thinking to try uninstalling Magisk (possible source of problem?) and to install again LOS17. Or could I try to reinstall LOS16? (which worked before)
It’s a little confusing for me with slots A & B, I have some experience of several rooted phones with LOS, but never with 2 slots…

Thanks again so far for your precious help :slight_smile:

Concerning the slots, I made the following observation:

When I’m in Slot A:

  • the start screen (black screen with Fairphone logo) shows the old/previous “powered by Android” writing, without the green Android guy
  • the recovery seems to be from Lineage (according to the symbol), and from there I can fastboot TWRP

When I was in Slot B:

  • the start screen (black screen with Fairphone logo) shows a new “powered by Android” writing, with the green Android guy. And I cannot use fastboot for TWRP (see error in above post)

Could it be, that LOS16 was on slot A, and somehow LOS17 was installed in slot B? Is that correct, or maybe the cause of the problem?

**EDIT: I can fastboot TWRP from both slots, and TWRP is asking me for the encryption pattern :slight_smile: But still: I tried to reinstall LOS17 and it’s not working. Should I try to install via ADB the LineageOS 16, or would this downgrade create trouble? **

Any error message along the way?
I think I would try the official LineageOS way and use the LineageOS recovery instead of TWRP.
Mind that the LineageOS recovery works a bit differently than TWRP and indeed gets flashed to the phone in the process, not booted with fastboot.

@AnotherElk Sorry, in fact I did not specify. No error installing LOS17.1, but I get into a bootloop. After the second loop, LOS Recovery tells me that the system may be corrupt.

Last night I studied :slight_smile: So now I know a little more about the partition slots A&B.
I understood that after every update or upgrade, root and modifications are overwritten, so with every update/upgrade also Magisk, root and TWRP have to be installed again since the partition changed. I did not try this, also because I am not sure how exactly to proceed…