FP3+: Issues with Android 13 update

Ok the wifi issue is not really a wifi issue…
I got the same problem with my usb-c lan adapter which worked before.
Now the lan connection drops every second.

I also use Wireguard to connect my Fairphone to my home network which provides ad blocking and dns resolving through Adguard Home and Unbound.
This still works.

In your router, do you have a WPA2-only mode?
I’m asking this because FP3/ Android 13 causes issues when WPA2/WPA3 combined mode with SAE.

I can use wpa + wpa2 or wpa2 only or wpa2 + wpa3.
I tested all of them.
But like I said, it’s the same with lan.
Doesn’t matter if wifi or wired lan.

Thank you… Well, then I will try again.

Thank you! I will try

Have a look here

I don’t have a lot of the other issues mentioned in the thread but I have found myself with a phone that will mysteriously crash in landscape mode. To fix it I’ve turned off autorotation. Anyone else experience it?

PS - haven’t quite noticed the fingerprint issues but I’ve trained myself to not really depend on the sensor anyway

It is a known problem that should be solved in an update.


I already tried this and my OS is also updated to the last version 7.56, same for my repeaters.
I also tried a static IP without success.

Hello there,

I got the update yesterday. Mostly, it runs fine, except for a few problems.

As someone else, I can’t cast my screen anymore. It causes the phone to “half reboot”: no shutting down, but the starting animation. I have to unlock the phone with the pass, and can’t use my finger, just like a first login after reboot. But I don’t have to enter my PIN code, the sim stays connected.

The phone takes a long time to ask for the PIN code. I think it’s Android who delays it so that it can start the phone faster. So, the phone starts, I log in. A moment pass, like 5 - 10 seconds, and it asks for the PIN. When I enter it, I get disconnected and must log in again. More problematic, the messages app may start before the sim is connected. There isn’t any problem with SMS/MMS. But for RCS, the app thinks there is no compatible SIM. The only solution is to force stop the app and re-open it, so it will re-detect the SIM card.

And last, and not the most important, I got some issues with the auto-luminosity. Sometimes, it just keep going up and down until I move to someplace else. In these moments, luminosity isn’t changing smoothly, instead it’s going by little steps, which feels a little bit like flickering.

If this is of any importance, I live in France, and using french sim and wifi. My phone operator is Orange, and my internet provider is SFR.

That’s all I’ve seen for now, thank you very much


Hi. I have an FP3 & am having the same issues with the phone not recognising the SIM card for nearly a minute after switch on.


i am consernd about updating my phone. for some reason i am unable to make a backup of my signal chats. i guess because i installed it with f-droid or aptoide, i cant remember. and instead of creating a new topic i may ask here, will my chats will be gone after the update to android 13? i remember that all my pictures where gone after i upgraded to android 11.
so i am asking everyone, was something gone or different after upgrading?

I didn’t lose anything with the update, and I also use signal. Of course, I can’t guarantee it’ll be the same for you.


The network issue wasn’t the Fairphones or Fritzboxs fault.
Also WPA3 + WPA2 works flawlessly.
It’s basically a feature.
Google removed the option to stay connected to a network without internet access.
Also Google sends some dns request while ignoring the vpn tunnel.
Now if you, like me, block tcp port 53 for outside connections, Android has no chance to reach or
Doing this prevents Google from collecting data about you and your smartphone.
In Android 13 Google forces this now and I got no idea how to work around this.

Also for those who use a VPN.
Don’t block non VPN connections or better exclude Googles services from it or you also will get a nonstop dropping network connection.

I have an issue with the NFC reader.

After i installed the Android 13 the fingerprint stopped working and i forgot my pincode for my banking security app.

I need to scan the chip on my passport to change the code but seems like i cant scan it after android 13.

I would gladly pay for a new fingerprint reader. I realy hope a fix is on the way, fast as this will be a dealbreaker for me regarding the fairphone and keep telling friends to buy it.

Do you mean to say that WPA3 + WPA2 mode worked flawlessly after you unblocked port 53? It’s unclear what the relationship between WiFi security mode and DNS is.

Yes, I just mentioned it because someone said it usually doesn’t work.
But for me it was the same for wireless and wired lan.
Now it works as it should but if someone talks about birds near my phone I probably will get a lot bird ads again.

So to be clear there never was a connection between dns and wifi security mode.

I found the real solution to this:
Go to Settings => Network & Internet => Private DNS
and switch it on and then off.

1 Like

First of all: THANKS to Fairphone for keeping FP3 up to date! I really appreciate that they took the pains to implement A13 for such an “old” device (old in the sens of: SOC-manufacturer does not support it anymore).
That said, my FP3 started to “act up” today. I updated to A13 two days ago, and had a flawless day yesterday, doing a longer, GPS assisted hike with lots of usage of the phone, however in airplane mode over a longer period.
Today, on day 2, for reasons I yet could not identify, the phone kindof freezes - sometimes after 10-20 minutes, sometimes after an hour or so: The touchscreen becomes unresponsive, or near unresponsive. If it reacts at all, it mis-interpretes the input, as if system resources for the touchscreen are not enough and it does not react quickly enough to the finger. If I succeed in restarting or switching off the phone, after it has rebooted, the issue remains, i.e. the phone is unresponsive from the beginning on! Only thing that solves it is removing the battery.
Main difference between yesterday and today: Yesterday the phone was mainly in airplane mode or had Wifi, while today I’m mainly on mobile data.
Any ideas? Anyone having the same?

EDIT: Ooooooohhh - now that I move around in the forum and read more, it came back to me - I DID change something today: I activated “Show notifications by swiping across fingerprint reader” (German: Benachrichtigungen durch Wischen über den Fingerabdrucksensor einblenden" - not sure if my translation is accurate), and since the fingerprint reader seems to be a neuralgic point, this may be the cause after all. I deactivated the setting again and will see if it is the root cause.

1 Like

…and it was. Have the setting off again, and since several hours stable again. For me OK - I do not use the fingerprint reader anyhow. But I guess for most users they need to find a solution…


Since updating my Fairphone3+ to Android13 I have experienced the following glitches

(1) the lowest volume setting for notifications is crazy loud. I cannot turn it down any further, have done in app and on device. Help, it is awful!

(2) volume for calls and volume for notifications are now on the same toggle - this is exceedingly stupid. Is there a fix?

(3) now the bedtime mode seems to stop messages and emails from arriving altogether, whereas previously they were simply silent. There is nowhere in app or in device settings that I can see to change this.
I would like to receive all communications but with no noise. Any fixes?

(4) the auto dimming setting in bedtime mode is messed up - it makes the apps brighter against the background, working in the opposite way from intended. Any fixes?

1 Like