FP3+: Issues with Android 13 update

hello, I have a fairphone 3 and since the Android 13 update I have problems with the hotspot by USB (it worked very well before and now it no longer works or very rarely) and via wifi only if I restart my phone each time. … Someone would have any idea ?

1 Like

Thanks for the news @shaakunthala , I was still with the “no WPA” mode on, just to speed up the manual reconnection but now I have tried WPA2 and I confirm, devices reconnect to the Fairphone hotspot without typing the password again. Now I hope the will fix a similar issue with the bluetooth connection, everytime I get in my car I have to reboot the phone in order to connect it to the hand free system.

1 Like

Did some tests, the Wifi hotspot connection with modern devices (5Ghz) is now ok, but old devices (2,4 GHZ) still can’t reconnect, they consider the phone as a new device every time… let’s hope for the next update.

Could it be because of the “Randomize MAC” setting which is by default “On” in newer Android versions?

4 Likes

Yes, I also think this is the problem. I can disable the random MAC access for every WIFI connection, (gear icon on the connection) but I don’t understand how to disable it for the hotspot…

My Fairphone 3 has become almost unusable since installing Android 13. Some big issues I have experienced;

I can’t take screenshots anymore. Whenever I take a screenshot, I get an error notification that simply reads ‘Couldn’t save screenshot Can’t save screenshot’. I have an SD card with about 100GB of storage available, plus my Camera app works fine, as do video recordings. But not screenshots. I hate how little information that the error notification gives. Tapping on it does nothing, there’s no error code or log information to tell me why I can’t take screenshots, just that I can’t.

My SIM card does not activate after a reboot. If I reboot now since updating to Android 13, I must call someone, wait for the call to fail due to the phone not recognizing the sim card. About 30 seconds to 2 minutes later, then I get prompted to enter my sim PIN. Only then does my 4G, SMS etc. work. On a similar note, the phone doesn’t seem to keep track of time while it is switched off, so if I reboot, I will have incorrect date and time until I do my little ritual with the failed call, or get Wi-Fi. I don’t remember this being a thing before the update.

‘Failed’ Reboots. I don’t know how else to describe this phenomenon, but I have been getting an issue, where if I reboot the phone once, the first time, it will just boot into a Black screen. I can access notifications and go to settings from there, but no other apps will work. I can only get black screen. If I go Settings > Apps > and launch a random app, it just goes to black screen again. I have to re-reboot to get actually be able to use the damn phone, only after the second reboot do I get all the expected behaviors and functionality.

Random apps crashing on launch. Sometimes apps will just not launch or immediately crash. Apps like KDEcoonect and Zorin connect, whether they are installed via Google Play or F-Droid, they will not launch no matter what. There have been other cases of apps not working, but these are the most recent ones I’ve seen.

Some apps not working with fingerprint sensor. This one is just confusing to me. Some apps have no issues whatsoever with using the fingerprint sensor, such as Bitwarden. I use my fingerprint as a faster login to access my passwords etc. But my banking app N26 will not work with my fingerprint, when I try to enable biometric login in the N26 app, it just says ‘error occurred’. N26 said there’s no reason from what they can see that it would be the app, especially since this function worked fine before switching to Android 13.

Toggling Bluetooth On or Off brings the phone to an absolute crawl for several minutes. This one is particularly frustrating, for some reason, toggling Bluetooth on or off makes the phone almost freeze for at least two minutes. I always forget about this when I am about to listen to music on my headphones or in my car. I go to settings, go to enable Bluetooth, then have my phone basically freeze for a few minutes. No indication of how long it will take or if it will unfreeze so I can actually go to my music app and play some music or whatever.

With all that said, is it just easier to revert to a previous version of Android? Can someone point me in the right direction on how this can be done. I rely on my phone for so much, and I love my Fairphone 3, I love what Fairphone themselves are trying to do. But there are just too many bugs and too much frustration that comes from using my phone now.

What is the last update on your phone ? Did you try in safe mode to see if there is not a problem with an app ? And are you ready to try a factory reset in case nothing else works ?

1 Like

Is your SD card configured as internal or portable memory?
Sounds like internal, what could cause some of the mentioned problems. See sdcardguide

(Regarding the problem with the fingerprint sensor see above. As a workaround you might consider to install lineageOS.)

2 Likes

Just FYI, MC_sickle334: I’ve moved your post and the replies about the SD card here because the other thread is solely about the fingerprint issue in A13 on the FP3(+).

1 Like

The settings app says I am up to date

Android Version: 13
Android Security Update: August 5, 2023

So a quick update after seeing you mention SD card issues. I managed to reformat my Samsung SD card as external, and it has solved my Screenshot issue.

Had the error notification gave a bit more info about what was causing the problem, it might not have been such an annoyance. But in any case, it does seem that using an SD card as internal storage on Fairphone 3 can cause screenshots to not work.

It has also helped with app performance. KDEconnect no longer crashes on launch.

Edited to add also, reformatting SD card has also helped with those ‘failed’ reboots I mentioned above. I had no idea that the memery card would impact performance this much.

4 Likes

See sdcardguide .
It’s a more general Android version thing than a particular Fairphone thing, but yes, Fairphones are affected, too, and badly.

I don’t know why this is even still offered to unsuspecting users as a formatting possibility. It made a limited kind of sense in the beginning of smartphoning when built-in storage was a real bottleneck, but it was a bad idea technically back then already to chain together sturdy built-in storage and a flimsy SD card in a flimsy card slot. And recent Android bugs obviously don’t help with this either.

4 Likes

Check if your SD card is formatted al External.
If it is formatted as internal, then it can give all kinds of problems.

Dear @koumilak , could you fix the Hotspot problem (having to enable it many times before it sticks) that came with Android 13 on a Fairphone 3? Activating the compatibility mode fixes it, but then Zoom complained about too slow a connection.

I haven’t had hotspot problems in a while. I think an update did the trick, probably the one that fixed delayed SIM unlocking. Maybe the slow connection you’re experiencing is unrelated.

That’s great to hear, thank you! My FP3 is still using the update from October 5, so I hope that the fix is rolled out soon. I also deemed connection speed even in compatibility mode sufficient for Zoom (around 1 MB/s) but strangely it started complaining.

Just to let others potentially facing the same problem: indeed backing up and factory resetting helped in my case. Thank you all for your help.

5 Likes

Dear @koumilak are you also running the update from 5 December? It just arrived, but somehow changed little.

I’m sorry, i don’t experience those particular issues anymore; sometimes the Wi-Fi drops randomly but that’s about it.
I’d try to reset the network settings (look up “reset network settings android”, it’s common to all android phones).
Good luck!

Hi, I posted this on reddit r/Fairphone some time ago, but since then, a few Updates later, nothing has changed:

FP3+ does not reconnect to wifi automatically

Since the upgrade to Android 13, my phone does not reconnect to any wifi network, when I leave and come back later. It will stay on mobile data forever, until I turn on the display manually. Then it reconnects after some seconds. This happened with all official Android 13 releases, up to the latest. Any clues how to fix this, other than switching to Lineage OS? I tried resetting Wifi, Mobile and Bluetooth, but it didn’t help, My wifes FP3+ has the exact same problem. I did not wipe the phone, if I have to do this, I will get rid of the official OS.

In the meantime, the problem is so annoying, all my smart home automations with Wifi presence detection refuse to work until I manually turn on the phone.
Do all Android 13 phones have this problem?

2 Likes