FP3 in Japan on Android 12 mobile network login issues/takes hours to get mobile data

I recently moved to Japan and would like to continue using my FP3 here. There was a previous thread about using the FP3 in Japan. In this thread positive experiences were stated with NTT based operators.

This website gives an overview of the various networks and the frequency band coverage.. Based on this I decided to go for Y!Mobile which uses the Softbank network. Now I can receive SMS and call without problems, but the login into the mobile network works only sporadically. Sometimes it takes minutes, sometimes hours. And once I restart the phone or turn of mobile data/turn on airplane the whole spiel starts again. What confuses me is that it works but just takes a long time, so the settings seem to be correct.

I recently updated to LineageOS 19 (i.e. I dirty flashed to Android 12) and did not check with my previous sim card whether it can login to the mobile network after the update, since I do not have it anymore. I reset the network settings but to no avail. I could not find any other report of connection issues on android 12, so I am truly a bit at a loss, where the problem may lie.

Did you already check whether the APN settings are really correct?
Most providers will have the correct settings somewhere on their website for comparison.

1 Like

Yes sorry, I forgot to mention, I checked the APN, deleted it, readded it, reset the APN settings. I think the only thing I have not done is a factory reset, which I would like to avoid for reasons you can probably understand.

The phone does connect after some hours, so the settings do not seem to be the problem. I have checked the other threads on the mobile network not working. It might be the same problem here, since it takes hours to connect, I imagine that most users did not wait for that long.

Does it make any difference if you set the phone to 3G and 2G only?

2 Likes

Well, I thought I had, but I did again and it somewhat solved the problem. My area does not seem to be covered by 2G anymore so I have no service when switching to that.

If I pick 3G I connect immediately to H+ and when I then manually switch to preferring 4G, it immediately connects to the 4G network.

If possible I would like to immediately connect to 4G without the manual work, but at least I have a reproducible way to connect to the mobile network. If anyone has an idea of what the problem could be, or how to run diagnostics, that would be appreciated.

1 Like

Well I did some checks, but could not find anything definitive, I imagine that dirty flashing from Android 10 to 11 and then from 11 to 12 might play some role in this problem. Just switching once from 4G to 3G to connect and then back to 4G every time I restart or turn off airplane mode is not that annoying, so I’ll accept that solution, thanks!

Final update, after it has been solved, with the latest updated of LineageOS for MicroG for the FP3 (2022 August 23), I connect normally to 4G immediately, seems it was a software problem after all. Thanks for your replies again!

2 Likes