English

🇩🇪 FP3 bluetooth problem with Ford SYNC3

Hi, thanks for the suggestion & sorry for my late answer. Unfortunately, this is not possible for IT security reasons. Our IT security policy is relatively strict here.

@ Rae

That’s good to hear. I hope you find the solution soon. :slight_smile:

1 Like

Irgendwas neues dazu?
Hat jemand, die verschiedenen Audio-Codecs bzw. Bluetooth-Protocoll-Versionen in den Entwickler-Optionen durchprobiert?
@rae würde evtl. ein Log (HCI-Snoop-Protokoll) helfen um das Problem zu beheben?

Any news on the issue?
Did anyone try out the different audio codecs and bluetooth-protocoll-versions of the developer options?
@rae would a log (HCI-Snoop-Protocoll) help to adress the issue?

Hi @rominator007, we cannot guarantee that it will, but if you do happen to try it, please share your findings. On our end, this is on our radar and it in being looked into by our software team, but we have no new developments to report just yet. Will keep you all updated when new information comes to light.

Cheers,
Rae :slight_smile:

1 Like

I see. Well I just tried again with the setting “Bluetooth-Geräte ohne Namen anzeigen” checked (English: something like “Show Bluetooth devices without name” or similar). That did not help.
I tried different values of “Bluetooth AVRCP-Version” to no avail.
And I tried with a value of “Bluetooth Audio-Codec” of “Optionale Codecs aktivieren” (English: something like “Activate optional codecs” or similiar) also without any result.

The behavior is as following: I try to couple starting with the car or the FP3. Everything looks alright. Event the phone is showing the connected bluetooth symbol at the top of the screen. Then the car gives me an error message “FP3 bietet keine SYNC-kompatiblen Funktionen.” (English: “FP3 does not offer any SYNC-compatible functions.” or similiar) and the connection is closed (I assume by the car).


This leads me to the assumption that the offered bluetooth services by FP3 are somehow not accepted by the car.

1 Like

Here is the version of SYNC running in my car:


For someone searching the web:
SYNC 3, Softwareversion: 2.2
Build 16280_PRODUCT
Ford Motor Company
etc.

I will post the HCI protocoll later when I have the android debugger installed in order to get to “/sdcard/btsnoop_hci.log” which annoyingly enough I can’t without the debugger.
I will also try to connect with this service app that I cannot find right now and don’t know it’s name that has a bluetooth-option.
I also found some “feature-flags” in the developer options where some bluetooth-settings are disabled strangely enough. Anybode knows something about this?

Software version 2.2 seems to be outdated, but I am not sure. I would ask your local Ford dealer for an update and try Bluetooth pairing again afterwards.

Hm, I had some hope that this issue could be solved by the latest FP Firmware update. Unfortunatelly it did not. Would have been really really great if it did!!

The latest (current) update for the FP3 seems to address security issues only.

so sad ! as Trump would say

I highly doubt that Trump is twittering from a Fairphone. Even if he used one, his tweets would not get any better…

sure he wouldn’t. It was just about the right tone for the “So sad” :wink:

I now upgraded to Sync 3 Version 3.0 and the behavior is pretty much the same.

Unfortunately I could not produce the Bluetooth-Log as it seems to not get placed at /sdcard/btsnoop_hci.log as everybody states around the internet.
This is really a drag. I even had to grab a pack of CDs for the vacation instead of the music on my FP3 :-/

I still have to check connecting via safe mode and the Bluetooth test option in the service menu (last option in the developers menu). After that I am really out of ideas.

Ich hänge mich hier mal dran und schließe mich dem Wunsch nach Berücksichtigung beim nächsten Systemupdate an. Die Tatsache, dass es mit e/OS funktioniert lässt ja hoffen. So lange hänge ich mein FP3 ans USB-Kabel.

Hopefully this will be solved by Android 10!

That would be great. Do we have any hints that this will be solved by Android 10 or is it just an assumption?

AFAIK an assumption (and a hope).

Well, I don’t want to spoil the party, but I received this message from FP support today:
“We are currently investigating the root of this issue. Unfortunately, at the moment there is nothing we can do to solve it. Please allow us a reasonable amount of time to investigate this.”

2 Likes

I lately checked with the service app (or how you call it. it is under developer settings and all at the bottom) and got the following output from the Bluetooth-test:
“Searching
No devices found
Test stopped”

I also did a restart into safe mode (should deactivate all apps that could mess with bluetooth) and could not connect to my car there either.

So I think I am all out of options. Hope this helps in investigating that further.

By the way. Connecting to other Bluetooth-devices with my FP3 works fine. Connecting to the “Sync” of my car also worked fine with my old FP2.

1 Like