English

FP3+ Auto-brightness: display brightness suddenly increases despite no change in light levels

Hello,

I have a Fairphone 3+ which I pre-ordered. It runs Android 10, and I haven’t used another OS on it.

Every day, I use my FP3+ to read in bed, with lights in the room turned off. This results in a very low, constant light level. I live in the countryside and don’t have car headlights shining through windows or anything like that, and no devices in the room that spontaneously produce light (short of a very dim, flickering LED or two).

When using the phone like this, I regularly encounter an issue where, when automatic brightness adjustment has dropped the brightness to its lowest levels, the phone will, seemingly randomly, instantly jump to around twenty-five percent brightness, stay there for two or three seconds, and then return to zero. I haven’t been able to identify a pattern in occurrences of this issue, and it still happens if I manually set it back to minimum brightness after the jump occurs. It always jumps to the same amount every time, and it even occurs if I’m under the covers, so the only source of light would be the phone’s own screen. It doesn’t seem to matter what’s on-screen either; regardless of whether dark mode or light mode content is displayed, the problem still occurs.

I’ve tried restarting the phone, disabling and re-enabling automatic brightness adjustment, and cleaning the light sensor. Nothing seems to have any effect. Since this issue has been occurring, I’ve installed every new software update that’s been made available, but there haven’t been any improvements in this area.

This is not a major issue, and the rest of the phone works fine (apart from the Camera app freezing and crashing sometimes, but that’s an issue for another post), and overall, I’m happy with my Fairphone 3+. But this issue is annoying, disrupting my evening relaxation and my reading, so I’d be grateful for any help or advice for resolving it.

Thank you.

Hi welcome to the furm

That could stir the auto setting, though you also say

I’m curious about the randomness, I have noticed that certain apps I use can go into background operation and then come alive and initiate the screen.

Have you tried a) in aeroplane mode, and b) with all notifications turned off ?

What app are you using to read ‘in bed’ ?

Thanks for your response and suggestions.

When I mentioned the LED lights, I was speaking only in terms of their contribution to the limited bouncing ambient light in the room; they’re not directly visible from my position in bed, and the phone sensor would be turned away from them. But maybe the sensor is just that sensitive.

When in bed, I usually use only one or two foreground apps at a time. Most often these are Amazon’s Kindle app or Firefox browser. The problem occurs even when I’ve been using the same app for several minutes and haven’t just switched to it. I also use a screen tinting app and a VPN, but both run in the background and don’t appear when I press the Overview/recent apps button. The screen tinter doesn’t change tint over time, and I haven’t noticed any loss of connection when the brightness change occurs.

I haven’t tried aeroplane mode or with notifications turned off. Can’t say I’ve noticed receiving a notification when the brightness change occurs. I’ll try these tonight and tomorrow tonight and report back.

1 Like

I have experienced the same, so I’ve stopped using this feature because it was too annoying.

Now that I read this thread, I realize that there are apps that do this adjustments as well. I will try them.

1 Like

Hello,

Apologies for the delay; several evenings this week I didn’t read long enough to notice if disabling notifications or enabling Aeroplane mode had any effect.

I’ve now tried with both of these individually and neither seem to work.

First, I tried with DND enabled and notifications set to ‘No visuals or sound from notifications’. I then tried with DND disabled and Aeroplane mode enabled.

In both cases, the random brightness adjustment still occurred. However, while in Aeroplane mode, I had the impression it occurred less often, but I’ve got no way to verify this.

Have you got any thoughts on this outcome or other suggestions for things to try?

Thank you again for your help.

Have noticed @FreekB’s response about apps that do automatic brightness adjustment, so I might try one of those and disabled Android’s built-in adjustment.

1 Like

I noticed the same since I got the FP3+ last year. And I can confirm that it has nothing to do with notifications, DND, or apps controlling the brightness.

My theory is that reflexions on the glass, covering the sensor, are triggering that behavior. But just a guess.

1 Like

You can test your theory by covering the sensor and see if it still changes.

You could try putting a thin translucent piece of tape over the sensor that would deflect light.

You are right. If the sensor is covered, the auto-brightness is not decreasing anymore without reasons. So it seems, that just very little amount of light, reflected in a disadvantegeous way, can cause this behaviour.

I would say this is some kind of “design-related peculiarity” which can not be easily changed. Except putting tape on it or turn off the auto-brightness, of course.

You can buy translucent tape with ridges that will deflect light from many angles, it’s often for bandages. I’m not sure if this is the one I have had for years

https://www.clinisupplies.co.uk/products/24/CliniTape-CLEAR-Surgical-Tape

The idea of the tape is to diffuse the light so that any brightness that may suddenly arise to the side will be diffused and partially redirected and reflected.

It’s only an idea but you could try something similar. I have found the old tape I have, some 20 to 30 years old :slight_smile:
tape

Apologies for the delayed response.

Thank you, @ontheair and @amoun, for your suggestions.

I’ll look into that translucent ridged tape and see if I can get any. Meanwhile, I’ll try covering the sensor with some regular opaque tape and see if it helps at all.

1 Like