FP3 Android 13 Update killed Wifi AGAIN

At the beginning of the year, there was major system update for my FP3, which let not let me connect to my wifi from my FritzBox 7530. I could see them and try to connect, but it would always fail. For both 2,4Ghz and 5Ghz. I had to reset my phone, losing access to my 2FA in the process, so I will not do this again.

I just did the update to Android 13 (even after the updater was bugging me), and now I have the same again. Mobile connection took a while to connect properly, but it works not. But with Wifi, no connectio to my nets a possible. I will try at work on Monday, as last time, there it worked (it also uses different access points).

Tried to restart the phone, the router, delete wifi entries and connected again, but to no avail.

Every other device in my network works fine, and I know that it is a well known problem between FritzBoxes and FP3. But I really can’t fathom, why their hasn’t been a fix after all those months. Really pissed off of having this big issue AGAIN.


Ensure the Fritzbox is up to date es well

1 Like

So I got it working. Apperently setting the Wifi to not allow new devices to connect was the issue. I set it to “allow all new devices (Alle neuen WLAN Geräte zulassen)”, and connecting to the Wifi works. Afterwards, I could set it to not accept new devices again and it still works.


The phone is probably using another MAC address since the update …


This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.