FP3+ adb OK but fastboot KO

Sorry to raise again a fastboot problem, but I went though multiple how to multiple post in forum without being able to solve the problem.

I want to install /e/ OS on my brand new FP3+.

On the FP3+ I do have:

Then I press start button to start (in fastboot mode ?) the device.
I get <!> screen information saying it is unlocked.
After this start I can use adb:

adb devices
List of devices attached
A209nnnnnn device

But when I start fastboot it does not return anything.

I check on windows 10: drivers are OK, I can see Android FP3 in hardware and share data is working.
I tryed on linux with the same result. I also created an entry in udev with info found in lsusb but no change fastboot does not see any device, I tryed root or not, same result.
Finaly I tryed easy installer on windows and after rebooting in fastmode it is stuck as if fastboot would not have been activated.

Help would be apreciated.

Did you try switching the phone off and on again (by manually removing the battery)?

This is already the screen of fastboot. By pressing the power button you probably just selected the first option being device info.

This screen is fastboot mode, but you can use adb… Something I’m missing here…

1 Like

I removed the battery. Then restarted (normal restart with just pressing only start button) and got:

then it boots in Fairphone OS.

After that still the same situation:
adb is working and list my attached device
fastboot does not say anything


That’s wrong. You need to stay on this screen in order to be able to use fastboot


Thank a lot, this was it: I have to remain on this screen to have fastboot working (several hours lost to experiment different drivers, frameworks …).
And it did not work with windows, I had to do it on Linux and I used the Easy Installer that did everything perfectly.
There is already a post about this situation where it says we have to stay on the fastboot screen but I did not get it.
Thanks again for this trick !


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.