English

FP3 A.0110, Android9 OS update, patchlevel 5th, January 2020

Hi! Thanks! - But what if I want to use the selector to chose another search engine? Will that require a new FP3 OS update, or is it the app that is missbehaving?

1 Like

I can only speculate here. From what users have written here since yesterday, it seems to me the Search engine selector does not work on anyone’s FP3, so most likely, yes, it will take the next update.

I would welcome if I’m proven wrong. :slight_smile: After all I would be curious if “none” was an option in it as well – it seems to me that many want to get rid of the search bar on their start screen altogether.

8 Likes

The name of this (newish?) app is

com.google.android.apps.setupwizard.searchselector

in case you want to remove it for good, as described here:

1 Like

For the record, the app did pop up for a second on my device, just as with clsbln , but closed right after.

I tend to see this as a good sign for my (mostly) un-googled phone :slight_smile:

1 Like

The update went well. Thanks to @urs_lesse for the solution how to deactivate the engine selector.

2 Likes

An even faster way to get rid of the “search engine selector” notification (that also works with work profiles):

Long tap the notification (turns white) > tap (i) > deactivate > confirm warning message.

6 Likes

Is it really everyone’s FP3, or is it just speculation? I thought that maybe it depends on some other app might have been removed/deactivated (considering many of us here try to de-Google their phones as much as possible). Maybe it requires Chrome to be active (since it states it does also influence the search engine in Chrome), or requires the default launcher, or… who knows?! I don’t use any of these and have it disabled, so I cannot check… But all this is just my personal speculation.

3 Likes

Same issue here too.

I just got my FP3 today, installed the update and I got the notification, too.
Using the search engine selection app doesn’t work, so I ended up deactivating it like Urs described.
No custom launcher, no disabled Google apps so far.

3 Likes

Oh, I see. Thanks for invalidating my assumption and confirming the contrary :smiley:

1 Like

Hi there,
Saw this thread before installing the update to help deciding if I should install it or not.
Well, I did install it. I am getting the same behaviour.
2 comments:

  1. The search engine selector is not a standard app so will not show in the list unless you select to display the system processes
  2. According to a website I found when looking for what the search engine selector was intended to be, I found that it may only work from March 1 2020… See the text under the screenshot stating “It’s possible the March 1 date may point to when we can expect to see these alternative search engines appear on Android in Europe”. So may be it’s worth waiting a bit and see if it works then (ok I would still don’t understand why this was deployed if it is intended not to be working immediately upon release)

Cheers

7 Likes

Thanks, the foul demon now rests in the storage!

Does anyone notice a “WiFi comaptibility improval”? I don’t.

I got these instructions from customer support:

  1. slide down from the top of your screen to open the drop-down menu;
  2. long-press the writing “Search engine selector” (the tile will become white);
  3. long-press the “i” in the circle located at the top right corner of the tile;
  4. tap on notifications (a new window will appear, showing on top the writing “Show notification”);
  5. next to the writing “Show notification” tap on the toggle to turn the notifications off;
  6. go back to your home screen. Done!

You will have to repeat the procedure if you have a work profile on your device.

I did! My Vodafone Wi-Fi router now works, and it did not before.

5 Likes

Hi, as I wrote in another topic I have the same problem, and I also can’t find an app called search engine something (in English or German). When I tap the notification it turns white with text (diese Benachrichtigungen werden) and on top of this another text in Green (… rückgängig machen). And I don’t see any “i” to tap.
How can I get rid of the app and everything to do with it (if it’s google, probably data collecting)?

I am trying to keep my FP3 as googlefree as possible,

Ok, once again. with screenshots. so everyone should understand how to do it:

  1. long press on the notification (about 2 seconds)

  2. press on the “i” icon

  3. press “DISABLE”

  4. press “DISABLE APP”

now you won’t see any further notifications :slight_smile:

10 Likes

BTW that screen/respectively the reason for that screen is actually quite a good one, because it is the result of the EU antitrust ruling against Google.
Thoigh the fact that this has been criticized by DuckDuckGo (though they seem to have deleted that for unknown reasons) and Ecosia (in German, sorry).

That it does not work (yet?) though, is awkward, of course. :laughing:

3 Likes

Conspiracy theory, Fairphone is on Googles payroll: Fairphone screwed up the selection function in the update to avoid changing the default search engine.

3 Likes

I’d invoke Hanlon’s Razor here :stuck_out_tongue_winking_eye:

1 Like