English

My FP3 doesn't like higher 5Ghz Wifi channels, especially channel 116

Sadly the FRITZ!Box doesn’t allow me to change the channel width. Only change was the mentioned 160MHz. This setting is not on though.


From the documentation

Allow wireless channels with 160-MHz channel bandwidth (5-GHz frequency band)

Increases the maximum radio channel width from 80 MHz to 160 MHz and allows the latest Wireless AC devices with 2 x 2 antenna technology to double their throughput rates.

Thanks for confirming!

The Fritz router seems to automatically use 80 Mhz channel width because it always shows a (max) channel usage of 4 (when 116 is selected: 116, 120, 124, 128, or when 52 is selected: 52, 56, 60, 64).
Each of those channels is 20 Mhz wide.

Could you try other frequencies as well, to check which ones exactly don’t work?

(Becomes understandable with DeepL.)

1 Like

Got this reply from support after I mentioned this thread:

We are already working on the wifi connection issue, it looks like it is a bug.

So we’ll have to wait and see…

5 Likes

I was exited to see this change in the new firmware FP3 A.0110:

WiFi comaptibility improval

but it did not really change anything for me.
Channel 116 is still extremely unstable and 120+ is very slow.

1 Like

I can confirm the 5Ghz channel problem on the FP3 with the Fritzbox 7590. When using auto channel, the phone would not even connect to the network at all. Switching to channel 52 made it work properly in n+ac mode.

3 Likes

Hi there,
i have been following this discussion since i received my FP 3 in December.
I always had connection issues with my FP3 at home (Fritz.box 6490 Cable @ 5Ghz and a Fritz.Repeater 310). However, i have no issues at work (Eduroam @ 5 Ghz - no clue what specific hardware that is).
My FP 3 does only connect to the Repeater (only supporting 2.4 Ghz) but never to the router itself. disregarding of my distance to the repeater, even when i´m in close proximity to the router.

I tried to change the router settings as described in this threat and a similar one - however no change what so ever - i hoped for the update not change either.

i guess this issue is really related to the WiFi-chip in the FP 3 and the fritz.box as all other devices get along pretty neatly with the 5Ghz network and switching between access points.

Meaning … if you would limit the phone to the 2.4 GHz band the connection would be stable?

Settings - Network & Internet - Wi-Fi - Wi-Fi preferences - Advanced - Wi-Fi frequency band

After initial problems I have a stable 5 GHz connection to my 6490 Cable for some time now, so something must be amiss here.

Fritz!OS: 07.12
5 GHz channel: fixed to channel 36
5 GHz WiFi standard: 802.11n+ac

802.11n+ac was a problem for me at first, you can set that to 802.11n+a for testing.
Some update on the phone fixed 802.11n+ac for me, though.

Fairphone OS version: A.0110 (January 5 security patch level)

1 Like

Does your FP3 connect to the fritzbox after switching off the repeater?

Hi, my FP3 Wifi on Channel 116 was very flaky too. Fritzbox 7560 OS 7.12. On Original Android and on /e/ Version 0.9p2020051454091. Fixing 5GHz to Channel 52 did resolve the issue for me.
greeting, bodo

3 Likes

I had a Fritzbox 7581. The 5GHz could not connect to the FP3 or the FP2 of my friend.
Now I have a Fritzbox 7590 and the setting for the wifi channels is on automatic.
I get a very good signal on channel 100, so is the FP2. I am in Tilburg, the Netherlands.
I am on /e/. Didn’t have the Fritzbox 7590 when I was on orginal android.

Could reproduce
Fritzbox 7590 in an environment with several 2.4 GHz networks and very few 5 GHz networks.
Fairphone 3 on current patch level randomly lost wifi connection on channel 124 and 116, was being automatically steered to 2.4 GHz by the router. Switched 5 GHz Autochannel to 5 GHz channel 52 enforced and haven’t had a single drop since. I didn’t switch on the 160 MHz channel width though.

4 Likes

I also had this issue and pegged my router to a lower 5 GHz channel and it’s been happy since! Unfortunately it seems higher channels are default on public wifi, since those still get dropped and then “disabled” on 5 GHz.

I also can confirm that my WiFi seems more stable (still not perfect), with my 5GHz configured to use channel 52 on a new AVM FRITZ!Box 7590. Are there now opensource WLAN drivers we could integrate into the FP2/3 LoS builds @chrmhoffmann?

2 posts were split to a new topic: Fairphone 2 Wi-Fi reception drops using channel 120

Hi guys, I wanted to say I was having some issues with my internet connection, which became most apparent during internet calls. The test here may help you to see if your settings have improved your phone’s connection (see the response times).

Just for info. I have a FritzBox 7530
a) you can rename the 2.4GHz and 5GHz SSID so you can connect to either.
b) Eventually I disabled the 5GHz in the FritzBox settings and I have no problems with the 2.4GHz connection,
c) I do have to restart the phone if I switch wifi off on the phone which I imagine is a seperarte issue

I can’t believe I found this thread only now. I was puzzled because my FP3 used to have problems with 5Ghz on some days, but not on others. Obviously, my FritzBox 6490 selecting the channel automatically explains that. Today it was extremely unstable again, and lo and behold, channel 116. I’ve set it to channel 52 now, everything fine so far.

4 Likes

Just in case anyone wondered: Same problem with the new update 8901.3.A.0077.20201221 that was released yesterday. Channel 116 is super flaky/slow, so I’m back on channel 100 (switched from 52 to less crowded 100 a while ago).

PS: I’ve just upgraded from Android 9 to 10.