FP2 won't turn on - stuck in restart loop

I had the same symptoms as described above by @ingridgk (also nicely shown on her video):

  • reboot stuck at first screen
  • loss of access to recovery mode
    however, in my case, it wasn’t linked to a drained battery.

In that state (some call it hardbricked), the only solution is probably to flash the system afresh using binary images, BUT without access to recovery mode, that seems hardly possible (at least using fastboot and flashable images). Can anyone confirm/infirm that?

My solution: I called support and now will send my FP2 back for repair… (they answered my call within seconds :heart_eyes:)

but that was after a month waiting that they answer my support ticket… :angry:

here is how it started with me:

  • phone started to randomly reboot (especially with Google Maps), sometimes asking to enter my simcard PIN
  • phone went into The Boot Loop of Death… (optimizing a random num of apps each time)
  • left phone doing its thing overnight (plugged)
  • phone dead in the morning, not booting passed the first screen, rebooting… no battery led, no recovery mode

If it is a deep discharged battery, I am not 100% sure if it is a warranty case, but it is possible.
Options I think you have in the very short time:

  • Best would be to see if you can get a hold of your friend with the FP2 (asap), so you can check if it is the battery or the bottom module (I doubt anything else will be the problem).
  • Order a new battery. In case you get your original back alive or it will be replaced under warranty, you’ll have a spare battery. Assuming it is only the battery that is the problem, you can deal with anything else (e.g. warranty claim) later, but you’ll have a working phone for your trip.
  • Give Fairphone a call for immediate support and see what they recommend/can do.
  • As I wrote before, if you didn’t experience problems with charging earlier, and you use the same charger, I don’t think the bottom module is the problem. Still you can try to disassemble/reassemble the module. It is possible that the connection got loose for example from a fall or something similar, and thus doesn’t charge.

There could be many causes, so you yourself can only try to tackle all the different kinds in order to rule out it is not a faulty module:

  • Try to disassemble/reassemble the phone, in particular take off the display and clean the contact pins.
  • If this doesn’t solve the issue, you could try to go into the recovery and wipe the cache,
  • or hard-reset the phone.

If nothing helps, you may need to get it thoroughly checked at Fairphone to see if there is a faulty module.

Thanks I do appreciate your reply!

I actually tried to hard reset it two hours ago. I managed to enter the recovery mode and hard reset my FP2, but my FP2 still hasn’t turned on after hard reset. It is still in this restart loop of “Fairphone” logo > black screen > vibration > “Fairphone” logo.

I have just sent a request to customer support and hope to receive their reply soon.

Thanks for the input!

Now I’ve tried everything above except trying my friend’s bottom module (had the wrong screwdriver) + doing a factory reset, and my phone still doesn’t charge. However, I got to charge the battery for a bit in my friend’s phone, and when I put it back into my own phone, I noticed that the battery drained really fast (a percent every minutes or so). So it seems the problem is not only charging the phone. Does anyone think this could still be connected to the bottom module?

I called support, but they could only ask me to send a support request online, and also told me that it will definitely not be possible to fix my problem before I leave.

I guess I have two options:
a) order a new bottom module, hope I get it in time and that it actually fixes the problem
b) get a new (cheap) phone

As much as I really want to do the right thing and give FP another chance, I’m a bit tempted to just go straight to b) – it will probably cost me less money, and I will have a working phone tomorrow.

Thanks, ingridgk, for detailed description and video.

Same issue here since yesterday with following conditions:

  • cold & humid conditions (no direct contact with water, just in slightly damp pockets or bags - nothing unusual)
  • battery 80% charged
  • 1 day after replacing an empty battery (at 3%) with my spare full battery
  • after 2 weeks of use only in airplane mode
  • as described by langga, it does app updates, usually “X of 95” or “X of 136” - sometimes reaches full number, but then goes back to restart loop
  • same after disassembling (base - screen - battery), cleaning, drying & waiting for hours

I don’t feel like investing half a day in all these options, since most don’t seem to have worked for others. I think I’ll send it back to FAIRPHONE.

So this seems to be happening to a growing number of people… (5-10 on this thread alone) and all in the last 3-4 weeks (no such records on this forum prior to that). I wonder what is the cause of this and if FP support staff will have time to look into it.

GOOD LUCK TO EVERYONE! :wink:

I have the following environment:
Fairphone2 with the openOS and openGAPPS pico as I need some apps from the Playstore.
After the last update of the openOS I first had some error indications concerning the google environment, which I ignored, later on I got the restart loop as described by langga.

For my special case the following worked:
I managed to enter the teamwin environment, by pressing volume up and the power button simultaneously. As the phone was in the boot screen at this time, I had to press both buttons quite a long time (20 sec). In teamwin I installed the openGAPPS as decribed in the corresponding post. Now my phone works again without trouble. So both, the restart loop and the error indications vanished.

1 Like

UPDATE:
Fairphone answered me and said I have to send my phone in. They will replace it.
This is what I’m doing now.

Good look to all those who also face this problem!

1 Like

I’m still having the issue (and a ticket for it), but now I’ve had a weird phenomenon. When I booted the phone, I got the following boot screen:

I’ve never seen this before, because usually the boot screen looks like this:

I have no idea what caused this or what it means, but I’ve got the feeling that it’s not good. I wasn’t able to reproduce it though.

1 Like

Hi all,

Same rebooting loop problem here.

Have got in touch with Fairphone Support Team but no answer yet.

I can access the system recovery menu in order to perform a system reboot.

Has anyone already try it before? Was it successful?

Thanks a lot for your advices.

Quentin

EDIT : hard reset did not do anything

Hi all,

Same condition for me …
Wet conditions and phone discharged.

It was impossible at the beginning to charge it. After some hours it was ok but now the phone is stuck at the recovery menu.

If I remove the battery during some hours , the phone starts well but if I reboot it I’m stuck again in the recovery menu.

I will try to disassemble/reassemble the phone

Reassembling the phone was not useful.
The phone starts well if I remove the battery during a long time otherwise I have the recovery menu

Hi there! I seem to have a similar kind of problem. My FP2 suddenly crashed while I was using Messenger and didn’t turn on again. I tried several things (removing the battery and putting it back, doing a battery reset…). I got the phone to charge a few times (also blinking at first, signalling a deep-discharged battery even though it was charged at the beginning), but it mostly stayed stuck in a restart loop. I also try dismantling it. Now it doesn’t react to anything. The restart loop does not even appear anymore, nor the LED light. I must say I am pretty desperate!

Check if the battery sits tightly in the phone or if it can move slightly. You may need to put it a small piece of paper to make sure the battery doesn’t loose connection to the phone.
Then try the battery reset again (let the battery cool down first) and make sure you don’t try to boot (don’t press any buttons) until the LED turns green. The phone shouldn’t try to boot on it’s own, but only show the Fairphone screen shortly, followed by the charging animation.

Thanks for your input! I tried this a couple of time before and tried it again just now. So I dismantled and reassemble the phone again. The battery seems tight enough: I don’t think I could find the space to put a piece of paper. I let the battery cool down for about one hour and then put it to charge. The LED blinking light appeared for one minute or two (no Fairphone screen or charging animation). And then the light disappeared and the phone does not seem to charge. Pressing buttons won’t help. Is there anything else I can do besides sending my phone back?

Did you already try (many) different (high quality data) cables?

I have the same issue and I can state it is NOT caused by the battery. My battery was at 60% when android crashed and the FP2 went into the “reboot” loop. - My battery works fine in another FP2 - we have two FP2s here. - So do not waste time trying to figure out how to “solve” this issue, but send your FP in for repair.

I did try with 3 different chargers and 3 different cables and also plugging it into my laptop! The charger I used worked just fine before, but is probably not powerful enough for a deep-discharged battery (5V, 0,5A). The other chargers I used were more powerful (1,8A or 2A) but apart from the red LED light blinking for a few second, nothing happened. I contacted the support and they got back to me really quickly, advising me to do a hard reset. I think I will try to do that (even though I will lose all my data…) before trying to send it back.

Hello again,

A quick update from my bootloop issue:
Talked to FP support bcause nobody was answering my support ticket. They asked me to send my phone in. Sent my phone in some weeks ago.
This week I got the answer that my phone will be replaced completely without charging me any additional €

-> “Indeed, with this bootloop issue we are replacing phones completely. We
are still not sure what the root cause of this problem is, which is why
we want to be as sure as possible that our customers aren’t getting
their phones back with the same issue”

Really frustrating but FP support acted really quick and customer friendly.

So do not hesitate to call them, describe the problem and send your Fphone in.

all the best,

Max

3 Likes

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.