English

FP2 Won't turn on or charge - See first post for troubleshooting

Hi everyone,

I am having more ore less the same problem as the original poster Ridley: as of yesterday morning, my phone’s battery is empty and will not (really) recharge. As a result I am stuck in the first minute or so of the recharging process, no matter what I do.

Description:
When I recharge the phone on a cable, it will go down the following sequence, though it doesn’t always get to the end of it:

  • Red light starts blinking (maybe 30 seconds)
  • Red light stops, white-on-black Fairphone logo appears (10-20 seconds)
  • Shows the screen with the blue battery recharging
  • Shows dialog “Updating app 15 of 177”

Somewhere along this road, I will then see the red light blink, feel the phone vibrate, and we’ll be back to just having the blinking red light.

What’s odd is that the numbers in the dialog are always different. It may be “Updating app 15 of 177” and the next time it may be “Updating app 13 of 154”. For a while it seemed that the total number of apps was going down, so I thought “Goodie, if I just wait long enough it will get through this stuff eventually.” But then it went back to “Updating app 15 of 181”. That was a disappointment :slight_smile:

When I take out the battery and connect the power, the phone will go into a fast cycle of red light, showing the Fairphone logo, and rebooting. If I put the battery back in, that just brings it back to the longer cycle described above.

Elimination:

  1. I’ve used two different USB-to-phone cables that have both worked well for a long time, plus two different socket-to-phone rechargers. The USB cables I connected to power coming from my laptop, my powerbank, the USB port in my car, and a friend’s powerbank.
  2. I’ve tried the hardware reboot suggested in other posts. I haven’t got the impression that it has made any difference, but it could be that I’ve just made things worse and caused the device to want to update all my apps.
  3. I have never ever taken off my device’s screen, or even fiddled with the little blue locks. So I don’t see any reason to starting doing that now as a way of solving the battery recharge problem. I did try once to press the battery extra tight while recharging, but that didn’t help. And it really doesn’t feel like the battery is somehow loose, either.

What happened just before:
The problem appears to have started the night before. I noticed that recharging didn’t work anymore. I remember looking at the battery status graph and seeing a very steep decline on the morning of that day-before. I had the phone off for a while that day. I didn’t drop it.

My own theories:

I noticed that my previous phone (Google Nexus 5) developed “battery awareness” issues after I started using a power bank to recharge it. The device would think that it was fully charged when in fact it wasn’t. Could it be that the FP2 phone is also somehow getting confused by the power bank?

Best regards,
Wytze

Got the same problem. Blinking red light, then it seems to have enough juice to automatically start up the fairphone animation with slow blinking red light, after that it returns to its fast blinking red light.

@wytzeschouten and @Gerard_Peltjes: You both have a deeply discharged battery.

You need to perform the battery reset as described in the #batteryguide and then let it charge until the LED turns at least yellow (better wait for green).
It will take a long time from blinking red to solid red and then to yellow, but don’t try to boot until then.

If it continues to go back to blinking red on it’s own then your charger, cable, battery, bottom module or core module is defect or you have a connection issue between the modules.
Take them apart, clean the connectors and put everything back in order. If you can move the battery around in it’s place then fill the gaps with folded paper strips, so it sits tightly.
Then try the batteryreset again.

@wytzeschouten if after you charged the battery you get into a bootloop (the app optimization process restarts again and again) then please read this and continue there.

(not sure whether or not i am expected to make a new topic, my excuses if i am thrasing the OP)

I’ve already done the suggested methods over and over again. Except for disassembling the module, will try that this evening but i dont expect much of it.

As said, i dont have a choice too boot my phone or not. The phone boots up without my consent which causes it to go in to deep discharge modus. If i am lucky it does not, i try to turn it off but during the turn off period (with circling circle) it goes in that case back to deep discharge mode.

Looking at the amount of post regarding charging and views on those topics, it is not a cable or charger issue but a Fairphone hard/software issue.

Hi Paul, thanks for your quick answer. Turns out it was enough to have let the device rest (disconnected and terribly empty) for a night.

When I connected the device to the powerbank, it gently started the sequence of (1) blinking red light, (2) Fairphone logo, (3) blue battery recharging screen and then (4) dark screen with permanent red light, then (5) permanent yellow light. After an hour I powered it on and it went into the app update process. Which it merrily finished in half an hour. Then all was back to normal.

I do wonder how my phone got into this state. Two days ago when this began, it wasn’t just a matter of me letting the battery drain: even when the device was on, the battery refused to recharge. I could see the battery level drop, and no matter what power source I connected it to, it just did not recharge (it didn’t show the lightning symbol in the battery icon either). Powering the device off and on did not help either, I did that two or three times in the hours during which the battery just went down.

Could it be related to another problem my FP2 has been having on and off?

In the last two months, I’ve had moments where the device just suddenly shut down. Often during or after calls, or while taking photos or videos. But also while browsing or merely flicking through the screens of the Android/FP2 launcher itself. This happens about once a week, though sometimes it can be in quick succession.

Best regards,
Wytze

From support: "According to the repair report, the core module, bottom module and the battery of your phone have been replaced with brand new ones. "

If that’s true then it could be software. -

When I received the phone back from being repaired it immediately did a a software update. Is it it possible that the phone worked in the Fairphone lab on one software version and then broke after I updated it?

Here is the current state of my phone: I removed the battery from the phone for several hours. I put the battery back in and I see the blinking light. According to the #batteryguide the light should turn solid red after “some minutes”. On my phone the light goes dark after 30 seconds and stays dark.

If I press the on button then the light starts blinking again. After a minute the light goes dark, I see the battery charging icon followed by the Fairphone logo. After about 30 seconds the screen goes dark and the red light starts blinking again.

Sometimes it gets to the “Android is starting…” message box. It counts up to a number before turning off again.
"Optimising app 20 of 128"
"Optimising app 28 of 86"
“Optimising app 24 of 128”

Can anyone think what might be happening here?

1 Like

“Optimising app 23 of 79”

Is there any significance to these numbers?

That means either your brand new bottom module is having issues too or your charger or cable is not working right.

With the right hardware the LED should stay on while charging and the phone shouldn’t try to start booting on it’s own. So you shouldn’t get to the app optimization bootloop without pressing a button - which by the way is a separate issue described here.

I’ve tried multiple cables that work with other phones and the LED never goes solid.

The phone is now stuck in the boot loop. Should I stop it? The number of apps optimised is increasing slowly.

You can try going to #dic:recoverymode.
Just try and stay there for a while and see if the phone charges there (it’s definitely more battery-friendly then the app optimization process).

I just came back to it and I think it has finished the loop.

The LED is now solid yellow. The screen is dark.

I will leave it connected to the charger and see what happens.

Well look at that. My phone has booted and is charged.

It is still running 1.13.0 but says my operating system is up to date.

So it was a software issue that was causing the charging problem, possibly caused by a failed system update.

Are there log files that I can send to Fairphone? They might be useful.

Okay, my sister is having the same issues on her Fairphone 2.
It doesn’t boot up and neither does it properly charge. We’ve tried a number of different cables, too.
We can’t be sure whether it is the battery or the bottom module since don’t know any other FP2 owner to check. My sister now considers returning the phone, but would like to recover the data from it. Is there any way we can do this?
Thank you!

Have a look at local Fairphoners address book.
Perhaps there is somebody around to at least test your battery and bottom module.

feel your frustration. Happens to me a lot. Currency without a phone as taking for ever to charge up…any idea how long it should take?

Cool, thank you! The page seems to be private, though, I can’t access it.

Sorry, I made a mistake. The link is now working.

1 Like

Another report to same kind of issue:
My Fairphone is now 18 month old and looks like the bottom connector is the culprit.
It switches on but charging stops before 100% and sometimes there is quick charging/not charging state switching.
Tried several chargers, cables, a new battery from the shop, dissambling and cleaning the bottom module. No change. And fiddling with the connector finally allows the charge to start again, but I think it also breaks it more.

My last trial would be to change completely the bottom connector but the shop indicates it as ‘out of stock’ which might be a hint that many other fairphoners ordered this spare part or that the repair team are replacing this module often on returned pieces.

So I’ll wait until this part is available again, hoping that my connector will not die before :cold_sweat:

Indeed, the bottom connector is dying:
today dyring a call, the distant party did not hear me.

I checked with the Settings > Maintenance > Hardware diagnostic tool: the bottom mike was producing noise and not transmitting voice.
Again by fiddling and tapping on the bottom connector, it started to work again.

Seems that the connections are loose but I don’t know how to tighten them more, looks more difficult than the battery that I now keeps into place with a piece of paper…

Finally I opened a ticket to support describing exactly the issue and the tests I have performed and they sent me a bottom module.
Everything is OK now.