FP2 won't boot after OS change

So I’ve had Fairphone Open installed for a few months, but I signed up to work for deliveroo and sadly the app required Google Play Services, meaning I needed to change back to standard Fairphone OS. My Updater app didn’t have an option to install Fairphone OS so I backed up my files and did a factory reset. I then used the fastboot .zip recommended here (https://support.fairphone.com/hc/en-us/articles/207914363-Manually-install-Fairphone-OS-for-the-Fairphone-2). It completed and my phone started up but then got stuck on “Android is starting, Preparing settings” and did not fully boot. I left it for an hour or so then took the battery out. When I turned it on again it got stuck at the bit with the blue dots under the Fairphone logo. I left it for hours with no progress. I have tried redoing the fastboot >5 times, and have tried redownloading the fastboot .zip in case it was corrupted with no luck. Every time it gets stuck on the blue dots screen. I can’t put the phone into recovery mode - when I try it comes up with the android man on his back, with a red alert triangle on top. Can anyone please help me?

If you end up having to install from scratch, here’s a working way for Fairphone Open OS … post from some time ago, version numbers might be outdated …

1 Like

thanks for your help!

Will bear that in mind about adding to Open for next time

I don’t have a microSD, do you know of any other ways to use TWRP? if it comes to it I can get one but that’ll take a few days

Maybe this halps:


Managed to get a hold of an SD card but used both that how to as well @BeMiGro

Thanks to both of you, very relieved to have my phone back!

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.