FP2 Stuck in Powered by Android - no TWRP launch

Heyas Everyone, I desperately need your help… I wanted to switch my FP to lineage today and it seems that I f’ed my phone up completley. Status:
Phone starts into FAIRPHONE POWERD BY android screen and does nothing.
How I get there?
First I’ve tried to install lineage-15.1-20181217-microG-FP2 via TWRP, on the way I did a backup using TWRP, unfortunatelly the backup got lost, no idea how this happened though. I wiped Fairphone Open OS following this thread:

How to Install Lineage OS on FP2 for dummies

Unfortunatelly installing lineage didnt work out due to invalid zip verificaton (even when I disabled the verificaton before I started the install attempt) I have tried 20181210 & 20180808, both the same result. I tried to find FPOpenOS image or zip, couldnt find any and finally hit the reboot button in TWRP to see what happens; I ignored the warning about no OS installed, since I was sure I will end up in TWRP recovery again. Big fail, since then I can’t get pass the launch / logo screen.

Does anyone have an idea what to do? I’m heading to the mountains after christmas where I def need a working phone, I don’t care about which OS for now, I just want it to start again. Please help me to not spend my christmas days sitting infront of a screen trying dsperatley to fix my phone :frowning:

I’ve read all simmilar threads that I could find without any solution; about to give up after 4 hours of research and fix attemps now… Help?

Thanks a lot and merry christmas

My question may sound stupid, but are you pushing Vol+ and Power button to boot into TWRP?
If you push Vol- and Power button you will end up in fastboot mode which will cause the permanent logo screen.


Here’s how to install LineageOS on the Fairphone 2 … including installing the latest TWRP (Important!) …


This is a problem with the TWRP version currently bundled with Fairphone Open OS.
Installing the latest TWRP version fixes this.

Not stupid at all, thanks for your reply. Unfortunatelly I use vol+

Thank you, AnotherElk. I will give that a shot once I manage to get my phone booting again. I’ve seen on an external (not FP related) site that my TWRP might not be compatibel with the lineage version. Unfortunately I didn’t manage to get access to my TWRP at that point anymore.

reading this thread again it stroke me that it my problem could also be hardware related New Fairphone 2 stuck on "powered by Android" screen

while trying to install te new OS I observed abnormal behavior when it comes to charging the batterie. when plugged into a notebock, the charger symbol often just flickered between + and flash (charge icon), sometimes the battery got drained evvenmore although it was connected. I had to switch often between powersupply for chrging and the connection to the notebook for transmitting data. otherwise the phone went into energy savining rapidly or switched off.

maye the constant switch between plugin and off, notebook,charger, etc. hd caused some malefunctioning? I´ve tried different cables and was quite certain that the issue is the usb port which doesnt provid enought power, but maybe I was mistaken? what do you think?

current status: I removed the batterie over night; pluggin it in (no matter if with or without batterie only leads to the fairphone logo screen, LED is not lid at all)

totally fishing in the dark here

Ok, the guide assumes that Android is booted, but it doesn’t do anything with it other than rebooting into bootloader (aka Fastboot mode).

Point 3 of the guide states “You can also boot into fastboot mode via a key combination”

Just boot the phone into Fastboot mode (Volume - while starting, it will only display the Fairphone logo, there’s nothing more to it) and flash the latest TWRP, then continue with the guide from there.


AnotherElk, you’re my savior, thank you so much, can’t tell you how much joy you just brought to me :slight_smile: not just that you povided the solution to boot my phone again, you also linked me to the manual for installing the os, which I original started this oddysee for. With your link and fina push for looking closer into it the whole thing was done in a few minutes (just like I hoped in the beginning).

Thanks again,
much love